The \LaTeX\ User’s Guide

by the \LaTeX\ Team*

Version 2.2.x

April 20, 2017

*If you have comments on or error corrections to this documentation, please send them to the \LaTeX\ Documentation mailing list: lyx-docs@lists.lyx.org
Contents

1. Getting Started 1
   1.1. What is LyX? 1
   1.2. How LyX Looks 1
   1.3. HELP 2
   1.4. Basic LyX Setup 2
   1.5. \LaTeX{} Setup 2

2. How to work with LyX 3
   2.1. Basic File Operations 3
   2.2. Basic Editing Features 4
   2.3. Undo and Redo 5
   2.4. Mouse Operations 5
   2.5. Navigating 6
      2.5.1. The Outliner 6
      2.5.2. Horizontal Scrolling 7
   2.6. Input/Word Completion 8
   2.7. Basic Key Bindings 8

3. LyX Basics 11
   3.1. Document Types 11
      3.1.1. Introduction 11
      3.1.2. Document Classes 11
      3.1.3. Document Layout 15
      3.1.4. Paper Size and Orientation 15
      3.1.5. Margins 16
      3.1.6. Important Note 16
   3.2. Paragraph Indentation and Separation 16
      3.2.1. Introduction 16
      3.2.2. Paragraph Separation 17
      3.2.3. Fine-Tuning 17
      3.2.4. Line Spacing 17
   3.3. Paragraph Environments 17
      3.3.1. Overview 17
      3.3.2. Standard 18
      3.3.3. Document Title 18
      3.3.4. Headings 19
## Contents

4.2. Footnotes ............................................. 65  
4.3. Marginal Notes ........................................ 66  
4.4. Graphics and Images .................................... 66  
  4.4.1. Image Formats ...................................... 67  
  4.4.2. Grouping of Image Settings ......................... 68  
4.5. Tables .................................................... 68  
  4.5.1. Table Dialog ....................................... 68  
  4.5.2. Multi-page Tables .................................. 69  
  4.5.3. Table Cells ........................................ 72  
4.6. Floats .................................................... 72  
  4.6.1. Introduction ....................................... 72  
  4.6.2. Figure Floats ...................................... 73  
  4.6.3. Table Floats ....................................... 74  
  4.6.4. More Information .................................. 74  
4.7. Minipages ............................................... 75  

5. Mathematical Formulas ...................................... 77  
  5.1. Basic Math Editing .................................... 77  
  5.1.1. Navigating in Formulas ............................ 77  
  5.1.2. Selecting Text ..................................... 78  
  5.1.3. Exponents and Subscripts .......................... 78  
  5.1.4. Fractions .......................................... 78  
  5.1.5. Roots ............................................. 79  
  5.1.6. Operators with Limits ............................. 79  
  5.1.7. Math Symbols ..................................... 79  
  5.1.8. Altering Spacing .................................. 80  
  5.1.9. Functions ......................................... 80  
  5.1.10. Accents .......................................... 80  
  5.2. Brackets and Delimiters ............................... 81  
  5.3. Arrays and Multi-line Equations ...................... 82  
  5.4. Formula Numbering and Referencing .................. 83  
  5.5. User defined math macros ............................. 84  
  5.6. Fine-Tuning .......................................... 84  
  5.6.1. Typefaces ......................................... 84  
  5.6.2. Math Text ......................................... 85  
  5.6.3. Font Sizes ........................................ 85  
  5.7. AMS-\LaTeX ............................................ 86  
  5.7.1. Enabling AMS-Support ............................. 86  
  5.7.2. AMS-Formula Types ................................. 86  

6. More Tools .................................................. 87  
  6.1. Cross-References ..................................... 87  
  6.2. Table of Contents and other Listings ................ 89  
  6.2.1. Table of Contents ................................ 89
6.15. Thesaurus .............................................. 113
  6.15.1. Setting up the thesaurus .......................... 113
  6.15.2. Using the thesaurus .............................. 114
6.16. Change Tracking ...................................... 114
6.17. Comparison of Documents ............................. 115
6.18. International Support ................................. 116
  6.18.1. Language Options ................................ 116
  6.18.2. Keyboard mapping configuration ................. 116

A. The User Interface ...................................... 117
  A.1. The File Menu ....................................... 117
    A.1.1. New .............................................. 117
    A.1.2. New from Template .............................. 117
    A.1.3. Open .............................................. 117
    A.1.4. Open Recent .................................... 117
    A.1.5. Close .............................................. 117
    A.1.6. Close All ....................................... 118
    A.1.7. Save .............................................. 118
    A.1.8. Save As .......................................... 118
    A.1.9. Save All ......................................... 118
    A.1.10. Revert to saved .................................. 118
    A.1.11. Version Control ................................. 118
    A.1.12. Import ............................................ 118
    A.1.13. Export .......................................... 119
    A.1.14. Fax .............................................. 121
    A.1.15. New and Close Window ......................... 121
    A.1.16. Exit .............................................. 121
  A.2. The Edit Menu ....................................... 121
    A.2.1. Undo and Redo .................................... 121
    A.2.2. Cut, Copy, Paste, Paste Recent, Paste Special 121
    A.2.3. Select Whole Inset ............................... 121
    A.2.4. Select All ....................................... 121
    A.2.5. Find & Replace (Quick) .......................... 122
    A.2.6. Find & Replace (Advanced) ...................... 122
    A.2.7. Move Paragraph Up/Down .......................... 122
    A.2.8. Text Style ....................................... 122
    A.2.9. Paragraph Settings .............................. 122
    A.2.10. Table and Rows & Columns ..................... 122
    A.2.11. Dissolve Inset .................................. 122
    A.2.12. Settings or Math ................................ 122
    A.2.13. Increase/Decrease List Depth .................. 123
  A.3. The View Menu ..................................... 123
    A.3.1. Open/Close all Insets ........................... 123
Contents

A.3.2. Unfold/Fold Math Macros .......................... 123
A.3.3. Outline Pane ........................................ 123
A.3.4. Source Pane ......................................... 123
A.3.5. Messages Pane ...................................... 123
A.3.6. Toolbars ............................................. 124
A.3.7. Split View .......................................... 124
A.3.8. Close Current View ................................ 124
A.3.9. Fullscreen ......................................... 124
A.4. The Insert Menu ...................................... 124
A.4.1. Math ............................................... 124
A.4.2. Special Character .................................. 125
A.4.3. Formatting ......................................... 125
A.4.4. List/TOC ........................................... 126
A.4.5. Float ............................................... 126
A.4.6. Note ............................................... 126
A.4.7. Branch ............................................. 127
A.4.8. Custom Insets ..................................... 127
A.4.9. File ............................................... 127
A.4.10. Box ............................................... 127
A.4.11. Citation .......................................... 127
A.4.13. Label ............................................. 127
A.4.15. Index Entry ....................................... 128
A.4.16. Nomenclature Entry .............................. 128
A.4.17. Table ............................................ 128
A.4.18. Graphics ......................................... 128
A.4.19. URL ............................................... 128
A.4.20. Hyperlink ........................................ 128
A.4.21. Footnote ........................................ 128
A.4.22. Marginal Note .................................... 128
A.4.23. Short Title ....................................... 128
A.4.24. $\text{TeX}$ Code .................................. 129
A.4.25. Program Listing .................................. 129
A.4.26. Date ............................................. 129
A.4.27. Preview .......................................... 129
A.5. The Navigate Menu ................................... 129
A.5.1. Bookmarks ....................................... 129
A.5.2. Next Note, Change, Cross-reference .............. 129
A.5.3. Go to Label ....................................... 130
A.5.4. Forward Search .................................. 130
A.6. The Document Menu .................................. 130
A.6.1. Change Tracking .................................. 130
A.6.2. $\text{LaTeX}$ Log ................................... 130
Contents

C. The Preferences Dialog

C.1. Look and Feel
- C.1.1. User Interface
- C.1.2. Document Handling
- C.1.3. Screen Fonts
- C.1.4. Colors
- C.1.5. Display

C.2. Editing
- C.2.1. Control
- C.2.2. Shortcuts
- C.2.3. Keyboard/Mouse
- C.2.4. Input Completion

C.3. Paths

C.4. Identity

C.5. Language Settings
- C.5.1. Language
- C.5.2. Spellchecker

C.6. Outputs
- C.6.1. General
- C.6.2. \LaTeX

C.7. File Handling
- C.7.1. Converters
- C.7.2. File Formats

D. Units available in \LaTeX

E. Credits

Bibliography

Bibliography 2

Nomenclature

Index
1. Getting Started

1.1. What is LyX?

LyX is a document preparation system. It is a tool for producing beautiful manuscripts, publishable books, business letters and proposals, and even poetry. It is unlike most other “word processors” in the sense that it uses the paradigm of a markup language as its core editing style. That means that when you type a section header, you mark it as a “Section”, not as “Bold, 17 pt type, left justified, 5 mm space below”. LyX takes care of the typesetting for you; so you deal only with concepts, not with mechanics.

This philosophy is explained in greater detail in the Introduction manual. If you haven’t read it yet, you need to. Yes, we mean now.

The Introduction manual describes several things in addition to LyX’s philosophy: most importantly, the format of all of the manuals. If you don’t read it, you will have a bear of a time navigating this manual. You might also be better served looking in one of the other manuals instead of this one. The Introduction manual describes that, too.

1.2. How LyX Looks

Like most applications, LyX has the familiar menu bar across the top of its window. Below it is a toolbar with a pulldown box and various buttons. There is, of course, a vertical scrollbar and a main work area for editing documents.

Note that there is no horizontal scrollbar. This is not a bug or an oversight, but intentional. When you read a book, you expect the end of a line to wrap around to the next line. Text overflows onto new pages in a vertical fashion, hence the need for only a vertical scrollbar. There are three cases where you might want a horizontal scrollbar. The first case is large images. To avoid them being displayed larger than your screen, left click on the image and use the option Scale on Screen in the tab \LaTeX and LyX options. The second and third cases are tables and equations which are wider than the LyX window. You can use the arrow keys to scroll horizontally through the table, but this doesn’t work for equations yet.

For a brief description of all LyX menus and toolbar buttons, have a look at Appendix A.
1. Getting Started

1.3. HELP

The help system consists of the LyX manuals. You can read all of the manuals from inside LyX. Just select the manual you want to read from the Help menu.

1.4. Basic LyX Setup

Almost all features of LyX can be configured via the menu Tools $\rightarrow$ Preferences. LyX is able to inspect your system to see what programs, \LaTeX{} document classes and \LaTeX{} packages are available. It uses this knowledge to give reasonable defaults for the preferences settings. Although this configuration has already been done when LyX was installed on your system, you might have some items that you installed locally, e.g. new \LaTeX{} classes, and which are not seen by LyX. To force LyX to re-inspect your system, you should use Tools $\rightarrow$ Reconfigure. You should then restart LyX to ensure that the changes are taken into account.

1.5. \LaTeX{} Setup

You can edit documents in LyX without having \LaTeX{} installed, but you will not be able to create PDFs or print your documents unless you do have it installed. However, some LyX documents use DocBook as the “backend” that can produce PDFs and the like, and every LyX document can always be output as plain text or as XHTML.

Some document classes may depend upon specific \LaTeX{} or DocBook classes or packages. Such document classes can be used even if you do not have the required files installed, but you will not be able to produce certain kinds of output.

The \LaTeX{} packages that LyX has found on your system are listed in a file you can view from the menu Help $\rightarrow$ \LaTeX{} Configuration. If you are missing packages you need, then you must install them and then reconfigure LyX (menu Tools $\rightarrow$ Reconfigure). See section Installing new \LaTeX{} files of the Customization manual for more information on installing additional \LaTeX{} packages.
2. How to work with LyX

2.1. Basic File Operations

Under the File menu and in the standard toolbar are basic operations for any word processor in addition to some more advanced operations:

- New, Ctrl+N or 
- New from Template, Ctrl+Shift+N
- Open, Ctrl+O or 
- Open Recent
- Close, Ctrl+W
- Save, Ctrl+S or 
- Save As, Ctrl+Shift+S
- Revert to saved
- Exit, Ctrl+Q

They all do pretty much the same thing as in other word processors, with a few minor differences. The File\n\nNew from Template command lists the available templates. Selecting a template will automatically set certain layout features for the document, features you would otherwise need to change manually. They can be of use for certain classes, especially those for writing letters (see section 3.1.2).

**Note:** There is no “default file” or document named “Untitled” or “scratch.” Unless you tell LyX to open a file or create a new one, that big, blank space is just that — a big, blank space.

Revert to saved and Version Control are useful if more people work on the same document at the same time. Revert to saved will reload the document from disk. You can of course also use it if you regret that you changed a document and want to restore it to the last save. With Version Control you can register the changes you made to a document so that others can identify them as your changes.

---

1If you plan to do this, you should check out the Version Control feature in LyX also. Read Additional Features.
2. How to work with LyX

2.2. Basic Editing Features

Like most modern word processors, LyX can perform cut and paste operations on blocks of text, can move by character, word, or page of text, and can delete whole words as well as individual characters. The next four sections cover the basic LyX editing features and how to access them. We will start with cut and paste.

As you might expect, the Edit menu and the standard toolbar has the cut and paste commands, along with various other editing features. Some of these are special and covered in later sections. The basic ones are:

- Cut, Ctrl+X or ﬂ
- Copy, Ctrl+C or ﬂ
- Paste, Ctrl+V or ﬂ
- Paste Recent
- Paste Special
- Find & Replace, Ctrl+Shift+F or ﬂ

The first three are self-explanatory. You can also copy text between LyX and other programs by Cut, Copy and Paste. Cut and Copy put text in two versions into the clipboard (formatted and unformatted), so that other programs can choose the most suitable form. Paste supports formatted and unformatted text as well, and additionally graphics. It tries to interpret the clipboard contents in an intelligent way. For example if the clipboard contains text in the format of comma separated values (CSV) and the cursor is inside a table, the text will be pasted into individual cells. The submenu of Paste Recent shows you a list with the last strings you have pasted. You can insert one at the current cursor position by clicking on a list entry.

The submenu Paste Special contains optional items for specific formats, depending on the clipboard contents. These include HTML, EBfX, Linkback PDF\(^2\), PDF, PNG, JPEG and EMF. These menu items are useful if the clipboard contains the same contents in different formats, and you want to select one format explicitly. (E.g. some programs put an image into the clipboard as graphics and as a short text which is often meaningless.) The menu item Paste Special>Plain Text, Join Lines is equivalent to Paste, with the only difference that it acts on text only. It will insert the text in the clipboard so that the whole text is inserted as one paragraph. A new paragraph is only started when there is a blank line in the text. Without Join Lines the text is inserted as paragraphs where the line breaks of the text will start a new paragraph. This is for example useful to copy contents of tables from webpages to a table in LyX. The items Paste Special>Selection, Join Lines and Paste Special>Selection paste from the primary selection. This is normally the currently selected text.

\(^2\)OS X only
The Edit $\Rightarrow$ Find & Replace item opens the Find and Replace dialog. Once you have found a word or expression, LYX selects it. Hitting the Replace button replaces the selected text with the contents of the Replace with field. You can click the Find Next button to skip the current word. Hit Replace All to replace all occurrences of the text in the document automatically. The Case sensitive option can be used if you want the search to consider the case of the search word. If the toggle is set, searching for “Test” will not match the word “test”. The Match whole words only option can be used to force LYX to only find complete words, e.g., searching for “star” will not match “starlet”. LYX offers also an advanced Find & Replace feature that is described in section 6.13.

Things like notes, floats, etc. (the so called “insets”) can be dissolved. This means that the inset is deleted and its content is left as normal text. Dissolving an inset is done by setting the cursor to the beginning of an inset and pressing Backspace or by setting the cursor to the end and pressing Delete.

Using the shortcut Ctrl+A while the cursor is in normal text selects the whole document. When the cursor is inside an inset Ctrl+A selects the content of the inset. Using Ctrl+A consecutively will increase the selection to the whole inset and then to the whole document. The shortcut Ctrl+Alt+A selects the whole document in every case and puts the cursor to the end of the document.

2.3. Undo and Redo

If you make a mistake, you can easily recover from it. LYX has a large-capacity undo/redo buffer. Select Edit $\Rightarrow$ Undo or the toolbar button to undo some mistake. If you accidentally undo too much, use Edit $\Rightarrow$ Redo or the toolbar button to “undo the undo.” The undo mechanism is currently limited to 100 steps to minimize memory overhead.

Note that if you revert back all changes to arrive at the document as it was last saved, the “changed” status of the document is unfortunately not reset. This is a consequence of the 100 step undo limit mentioned above.

Undo and Redo work on almost everything in LYX. But they will not undo or redo text character by character, but by blocks of text.

2.4. Mouse Operations

These are the most basic mouse operations.

1. Motion
   - Click the left mouse button once anywhere in the edit window. The cursor moves to the text under the mouse.
2. How to work with \LaTeX

2. Selecting Text

- Hold down the left mouse button and drag the mouse. \LaTeX marks the text between the old and new mouse positions. Use Edit $\Rightarrow$ Copy to create a copy of the text in \LaTeX's buffer (and the clipboard).
- Re-position the cursor and then paste the text back into \LaTeX using Edit $\Rightarrow$ Paste.

3. Insets (Footnotes, Notes, Floats, etc.)

Right-click on them to set their properties. Also check the appropriate section of this manual for more details.

2.5. Navigating

\LaTeX offers you several ways to navigate in documents:

- The Navigate menu lists all sections of the document as submenu entries that you can click to jump to the corresponding document part.
- The “Outline”, which is accessed either by the menu View $\Rightarrow$ Outline Pane or by the toolbar button.
- You can set bookmarks in your document under Navigate $\Rightarrow$ Bookmarks and use the same menu to return to them. Note that bookmarks are saved between sessions.

The toolbar button (also Navigate $\Rightarrow$ Bookmarks $\Rightarrow$ Navigate Back) jumps to the position in the document where you recently changed something. This is useful when you have a large document and have navigated or scrolled to another document part to look for something, and want to go back to your last editing position.

By pressing the F5 key the cursor will be vertically centered in \LaTeX's main window.

2.5.1. The Outliner

In the pull-down box at the top of the outline window, you can choose between several different lists, including other TOC-like objects, such as lists of tables and figures, but also lists of footnotes, or labels and cross-references (see section 6.1), or notes, or citations (see section 6.5). Clicking on any of these will take you to the corresponding object in your document.

Right-clicking on elements in the Outline opens in many cases a context menu that will allow for direct modification of those elements. For example, with citations, the context menu allows you to open the citation dialog and to modify the citation.

The Filter field at the top allows you to restrict which entries appear in the outline. For example, if you are displaying the list of Labels and References and wish to see
only references to subsections, you can enter the text “sub” in the filter, and only
entries containing that text will be displayed.

At the bottom of the outline are several buttons and the like that allow you further to
control the display. The Sort option sorts the current list alphabetically. Otherwise,
the elements appear in the order in which they occur in the document. The Keep
option keeps it in the current view state. Keeping means that when you have, for
example, the subsections of sections 2 and 4 displayed and click on section 3, the
subsection of sections 2 and 4 will still be displayed. Without the Keep option they
will be hidden to highlight the clicked section 3. Finally, the slider at the left can be
used to open the Outline to a given “depth”. It is best just to experiment with it to see how it works.

The button refreshes the TOC (though this should not usually be necessary).
Next to it are buttons that allow you to change the position of sections in your
document. The and buttons move sections up and down in the document. So,
for example, you can move section 2.5 before section 2.4 or after section 2.6. will then automatically rearrange the sections to the new order. With the buttons and (or the corresponding key bindings Tab and Shift-Tab) you can change the level of sections. So you can for example make section 2.5 chapter 3 or subsection 2.4.1.

By right-clicking on a section in the outliner you can select the whole section to copy,
cut or delete it.

2.5.2. Horizontal Scrolling

LyX does not have a horizontal scrollbar because the standard output page formats
like e.g. ISO A4 are less wide than PC or laptop screens. Therefore you will get
troubles in the output of your document if document parts exceed the width of the
LyX main screen.

There are of course exceptions where horizontal scrolling is necessary. For example

- LyX is used on a small tablet computer
- Wide tables that are rotated $90^\circ$ to fit a whole page\(^3\)
- Math constructs with long command names

For these cases LyX has an mechanism that scrolls automatically when the cursor is
moved. As example shrink the LyX windows so that table 2.1 is wider. You will now see a dotted red line at the right or the left side of the table. Put the cursor into the
table and move it with the Tab or the arrow keys to see the horizontal scrolling of
the table.

\(^3\)See section Rotated Floats of the Embedded Objects manual.
2. How to work with LyX

Table 2.1.: Horizontal scrolling test.

| a | b | c |

2.6. Input/Word Completion

LyX provides completion of words by scanning all documents that are currently opened. Every word that appears in these documents is added to a database that is used to propose completions.

Input completion can be activated in the LyX preferences (menu Tools ▶ Preferences) in the section Editing ▶ Input Completion. With the option Automatic inline completion the proposed completion is shown directly after the cursor. With the option Automatic popup the completions are always shown in a popup. The cursor completion indicator can be turned off by deselecting the option Cursor indicator. With the general options you can define the delay time for the inline and popup completion, you can set the minimal number of characters a word must have that it will be taken into account for a completion and you can choose if long completions should be abbreviated.

LyX displays a small triangle after the cursor as an indicator that there are completions available. Press the Tab key to accept a proposed completion. If several completions are possible, a popup is opened showing them. You can select a completion in the popup using the mouse or the arrow keys, and accept the chosen completion by pressing Return.

The completion options for math in the preferences do the same as the corresponding options for text. The special math option Autocorrection enables characters to be composed. If, for example, you want to insert the character $\Rightarrow$, you can then input the characters “$=>$” to a formula to get it. So this is a quick alternative to the insertion of commands or the use of the math toolbar. A list with supported character combinations can be found in the file autocorrect that is in LyX’s installation folder. Math autocorrection can at any time be turned on by pressing the exclamation mark “!” . Pressing Space turns it off.

2.7. Basic Key Bindings

There are at least two different primary binding maps: cua and emacs. LyX’s default is cua, which can be changed in the LyX preferences under Editing ▶ Shortcuts. (You can list or change any key bindings as explained in section C.2.2.1.)

Some keys, like Page Up, Page Down, Left, Right, Up and Down, do exactly what you expect them to do. Other keys don’t:
Tab

There is no such thing as a tab stop in \LaTeX. If you do not understand this, go read sections 3.2.1 and 3.3, especially section 3.3.6, right now. Yes, right now. If you are still confused, look in the Tutorial.

In \LaTeX the Tab key is only used to accept proposed input completions, to move the cursor in tables or math matrices or to change the nesting level in Itemize or Enumerate.

Esc

This is the “cancel key.” It is used, generically, to cancel operations. Other parts of the manual will go into greater detail about this.

Home and End These move the cursor, respectively, to the beginning and end of a line, unless you are using the Emacs bindings where they jump to the beginning or end of the file.

There are three modifier keys:

Control

(Denoted by “Ctrl” in the documentation files) This has a couple of different uses, depending on which keys it is used in combination with:

• Backspace or Delete, it deletes an entire word instead of a single character.

• Left and Right, it moves by words instead of characters.

• Home and End, it moves to the beginning and the end of the document, respectively.

Shift

(Denoted by “Shift” in the documentation files) Use this with any of the arrow keys to select the text between the old and new cursor positions.

Alt

(Denoted by “Alt” in the documentation files) This is the Alt key on many keyboards, unless your keyboard has a distinct Meta key. If you have both keys, you will need to try out which one actually performs the Alt+ function.

This key does many different things, but it also activates the menu accelerator keys. If you use this in combination with any of the underlined letters in a menu or menu item, it selects that menu item.

For example, the sequence “Alt e s c” brings up the “Text Style” dialog. Typing “Alt f” opens the File menu.

The Shortcuts manual lists all other things bound to the Alt key.

You will learn more and more key bindings and short-cut keys as you use \LaTeX, because most actions will prompt a small message in the status bar at the bottom of \LaTeX’s main window which describes the name of the action you have just triggered, and any existing key bindings for that action. The \LaTeX menus also list the defined key bindings. The notation for the key bindings is very similar to the notation used in this documentation, so you should not have any problems understanding it. However, notice that Shift-modifiers are explicitly mentioned, so “Alt+P Shift+A” means Alt+P followed by a capital A.
3. **LyX Basics**

3.1. **Document Types**

3.1.1. **Introduction**

Before you do anything else, before you ever start writing a document, you need to decide what type of document you want to edit. Different types of documents use different types of spacing, headings, numbering schemes, and so on. Additionally, different documents use different paragraph environments, and format the title of your document differently.

A *document class* describes a group of properties common to a particular set of documents. By setting the document class, you automatically select these properties, making it easier to create the type of document you want. If you don’t choose a document class, LyX picks one for you by default. So it is up to you to change the class of your document.

3.1.2. **Document Classes**

You can select a class using the Document > Settings > Document Class dialog. Select the class you want to use, and make any fine tunings of the options you may need.

3.1.2.1. **Overview**

There are four standard document classes in LyX. They are:

- **Article** for basic articles
- **Report** for basic reports
- **Book** for writing a book
- **Letter** for US-style letters

There are also some non-standard classes, which LyX only uses if you have installed the corresponding \LaTeX\ class files, though most \LaTeX\ distributions will include many of these. Here are some of the classes. The full list with detailed explanations can be found in chapter *Special Document Classes* in the *Additional Features* manual:
3. \LaTeX{} Basics

A&A Journal articles in the style and format used in Astronomy & Astrophysics

ACS For submissions to the journals published by the American Chemistry Society

AGU For submissions to the journals published by the American Geophysical Union

AMS Layouts for articles and books in the style and format used by the American Mathematical Society (AMS). There are three article layouts available. The standard one uses a typical numbering scheme for theorems etc., that prepends the section number to the number of the result. All result-type statements (propositions, corollaries, and so on) are sequenced together, but definitions, examples, and the like have their own sequence. The “sequential numbering” scheme does not place the section number with each result, but numbers them throughout the article in a single sequence. Each type of result gets its own sequence. There is also a layout that dispenses with numbering of statements altogether.

Beamer Layout for presentations

Broadway Layout for writing plays. It is not an existing \LaTeX{} document class, but a new one that is distributed with \LaTeX{}.

Chess Layout to write about chess games

Curriculum vitae classes to create curriculum vitae

Elsarticle Layout for journals of the Elsevier publishing group

Foils Used to make transparencies

Hollywood Used to type spec scripts for the US film industry. It is not an existing \LaTeX{} document class, but a new one that is distributed with \LaTeX{}.

IEEEtran Layout for the journals published by the Institute of Electrical and Electronics Engineers (IEEE)

IOP Layout for journals of the Institute of Physics publishing group

Kluwer Layout for journals of the Kluwer publishing group

KOMA-Script a replacement for the standard classes, offers many useful features like caption formatting, automatic print space calculation etc. (Is used by this document.)

Memoir another replacement for the standard classes

Powerdot Layout for presentations

REVTeX is used to write articles for the publications of the American Physical Society (APS), American Institute of Physics (AIP), and Optical Society of America (OSA). This class is not completely compatible with all \LaTeX{} features.

Slides Used to make transparencies

SPIE Proceedings Layout for the journals published by The International Society for Optical Engineering (SPIE)
Springer  Layouts for journals of the Springer publishing group

We will not go into detail about how to use these different document classes here. You can find details about the non-standard classes in chapter *Special Document Classes* of the *Additional Features* manual. Here, we will settle for a list of some of the common properties of all of the document classes.

### 3.1.2.2. Availability

You will probably find that many of the document classes listed under *Document* ➤ *Settings* ➤ *Document Class* are marked as “Unavailable”. If you open a document that uses such a class, you will receive a warning saying that there are files that are required to produce output that are not installed. So it may seem that something is wrong.

Nothing is wrong. LYX includes many more document classes than you will ever need to use, and some of them, like IOP, are highly specialized. LYX tries to support as many different types of documents as possible, and it includes almost one hundred different layout files, with a growing number. No \TeX{} distribution will install by default all files that might be needed by some document class. There are just too many of them. That is why some of the document classes are unavailable.

If there is a document class you would like to use that is marked as “Unavailable”, you just need to install the appropriate package files. The easiest way to find out which files you need to install is to use that document class for a new file. LYX will display a dialog that will list the missing files. See section *Installing new \TeX{} files* in of the *Customization* manual for information on how to install them.

Although LYX provides support for many different sorts of documents, it does not include support for every document class people might want to use. For example, many universities provide \TeX{} class files to be used for dissertations submitted to those universities. The LYX team cannot write layout files to support every one of these. There are too many. Fortunately, users can write their own layout files, and many users have done so. Chapter *Installing New Document Classes, Layouts, and Templates* of the *Customization* manual contains information on how to create layout files.

### 3.1.2.3. Modules

Modules load additional features that are not by default available in the chosen document class. For example you might want to write Braille (embossed printing) in a document. This is not available in any document class, so you have to load the corresponding module in the **Modules** section of the *Document* ➤ *Settings* dialog. Highlighting a module in the dialog will bring up a description of what it does.
Some modules require \TeX\ packages or file format converters that are not always installed by default. \LaTeX{} will warn you if you do not have a required package or converter, and it will tell you what exactly you are missing. You can still use the module while editing your file, but you will not be able to export to PDF or print your document, since \LaTeX{} will not be able to compile the \TeX{} file without the missing prerequisites. If you want to be able to produce this kind of output, then you need to install the missing prerequisites and then reconfigure \LaTeX{} by selecting Tools \textgreater{} Reconfigure. See section Installing new \TeX{} files of the \textit{Customization} manual for more information on installing required packages.

**Note:** Some modules require other modules, and some pairs of modules are incompatible. \LaTeX{} will advise you about these things.

### 3.1.2.4. Local Layout

Modules are to \LaTeX{} much as packages are to \TeX{}: They are intended to be used in a variety of different documents. If you often find yourself needing the same sort of thing in different documents, you should consider writing a module for this purpose. Sometimes, however, a particular document has very special needs, but you need a specific inset or character style only that one time. You want something that is like a document's own \TeX{} preamble. What you want is \LaTeX{}'s “Local Layout”. See section \textit{Local Layout} of the \textit{Customization} manual for information on how to use it.

### 3.1.2.5. Properties

Each class has a default set of options. Here’s a quick table describing them:

<table>
<thead>
<tr>
<th></th>
<th>Page style</th>
<th>Sides</th>
<th>Columns</th>
<th>Max. sectioning level</th>
</tr>
</thead>
<tbody>
<tr>
<td>article</td>
<td>Plain</td>
<td>One</td>
<td>One</td>
<td>Section</td>
</tr>
<tr>
<td>report</td>
<td>Plain</td>
<td>One</td>
<td>One</td>
<td>Chapter</td>
</tr>
<tr>
<td>book</td>
<td>Headings</td>
<td>Two</td>
<td>One</td>
<td>Chapter</td>
</tr>
<tr>
<td>letter</td>
<td>Plain</td>
<td>One</td>
<td>One</td>
<td>none</td>
</tr>
</tbody>
</table>

You’re probably also wondering what “Max. sectioning level” means. There are several paragraph environments used to create section headings. Different document classes allow different types of section headings. Only two use the Chapter heading; the rest do not and begin instead with the Section heading. Some document classes, such as the ones for letters, don’t use any section headings. In addition to Chapter and Section headings, there are also Subsection headings, Subsubsection headings, and so on. We will describe these headings fully in section 3.3.4.
3.1.3. Document Layout

The most important properties of document classes are set in the menu Document > Settings. There in the Class options field under Documents Class, you can enter special options for your document class in a comma-separated list. This is only necessary if LyX doesn’t support special options you want to use for your document. To learn more about your favorite \LaTeX-class and its options, you have to read its manual.

The drop box Headings style in the Document > Settings dialog under Page Layout controls what sorts of headings and page numbers go on a page. You can choose between the following five options:

- **Default**: Use default page style of current class.
- **empty**: No page numbers or headings.
- **plain**: Page numbers only.
- **headings**: Page numbers and either the current chapter or section title and number. Whether LyX uses the current chapter or the current section depends on the maximum sectioning level of the class.
- **fancy**: This allows you to define fully customizable headers and footers if you have the \LaTeX-package \texttt{fancyhdr} installed. How they are defined is explained in section 6.11.

The separation of paragraphs is described in section 3.2.2.

3.1.4. Paper Size and Orientation

You can find the following options in the menu Page Layout of the Document > Settings dialog:

- **Paper Format**: What size paper to print on. The choices are
  - Default
  - A0 – A6
  - B0 – B6
  - C0 – C6
  - JIS B0 – JIS B6
  - Custom

- **Orientation**: To choose whether to output as Landscape or as Portrait.

- **Two-sided document**: Adjusts the print space to print both sides of paper. That means that the print space for odd- and even-numbered pages is different.
3. **LyX Basics**

3.1.5. **Margins**

Paper margins are set in the menu **Document > Settings**.

If you use a KOMA-Script document class, you can use the default settings because KOMA-Script calculates the print space automatically by taking the paper format and the font size into account.

3.1.6. **Important Note**

If you change a document class, LyX has to convert *everything* into the new class. That includes the paragraph environments. Some paragraph environments are standard, in so far as all of the document classes have them; but some classes have special paragraph environments. If this is the case, and you change the document class, LyX will mark the paragraphs whose styles it no longer understands as “unknown”. The name of the style is retained, in case you should want to go back to the old class. But these paragraphs will be output with no special formatting, so you will either need to create a new style yourself or else convert these paragraphs manually to a style present in your new document class.

3.2. **Paragraph Indentation and Separation**

3.2.1. **Introduction**

Before describing all of the various paragraph environments, we’d like to say a word or two about paragraph indentation.

Everyone seems to have their own convention for separating paragraphs. Most Americans indent the first line of a paragraph. Others don’t indent but put extra space between the paragraphs. If you choose indentation for paragraphs the *first* paragraph of a section, or after a figure, an equation, a table, a list, etc., is *not* indented. Only a paragraph following another paragraph gets indented. Note that the indentation behavior is different when you use another document language than English. LaTeX takes care that the indentation follows the rules of the language used.

The space between paragraphs, like the line spacing, the space between headings and text — in fact, all the spacing for just about everything —is pre-coded into LyX. As we said, you don’t worry about how much space to add between what. LyX takes care of that. In fact, these pre-coded vertical spacings aren’t a single number but a range. That way, LyX can squish or stretch the space between lines to make sure figures fit on a page with text, so that sections don’t start at the bottom of a page, and so on.\(^1\) However, pre-coded doesn’t mean you can’t change them. LyX gives

\(^1\)LaTeX does this when LyX goes to produce a printable file.
you the ability globally to change all these pre-coded spacings. We will explain more later.

3.2.2. Paragraph Separation

Select Indentation or Vertical space in the submenu Text Layout of the dialog Document ▷ Settings to indent paragraphs or to add extra space between paragraphs, respectively.

3.2.3. Fine-Tuning

You can also change the separation method of a single paragraph. Open the Edit ▷ Paragraph Settings dialog and toggle the Indent Paragraph option to change the state of the current paragraph (shortcut Alt+A 1). If paragraphs have no indentation but use extra space for separation, this button will be ignored (you can’t indent a single paragraph by toggling this).

You should only need to change the indentation method for a single paragraph if you need to do some fine-tuning.

3.2.4. Line Spacing

In the Document ▷ Settings dialog you can set the line spacing for the whole document in the submenu Text Layout. You can set it for a single paragraph in the Edit ▷ Paragraph Settings dialog but this should be used very exceptionally because vertical spacing is normally defined in the environment’s style.

3.3. Paragraph Environments

3.3.1. Overview

Paragraph environments correspond to the

\begin{environment} ... \end{environment}

command sequence in \LaTeX files. If you don’t know \LaTeX, or the concept of a paragraph environment is totally alien to you, we urge you to read the Tutorial. The Tutorial also contains many more examples than this section does.

A paragraph environment is simply a “container” for a paragraph which gives that paragraph certain properties. This can include a particular style of font, different

---

2 You need to have the \LaTeX-package \texttt{setspace} installed to use this feature.
margins, a numbering scheme, labels, and so on. Additionally, you can “nest” the different environments inside one another, allowing one environment to inherit some of the properties of another. The different paragraph environments totally replace the need for messy tab stops, on the fly margin adjustment, and other hangovers from the days of typewriters. There are several paragraph environments that are specific to a particular document type. We will only be covering the most common ones here.

To choose a new paragraph environment, use the pull-down box at the left end of the toolbar. \textsc{LyX} will change the environment of the entire paragraph in which the cursor sits. You can also change the environment of an entire group of paragraphs if you select them before choosing the new environment.

Note that entering \texttt{Return} will \textit{typically} create a new paragraph using the \texttt{Standard} paragraph environment. We say “typically” because if you are in one of these environments:

- Quote
- Quotation
- Verse
- Itemize
- Enumerate
- Description
- List

\textsc{LyX} keeps the old paragraph environment when you enter \texttt{Return}, rather than resetting it to \texttt{Standard}. Also the nesting depth is preserved (for more on nesting see section 3.4).

3.3.2. Standard

The default paragraph environment is \texttt{Standard} for most classes. It creates a plain paragraph. If \textsc{LyX} resets the paragraph environment, this is the one it chooses. In fact, the paragraph you’re reading right now (and most of the ones in this manual) are in the \texttt{Standard} environment.

You can nest a paragraph using the \texttt{Standard} environment in just about anything else, but you can’t really nest anything in a \texttt{Standard} environment.

3.3.3. Document Title

A \texttt{\LaTeX} title page has three parts: the title itself, the name(s) of the author(s) and a “footnote” for thanks or contact information. For certain types of documents, \texttt{\LaTeX}
places all of this on a separate page along with today’s date. For other types of documents, the title “page” goes at the top of the first page of the document.

\LaTeX\ provides an interface to the title page commands through the paragraph environments \texttt{Title}, \texttt{Author}, and \texttt{Date}. Here’s how you use them:

- Put the title of your document in the \texttt{Title} environment.
- Put the author name in the \texttt{Author} environment.
- If you want the date to have a certain appearance, want to use a fixed date, or want other text to appear in place of today’s date, put that text in the \texttt{Date} environment. Note that using this environment is optional. If you don’t provide any, \LaTeX\ will automatically insert today’s date. If you don’t want a date, use the option \texttt{Suppress default date on front page} in the menu \texttt{Document} \rightarrow \texttt{Settings} \rightarrow \texttt{Document class}.

You can use footnotes to insert “thanks” or contact information.

### 3.3.4. Headings

There are several paragraph environments for producing section headings. \LaTeX\ takes care of the numbering for you.

#### 3.3.4.1. Numbered Headings

There are 7 numbered types of section headings. They are:

1. Part
2. Chapter
3. Section
4. Subsection
5. Subsubsection
6. Paragraph
7. Subparagraph

\LaTeX\ labels each heading with a series of numbers, separated by periods. The numbers describe where in the document you are. Unlike the other headings, parts are numbered with Latin letters.

Headings all subdivide your document into different pieces of text. For example, suppose you’re writing a book. You group the book into chapters. \LaTeX\ does a similar grouping:

- Part is divided into either \texttt{Chapters} or \texttt{Sections}
3. LyX Basics

- Chapters are divided into Sections
- Sections are divided into Subsections
- Subsections are divided into Subsubsections
- Subsubsections are divided into Paragraphs
- Paragraphs are divided into Subparagraphs

**Note:** Not all document types use the Chapter heading as the maximum sectioning level. In that case the Section is the top-level heading.

So, if you use the Subsubsection environment to label a new sub-subsection, LyX labels it with its number, along with the number of the subsection, section and, if applicable, chapter that it’s in. For example: the fifth section of the second chapter of this book has the label “2.5”.

### 3.3.4.2. Unnumbered Headings

The unnumbered section headings have a “*” at the end of their name. They work the same as their numbered counterparts but will not appear in the table of contents, see section 6.2.

### 3.3.4.3. Changing the Numbering

You can also alter which sectioning levels get numbered and which ones appear in the Table of Contents. Now, this doesn’t remove any of the levels; that’s preset in the document class. Just as certain classes start with Chapter and go down to the Subparagraph level. Others start at Section. Similarly, not all document classes number all sectioning levels. Most don’t number Paragraph or Subparagraph. This is something you can change.

Open the **Document** > **Settings** dialog. Under **Numbering & TOC** you will see two counters. The one named **Numbering** controls how far down in the sectioning hierarchy LyX numbers a section heading. The other one controls the appearance of the section headings in the table of contents.

### 3.3.4.4. Short Titles of Headings

Some section or chapter titles, such as this one, can get quite long. This can cause trouble when there is limited horizontal space. For example, if the header of the page is set to show the current section title, a long title will protrude over the page margins and look awful.

LyX allows you to specify a short title for section headings. This short title is used in the header and in the actual table of contents, avoiding the problem mentioned.
To specify a short title, set the cursor behind the title and use the menu Insert→Short Title. This will insert a box labeled “Short Title” which you can use to enter the short title text. This also works for captions inside floats. There can only be one short title per title.

The title of this section is a good example of using this feature.

### 3.3.4.5. Special Information

The following information applies to all section headings:

- You cannot do any nesting with these environments.
- You cannot use a margin note in any of these environments.
- You can only use inline math in these environments.
- You can use labels and cross-references to refer to their numbers.

### 3.3.5. Quotes and Poetry

\LaTeX{} has three paragraph environments for writing poetry and quotations. They are Quote, Quotation, and Verse. Forget the days of changing line spacing and twiddling with margins. These three paragraph environments already have those changes built-in. They all widen the left margin and add a bit of extra space above and below the text they contain. They also allow nesting, so you can put a Verse in a Quotation, as well as in some other paragraph environments.

There is another feature of these three paragraph environments: they do not reset to Standard when you start a new paragraph. So, you can type in that poem and merrily enter Return without worrying about the paragraph environment changing on you. Of course, that means that, once you are done typing in that poem, you have to change back to the Standard environment yourself.

#### 3.3.5.1. Quote and Quotation

Now that we’ve described the similarities of these three environments, it’s time for the differences. Quote and Quotation are identical except for one difference: Quote uses extra spacing to separate paragraphs and never indents the first line. Quotation always indents the first line of a paragraph and uses the same line spacing throughout.

Here’s an example of the Quote environment:

```latex
This is in the Quote environment. I can keep writing, extending this line out further and further until it wraps. See – no indentation!

Here’s the second paragraph of this quote. Again, there’s no indentation, but there is extra space between me and the other paragraph.
```
3. LyX Basics

Here’s another example, this time in the Quotation environment:

This is in the Quotation environment. If I keep writing, you will see the indentation. If your country uses a writing style that indicates new paragraphs by indenting the first line, then Quotation is the environment for you! Well, you’d use it if you were quoting other text.

Here’s a new paragraph. I could ramble on and on, like a politician at election time. If I did that, though, you’d get bored.

As the examples show, Quote is for those people who use extra space to separate paragraphs. They should put quotes in the Quote environment. Those who use indentation to mark a new paragraph should use the Quotation paragraph environment for quoted text.

3.3.5.2. Verse

Verse is a paragraph environment for poetry, rhymes, verses, and so on. Here’s an example:

This is in Verse
Which I did not rehearse!

It could be much worse. This line could be long, very long, oh so long, so very long that it wraps around. It looks okay on screen, but in the printed version, the extra lines are indented a bit more than the first.

Okay, so it’s turned to prose and doesn’t rhyme anymore. So sue me.

To break a line
And make things look fine
Use Ctrl+Return.

As you can see, Verse does not indent both margins. Each stanza of the verse or poem is in its own paragraph. To separate the individual lines of a stanza, use the shortcut Ctrl+Return.

3.3.6. Lists

LyX has four different paragraph environments for creating different kinds of lists. In the Itemize and Enumerate environments, LyX labels your list items with bullets or numbers, respectively. In the Description and List environments, LyX lets you provide your own label. We will present the individual details of each type of list next after describing some general features of all four of them.

3.3.6.1. General Features

The four paragraph environments for lists differ from the other environments in several ways. First, LyX treats each paragraph as a list item. Hitting Return does not
reset the environment to Standard but keeps the current environment and creates a new list item. The nesting depth is thereby kept. If you want to keep the paragraph environment but reset the current nesting depth, you can use Alt+Return. If you do this at the top level of a list, it returns you to the Standard environment.

You can nest lists of any type inside one another. In fact, \LaTeX{} changes the labels on some list items depending on how it is nested. If you intend to use any of the list paragraph environments, we suggest you read all of section 3.4.

### 3.3.6.2. Itemize

The first type of list we will describe in detail is the Itemize paragraph environment. It has the following properties:

- Each item has a particular bullet or symbol as its label.
  - \LaTeX{} uses the same symbol for all of the items in a given nesting level.
  - The symbol appears at the beginning of the first line.
- The items can have any length. \LaTeX{} automatically offsets the left margin of each item. The offset is always relative to whatever environment the Itemize list may be in.
- If you nest an Itemize environment inside another Itemize environment, the label changes to a new symbol.
  - There are four different symbols for up to a four-fold nesting.
  - \LaTeX{} always shows the same symbol on screen.
  - See section 3.4 for a full explanation of nesting.

Of course, that explanation was also an example of an Itemize list. The Itemize environment is best suited for lists where the order doesn’t matter.

We said that different levels use different symbols as their label. Here’s an example of all four possible symbols.

- The label for the first level Itemize is a large black dot, or bullet.
  - The label for the second level is a dash.
    * The label for the third is an asterisk.
      - The label for the fourth is a centered dot.
    * Back out to the third level.
  - Back to the second level.
- Back to the outermost level.
3. **LyX Basics**

These are the default labels for an *Itemize* list. You can customize how these labels are displayed in the output in the *Document > Settings* dialog in the submenu *Bullets*. These customizations are not displayed in **LyX**.

Notice how the space between items decreases with increasing depth. We will explain nesting and all the tricks you can do with different depths in section 3.4.

### 3.3.6.3. *Enumerate*

The *Enumerate* environment is used to create numbered lists and outlines. It has these properties:

1. Each item has a numeral as its label.
   a) The label type depends on the nesting depth.
2. **LyX** automatically counts the items for you and updates the label as appropriate.
3. Each new *Enumerate* environment resets the counter to one.
4. Like the *Itemize* environment, the *Enumerate* environment:
   a) Offsets the items relative to the left margin. Items can have any length.
   b) Reduces the space between items as the nesting depth increases.
   c) Uses different types of labels depending on the nesting depth.
   d) Allows up to a four-fold nesting.

Unlike the *Itemize* environment, *Enumerate* shows the different labels for each item in **LyX**. Here is how **LyX** labels the four different levels in an *Enumerate*:

1. The first level of an *Enumerate* uses Arabic numerals followed by a period.
   a) The second level uses lower case letters surrounded by parentheses.
      i. The third level uses lower-case Roman numerals followed by a period.
         A. The fourth level uses capital letters followed by a period.
         B. Again, notice the decrease in the spacing between items as the nesting depth increases.
      ii. Back to the third level
   b) Back to the second level.
2. Back to the outermost level.

You can customize the type of numbering used in the *Enumerate* environment, see section 3.3.7. Such customization only shows up in the printed version, not in **LyX**.

There is more to nesting *Enumerate* environments than we’ve stated here. You should read section 3.4 to learn more about nesting.
3.3.6.4. Description

Unlike the previous two environments, the Description list has no fixed label. Instead, \LaTeX uses the first “word” of the first line as the label. Here’s an example:

**Example:** This is an example of the Description environment.

\LaTeX typesets the label in boldface and puts extra space between it and the rest of the line.

With the first “word” it is meant that the first usage of the \texttt{Space} key ends the label if you are at the beginning of the first line of an item. If you need to use more than one word in a label use a \texttt{Protected Space}. (Use either Ctrl+Space or the menu \texttt{Insert}→\texttt{Formatting}→\texttt{Protected Space}; see section 3.5.1 for more information.) Here is an example:

**Second Example:** This one shows how to use a \texttt{Protected Space} in the label of a Description list item.

**Usage:** You should use the Description environment for things like definitions and theorems. Use it when you need to make one word in particular stand out in the text that describes it. It’s not a good idea to use a Description environment when you have an entire sentence that you want to describe. You’re better off using \texttt{Itemize} or \texttt{Enumerate} and nesting several \texttt{Standard} paragraphs into them.

**Nesting:** You can nest Description environments inside one another, nest them in other types of lists, and so on.

Notice that after the first line, \LaTeX indents subsequent lines, offsetting them from the first line.

3.3.6.5. Labeling

The Labeling environment is a \LaTeX extension to \LaTeXeX.

Like the Description list the Labeling list has user-defined labels for each list item but it provides some additional features. Here are its properties:

- **item labels** \LaTeX uses the first “word” of each line as the item label. The first \texttt{Space} after the beginning of the first line of an item marks the end of the label.
  
  If you need to use more than one word in an item label, use a protected space as described above.

- **margins** As you can see, \LaTeX uses different margins for the item label and the body of the item text. The body of the text has a larger left margin, which is equal to the default label width plus a little extra space.

- **label width** \LaTeX uses the width of the label, or the default width, whatever is larger.
  
  If the label width is larger, the label “extends” into the first line. In other words, the text of the first line isn’t aligned with the left margin of the rest of the item text.
default width You can set the default label width to ensure that the text of all items in a Labeling environment has the same left margin.

To change the default width, select all items in the list. Now open the Edit → Paragraph Settings dialog (toolbar button ). The text in the box Longest label determines the default label width. You can use the text of your largest label here, but you can also use the letter “M” multiple times instead. M is the widest character and is a standard unit of widths in \texttt{LATEX}. By using “M” as the unit of width you don’t need to keep changing the contents of Longest label every time you alter a label in a List environment.

The predefined default width is the length of “00.00.0000” (equal to 6 M).

You should use the Labeling list the same way as the Description list: When you need one word to stand out from the text that describes it. The Labeling environment gives you another way to do this, using a different overall layout.

You can nest Labeling lists inside one another, nest them in other types of lists, and so on. They work just like the other list paragraph environments. Read section 3.4 to learn about nesting.

There is yet another feature of the Labeling list: As you can see in the examples, LyX left-justifies the item labels by default. You can use additional HFills to change how LyX justifies the item label. HFills are documented in section 3.5.2. Here are some examples:

- Left The default for Labeling item labels.
- Right One HFill at the beginning of the label right justifies it.
- Center One HFill at the beginning of the label and one at the end centers it.

### 3.3.7. Customized Lists

The features described in this section require that the module Customisable Lists (enumitem) is loaded in the document settings. The module uses the \texttt{LATEX}-package enumitem.

#### 3.3.7.1. Custom Enumerate Lists

The default numbering of numbered lists can be changed by adding an optional argument (menu Insert → Enumerate Options) to the first item of each level in the list. There you add the command

\begin{verbatim}
label=\roman{enumi}
\end{verbatim}

in \TeX{} Code (shortcut Ctrl+L).\(^3\) \texttt{enumi} is hereby the first level counter of the enumeration. The command \texttt{\roman} outputs the counter as a small Roman numeral.

\(^3\)For more about \TeX{} Code, look at section 6.10.
3.3. Paragraph Environments

For capital Roman numerals replace \texttt{\textbackslash roman} with \texttt{\textbackslash Roman} in the command above. For Arabic numerals use \texttt{\textbackslash arabic}. To “number” items with capital or small Latin letters use \texttt{\textbackslash Alph} or \texttt{\textbackslash alph}, respectively.

**Note:** You can only number 26 items with Latin letters, because this numbering is limited to single letters.

To change the numbering for the list sublevels, replace the 'i’ in the command by the small Roman numeral of the level (enumi, enumii, enumiii, enumiv).

Here is a list with custom numbering:

\texttt{\textbackslash #A\# Level 1
\texttt{\textbackslash A.1 Level 2
\texttt{\textbackslash A.2 Level 2
\texttt{\texttt{1 Level 3
\texttt{\texttt{i) Level 4

For this list these commands were used:

\texttt{label=\textbackslash#\textbackslash Alph\{enumi\}\textbackslash#
\texttt{label=\textbackslash Alph\{enumi\},\textbackslash arabic\{enumii\}
\texttt{label=\textbackslash bfseries\{\textbackslash arabic\{enumiii\}\}
\texttt{label=\textbackslash emph\{\textbackslash roman\{enumiv\}\}}

where the command \texttt{\textbackslash emph\{\} makes the label emphasized and \texttt{\textbackslash bfseries\{\} makes it bold.

**Note:** When you change the label of a list level, it will be used for all following lists until you change the definition.

3.3.7.2. Resumed Enumeration

Enumerations can be resumed after intermediate paragraphs:

1. first
2. second
regular text
3. resumed

To resume an enumeration, use the style \texttt{Enumerate-Resume}. Its numbering appears in blue within \LaTeX{} to indicate that it is a resumed list and that the numbering will not be correct in \LaTeX{}, but in the output.

**Note:** If there is no previous enumeration to resume, you will get a \LaTeX{} error.

Perhaps you might want to resume the list with a different number from the next one. Or you want to start a new enumeration with a defined number. This is possible by
3. \LaTeX Basics

adding an optional argument to the first list item of a normal enumeration. There, insert the command

\texttt{start=number}

where \texttt{number} is the number with which you want to resume the list. An example:

1. first item
2. second item

Enumeration starting at a given value:

4. This enumeration starts at 4

\subsection*{3.3.7.3. List Spacing}

In some cases you might want less or more vertical space between the items of a list. For example if the default space is too much in your opinion in this case:

- A bullet list
- with standard spacing

You can decrease the space by adding an optional argument to the first item of the list. Add there the command \texttt{nolistsep} to get no additional list space like in this example:

- A bullet list
- without additional
- vertical space

To add space you can use several other commands provided by the \LaTeX-package \texttt{enumitem}. For more information see its documentation, [14].

There are also many commands available to change the horizontal spacing and indentation. Here is an example where the indentation was changed to that of the paragraphs in the document and the label separation was set to 2cm so that the number is in the page margin:

1. An enumeration
2. with negative indentation

\subsection*{3.3.7.4. Further Customization}

You can also change the style of description lists. The command

\texttt{font=definition}

changes the description label font, the command

\texttt{style=definition}
sets the list style.

An example where the command

\texttt{font=\itshape, style=nextline}

is used:

**Ionizing radiation:**

Ionizing radiation consists of particles or electromagnetic waves that are energetic enough to detach electrons from atoms or molecules, therefore ionizing them.

**Reference counting:**

In computer science, reference counting is a technique of storing the number of references, pointers, or handles to a resource such as an object, block of memory, disk space or other resource.

There are many more commands and features provided by the \LaTeX-package \texttt{enumitem}. For more information see its documentation [14].

### 3.3.8. Letters

#### 3.3.8.1. Address and Right Address: An Overview

Although \LaTeXX has document classes for letters, we’ve also created two paragraph environments called \texttt{Address} and \texttt{Right Address}. To use the letter class, you need to use specific paragraph environments in a specific order, otherwise \LaTeX gags on the document. In contrast, you can use the \texttt{Address} and \texttt{Right Address} paragraph environments anywhere with no problem. You can even nest them inside other environments, though you can’t nest anything in them.

Of course, you’re not limited to using \texttt{Address} and \texttt{Right Address} for letters only. \texttt{Right Address}, in particular, is useful for creating article titles like those used in some European academic papers.

#### 3.3.8.2. Usage

The \texttt{Address} environment formats text in the style of an address, which is also used for the opening and signature in some countries. Similarly, the \texttt{Right Address} environment formats text in the style of a right-justified address, which is used for the sender’s address and today’s date in some countries. Here’s an example of each:

Right Address
Who I am
Where I am
When is it? What is today?
3. LyX Basics

That was **Right Address**. Notice that the lines all have the same left margin, which LyX sets to fit the largest block of text on a single line. Here’s an example of the **Address** environment:

Who are you
Where do I send this
Your post office and country

As you can see, both **Address** and **Right Address** add extra space between themselves and the next paragraph. If you enter **Return** in either of these environments, LyX resets the nesting depth and sets the environment to **Standard**. This makes sense, since **Return** is the paragraph-break function, and the individual lines of an address are not paragraphs. Thus, you have to use **break-line** (Ctrl+Return or Insert→Formatting→Ragged Line Break) to start a new line in an **Address** or **Right Address** environment.

### 3.3.9. Academic Writing

Most academic writing begins with an abstract and ends with a bibliography or list of references. LyX contains paragraph environments for both of these.

#### 3.3.9.1. Abstract

The **Abstract** environment is used for the abstract of an article. Technically, you could use this environment anywhere, but you really should only use it at the beginning of the document, after the title. Also, don’t bother trying to nest **Abstract** in anything else or *vice versa*. It will not work. The **Abstract** environment is only useful in the article and report document classes. The book document classes ignores the **Abstract** completely, and it’s utterly silly to use **Abstract** in a letter document class.

The **Abstract** environment does several things for you. First, it puts the centered label “Abstract” above the text. The label and the text of the abstract are separated by some extra vertical space. Second, it typesets everything in a smaller font, just as you’d expect. Lastly, it adds a bit of extra vertical space between the abstract and the subsequent text. Well, that’s how it will appear on the LyX screen. The actual appearance in the output depends on the document class you are using.

Starting a new paragraph by entering **Return** does not reset the paragraph environment. The new paragraph will still be in the **Abstract** environment. So, you will have to change the paragraph environment yourself when you finish entering the abstract of your document.

We would love to demonstrate the **Abstract** environment, but since this document is in the “book” class, we can’t do this. We inserted it therefore as figure 3.1. If you have never heard of an “abstract” before, you can safely ignore this environment.
Abstract

This is an abstract. As you can see, it is printed in a smaller font size than the other paragraph types.
Also several paragraphs are possible in the abstract.

This is a “Standard” paragraph to visualize the differences in the font size.

Figure 3.1.: Paragraph in the Abstract environment

3.3.9.2. Bibliography

The Bibliography environment is used to list references. Technically, you could use this environment anywhere, but you really should only use it at the end of the document. Nesting Bibliography in anything else or vice versa will not work.

When you first open a Bibliography environment, LyX adds a large vertical space, followed by the heading “Bibliography” or “References,” depending on the document class. The heading is in a large boldface font. Each paragraph of the Bibliography environment is a bibliography entry. Thus, entering Return does not reset the paragraph environment. Each new paragraph is still in the Bibliography environment.

There is another, usually better way to include references in your document by using a BibTeX database. For more information on that, and for a detailed description of LyX’s bibliography handling, have a look at section 6.5.

3.3.10. Special Environments

LyX provides two environments that can be used to emulate the behavior of a computer console/terminal and a typewriter.

3.3.10.1. LyX-Code

The LyX-Code environment is a LyX extension. It type-sets text in a typewriter-style font. It also treats the Space key as a fixed whitespace.\(^4\) LyX-Code, Verbatim and Verbatim* are the only environments in which you can type multiple whitespaces in LyX. If you need to insert blank lines, you will still need to use Ctrl+Return (the break-line function). Return breaks paragraphs. Note, however, that Return

\(^4\)In the LyX-Code environment, the Space key is treated as a Protected Blank instead of an end-of-word marker.
3. \LaTeX{} Basics

does not reset the paragraph environment. So, when you finish using the \texttt{\LaTeX{}-Code} environment, you will need to change the paragraph environment yourself. Also, you can nest the \texttt{\LaTeX{}-Code} environment inside of others.

There are a few quirks with this environment:

- You cannot use Ctrl+Return at the beginning of a new paragraph (i.e. you can’t follow Return with a Ctrl+Return).
- You cannot follow a Ctrl+Return with a Space but with a Ctrl+Space.
- You cannot have an empty paragraph or an empty line. You must put at least one Space in any line you want blank. Otherwise, \TeX{} generates errors.
- You cannot get the typewriter double quotes by typing ” since that will insert real quotes. You get the typewriter double quotes with Ctrl+".

Here is an example:

```c
#include <stdio.h>

int main(void)
{
    printf("Hello World!\n");
    return 0;
}
```

This is just the standard “Hello world!” program.

\texttt{\LaTeX{}-Code} has one purpose: to typeset code, such as program source, shell scripts and so on. Use it only in those very special cases where you need to generate text as if you used a typewriter. For longer parts of programming code, use the listings inset that is described in the chapter \textit{Program Code Listings} of the \textit{Embedded Objects} manual.

### 3.3.10.2. Verbatim

The \texttt{Verbatim} environment is similar to the \texttt{\LaTeX{}-Code} environment with the difference that its content will be treated like a computer console text. \texttt{Verbatim} does therefore not have paragraphs so that Return breaks lines. Compared to \texttt{\LaTeX{}-Code} the Space key is treated like a normal space in text (not as a protected space) and you can have empty lines. In contrary to \texttt{\LaTeX{}-Code}, \texttt{Verbatim} cannot

- have a certain language and a text style
- contain hyperlinks, boxes, foot- and margin notes, notes, math, citations, index- and nomenclature entries, labels, tables, graphics, listings, floats and \TeX{} Code

Because of these properties \texttt{Verbatim} works like a typewriter. Here is an example:
This is Verbatim.
The following 2 lines are empty:

Almost everything is allowed in Verbatim: "%&$§#~''\}][{{

The Verbatim* environment is identical to Verbatim with the difference that spaces appear in the output as the character ‘\’. An example:

This/uni2423is/uni2423Verbatim*.

3.4. Nesting Environments

3.4.1. Introduction

LyX treats text as a unified block with a particular context and specific properties. This allows you to create blocks that inherit some of the properties of another block. For example you have three main points in an outline, but point #2 also has two subpoints. In other words, you have a list inside of another list, with the inner list “attached” to item #2:

1. one
2. two
   a) sublist – item #1
   b) sublist – item #2
3. three

You put a list inside a list by nesting one list inside the other. Nesting an environment is quite simple: Select Edit > Increase List Depth or Decrease List Depth to change the nesting depth (the status bar will tell you how far you are nested). Instead of the menu, you can also use the toolbar buttons and or the key bindings Tab and Shift+Tab or Alt+Shift+Right and Alt+Shift+Left. The change will work on the current selection, if you have made one (allowing you to change the nesting of several paragraphs at once), or the current paragraph.

Note that LyX only changes the nesting depth if it can. If it is invalid to do so, nothing happens if you try to change the depth. Additionally, if you change the depth of one paragraph, it affects the depth of every paragraph nested inside of it.

Nesting isn’t limited to lists. In LyX, you can nest just about anything inside anything else, as you’re about to find out. This is the real power of nesting paragraph environments.
3. LyX Basics

3.4.2. What You Can and Can’t Nest

Before we fire a list of paragraph environments at you, we need to tell you a little bit more about how nesting works.

The question of nesting a paragraph environment is a bit more complicated than a simple yes or no. There are three types of paragraph environments:

- Completely unnestable
- Fully nestable, you can nest them inside things and you can also nest other things inside them.
- A third type, you can nest them into other environments, but you can’t nest anything into them.

Here’s a list of the three types of nesting behavior, and which paragraph environments have them:

**Unnestable** Can’t nest them. Can’t nest into them.

- Bibliography
- Abstract
- Title
- Author
- Date

**Fully Nestable** You can nest them. You can nest other things into them.

- Verse
- Quote
- Quotation
- Itemize
- Enumerate
- Description
- List
- LyX-Code
- Verbatim
- Verbatim*

**Nestable-Inside** You can nest them inside other things. You can’t nest anything into them.

- Standard
- Part
3.4. Nesting Environments

- Chapter
- Section
- Subsection
- Subsubsection
- Paragraph
- Subparagraph
- Part*
- Chapter*
- Section*
- Subsection*
- Subsubsection*
- Right Address
- Address

**Note:** Although it is possible, for example, to nest numbered section headings like *Chapter, Section, etc.* into lists, it is highly recommended not to do this because the aim is to create well-structured documents following typesetting guidelines whereas nested section headings violate this.

### 3.4.3. Nesting Other Things: Tables, Math, Floats, etc.

There are several things that aren’t paragraph environments, but which are affected by nesting anyhow. They are:

- equations
- tables
- figures

**Note:** Figures and tables in *Floats* are not affected by this. Have a look at section 4.6 for more information about *Floats.*

LyX can treat these three objects as either a word or as a paragraph. If a figure, table, or an equation is inline, it goes wherever the paragraph it is in goes.

On the other hand, if you have an equation, figure or table in a “paragraph” of its own, it behaves just like a “nestable-inside” paragraph environment. You can nest it into any environment, but you obviously can’t nest anything into it.

Here’s an example with a table:

1. Item One
3. \textit{\LaTeX} Basics

a) This is (a) and it’s nested.

\begin{tabular}{|l|l|}
\hline
a & b \\
\hline
\end{tabular}

\begin{tabular}{|l|l|}
\hline
c & d \\
\hline
\end{tabular}

b) This is (b). The table is actually nested inside (a).

2. Back out again.

If we hadn’t nested the table at all, the list would look like this:

1. Item One

a) This is (a) and it’s nested.

\begin{tabular}{|l|l|}
\hline
a & b \\
\hline
\end{tabular}

\begin{tabular}{|l|l|}
\hline
c & d \\
\hline
\end{tabular}

1. This is (b). The table is \textit{not} nested inside (a). In fact, it’s not nested at all.

2. Back out again.

Notice how item (b) is not only no longer nested, but is also the first item of a new list!

There’s another trap you can fall into: Nesting the table, but not going deep enough. \textit{\LaTeX} then turns anything after the table into a new sublist.

1. Item One

a) This is (a) and it’s nested.

\begin{tabular}{|l|l|}
\hline
a & b \\
\hline
\end{tabular}

\begin{tabular}{|l|l|}
\hline
c & d \\
\hline
\end{tabular}

1. This is (b). The table is actually nested inside Item One, but \textit{not} inside (a).

2. Back out again.

As you can see, item (b) turned into the first item of a new list, but a new list \textit{inside} item 1. The same thing would have happened to a figure or an equation. So, if you nest tables, figures or equations, make sure you go to the right depth!
3.4.4. Usage and General Features

Speaking of levels, \LaTeX{} can perform up to a six-fold nesting. In other words, “level #6” is the innermost possible depth. Here’s an example to illustrate what we mean:

1. level #1 – outermost
   a) level #2
      i. level #3
      A. level #4
         • level #5
            – level #6

There are two exceptions to the six-fold nesting limit, and you can see both of them in the example. Unlike the other fully-nestable environments, you can only perform a four-fold nesting with the \texttt{Enumerate} and \texttt{Itemize} environments. For example, if we tried to nest another \texttt{Enumerate} list inside item “A.”, we would get errors.

3.4.5. Some Examples

The best way to explain just what you can do with nesting is by illustration. We have several examples of nested environments. In them, we explain how we created the example, so that you can reproduce them.

3.4.5.1. Example 1: The Six-fold Way and Mixed Nesting

#1-a This is the outermost level. It’s a \texttt{List} environment.

#2-a This is level #2. We created it by using Alt+Return followed by Alt+Shift+Right.

#3-a This is level #3. This time, we just enter Return, then used Alt+Shift+Right twice in a row. We could have also created it the same way as we did the previous level, by entering Alt+Return followed by Alt+Shift+Right.

This is actually a \texttt{Standard} environment, nested inside of “#3-a”. So, it’s at level #4. We did this by entering Alt+Return, then Alt+Shift+Right, then changing the paragraph environment to \texttt{Standard}. Do this to create list items with more than one paragraph — it also works for the \texttt{Description}, \texttt{Enumerate}, and \texttt{Itemize} environments!

Here’s another \texttt{Standard} paragraph, also at level #4, made with just a Alt+Return.
3. \textit{LyX} Basics

\#4-a This is level \#4. We enter Alt+Return and changed the paragraph environment back to List. Remember — we can’t nest anything inside a \texttt{Standard} environment, which is why we’re still at level \#4. However, we \textit{can} keep nesting things inside “\#3-a”.

\#5-a This is level \#5...

\#6-a ...and this is level \#6. By now, you should know how we made these two.

\#5-b Back to level \#5. Just enter Alt+Return followed by a Alt+Shift+Left.

\#4-b After another Alt+Return followed by a Alt+Shift+Left, we’re back at level \#4.

\#3-b Back to level \#3. By now it should be obvious how we did this.

\#2-b Back to level \#2.

\#1-b And last, back to the outermost level, \#1. After this sentence, we will enter Return and change the paragraph environment back to \texttt{Standard} to end the list.

We could have also used the \texttt{Description}, \texttt{Quote}, \texttt{Quotation}, or even the \texttt{Verse} environment in place of the \texttt{List} environment. The example would have worked exactly the same.

\subsection*{3.4.5.2. Example 2: Inheritance}

This is the \texttt{LyX-Code} environment, at level \#1, the outermost level. Now we will enter Return, then Alt+Shift+Right, after which, we will change to the \texttt{Enumerate} environment.

1. This is the \texttt{Enumerate} environment, at level \#2.

2. Notice how the nested \texttt{Enumerate} not only inherits its margins from its parent environment (\texttt{LyX-Code}), but also inherits its font and spacing!

We ended this example by entering Return. After that, we needed to reset the paragraph environment to \texttt{Standard} and reset the nesting depth by using Alt+Shift+Left once.

\subsection*{3.4.5.3. Example 3: Labels, Levels, and the \texttt{Enumerate} and \texttt{Itemize} Environments}

1. This is level \#1, in an \texttt{Enumerate} paragraph environment. We’re actually going to nest a bunch of these.
3.4. Nesting Environments

a) This is level #2. We used Alt+Return followed by Alt+Shift+Right. Now, what happens if we nest an Itemize environment inside of this one? It will be at level #3, but what will its label be? An asterisk?

- No! It’s a bullet. This is the first Itemize environment, even though it’s at level #3. So, its label is a bullet. (We got here by using Alt+Return, then Alt+Shift+Right, then changing the environment to Itemize.)

  - Here’s level #4, produced using Alt+Return, then Alt+Shift+Right. We will do that again...

  i. ...to get to level #5. This time, however, we also changed the paragraph environment back to Enumerate. Notice the type of numbering, it is lowercase Roman, because we are in the thirdfold Enumerate environment (that is, it is an Enumerate inside an Enumerate inside an Enumerate).

ii. What happens if we don’t change the paragraph environment, but decrease the nesting depth? What type of numbering does L\LaTeX\ use?

iii. Oh, as if you couldn’t guess by now, we’re just using Alt+Return to keep the current environment and depth but create a new item.

iv. Let’s use Alt+Shift+Left to decrease the depth after the next Alt+Return.

  i. This is level #4. Look what type of label \LaTeX\ is using!

  i. This is level #3. Even though we’ve changed levels, \LaTeX\ is still using a lowercase Roman numeral as the label. Why?

ii. Because, even though the nesting depth has changed, the paragraph is still a thirdfold Enumerate environment. Notice, however, that \LaTeX\ did reset the counter for the label.

b) Another Alt+Return Alt+Shift+Left sequence, and we’re back to level #2. This time, we not only changed the nesting depth, but we also moved back into the twofold-nested Enumerate environment.

2. The same thing happens if we do another Alt+Return Alt+Shift+Left sequence and return to level #1, the outermost level.

Lastly, we reset the environment to Standard. As you can see, the level number doesn’t correspond to what type of labeling \LaTeX\ uses for the Enumerate and Itemize environments. The number of other Enumerate environments surrounding it determines what kind of label \LaTeX\ uses for an Enumerate item. The same rule applies for the Itemize environment, as well.
3. \LaTeX Basics

3.4.5.4. Example 4: Going Bonkers

1. We’re going to go totally nuts now. We will not nest as deep as in the other examples, nor will we go into the same detail with how we did it. (level #1: Enumerate)

(Return, Alt+Shift+Right, Standard: level #2) We will stick an encapsulated description of how we created the example in parentheses someplace. For example, the two key bindings are how we changed the depth. The environment name is the name of the current environment. Either before or after this, we will put in the level.

2. (Return, Enumerate: level #1) This is the next item in the list.

   Now we will add verse.
   It will get much worse.
   (Return, Alt+Shift+Right, Verse: level #2)
   Fiddle dee, Fiddle doo.
   Bippitey boppitey boo!
   (Alt+Return)

   Here comes a table:

<table>
<thead>
<tr>
<th>one-fish</th>
<th>two-fish</th>
</tr>
</thead>
<tbody>
<tr>
<td>red-fish</td>
<td>blue-fish</td>
</tr>
</tbody>
</table>

   (Alt+Return, Table, Alt+Shift+Right 3 times, Alt+Return, Verse, Alt+Shift+Left)

3. (Return, Enumerate: level #1) This is another item. Note that selecting a Table resets the nesting depth to level #1, so we increased the nesting depth 3 times to put the table inside the Verse environment.

   We’re now ending the Enumerate list and changing to Quotation. We’re still at level #1. We want to show you some of the things you can do by mixing environments. The next set of paragraphs is a “quoted letter.” We will nest both the Address and Right Address environments inside of this one, then use another nested Quotation for the letter body. We will use Alt+Return to preserve the depth. Remember that you need to use Ctrl+Return to create multiple lines inside the Address and Right Address environments. Here it goes:

   1234 Nowhere Rd.
   Moosegroin, MT 00100
   9-6-96

   Dear Mr. Fizlewitz:

   

40
We regret to inform you that we cannot fill your order for 50 L of compressed methane gas due to circumstances beyond our control. Unfortunately, several of our cows have mysteriously exploded, creating a backlog in our orders for methane. We will place your name on the waiting list and try to fill your order as soon as possible. In the meantime, we thank you for your patience.

We do, however, now have a special on beef. If you are interested, please return the enclosed pricing and order form with your order, along with payment.

We thank you again for your patience.

Sincerely,
Bill Hick

That ends that example!

As you can see, nesting environments in \texttt{LYX} gives you a lot of power with just a few keystrokes. We could have easily nested an \texttt{Itemize} list inside of a \texttt{Quotation} or \texttt{Quote}, or put a \texttt{Quote} inside of an \texttt{Itemize} list. You have a huge variety of options at your disposal.

### 3.4.6. Separate Nestings

It is sometimes necessary to have two consecutive environments of the same type. For example you need two different enumerations:

1. Hello
   a) this is an
      i. enumeration
      \begin{itemize}
      \item itemize list
      \end{itemize}
   1. Hi
   2. this is another
   3. enumeration

To split an existing list into two lists, set the cursor at the end of a list item and use the menu \texttt{Edit}→\texttt{Start New Environment}. This inserts a plain separator (red line in \texttt{LYX}) and behind it the new list. The menu \texttt{Edit}→\texttt{Start New Parent Environment} only appears if the item is nested. It does not only separate the list but also creates a new one outside the nesting.

By right-clicking on a separator one can change it into a paragraph separator (red arrow in \texttt{LYX}). The difference between both separator types is that the plain separator only splits the list and not the current paragraph.
3. LyX Basics

In general, you get an environment separator when you press Return in a Standard environment immediately after a non-Standard one.

3.5. Spacing, pagination and line breaks

What is a space? While you might be used to pressing the space key anytime you want to separate two words in ordinary word processors, LyX offers you more spaces: spaces of different widths and spaces which can or cannot be broken at the end of a line. The following sections will show you some examples where those spaces are useful.

3.5.1. Protected Space

The protected space: It is used to tell LyX (and \LaTeX) not to break the line at that point. This may be necessary to avoid unlucky line breaks, like in:

Further documentation is given in section 6.5.

Obviously, it would be a good thing to put a protected space between “section” and “6.5”. A protected space is set with InsertÆFormattingÆProtected Space (shortcut Ctrl+Space).

3.5.2. Horizontal Space

All horizontal spaces can be inserted with the menu InsertÆFormattingÆHorizontal Space. The length units are listed in Appendix D.

3.5.2.1. Inter-word Space

With the introduction of typewriters, it became conventional in some countries to type two spaces after a period to mimic the wider spaces used by typesetters at the ends of sentences. There is no need to do this as LyX automatically takes care about this. However, you do not want an end of sentence space after an abbreviation followed by a period; see section 3.9.3.1 for examples. To insert a normal space, select InsertÆFormattingÆInterword Space (shortcut Ctrl+Alt+Space).

3.5.2.2. Thin Space

A “thin space” is a blank which has half the size of a normal space (and it is also “protected”). The typographical conventions in a lot of languages propose the use
3.5. Spacing, pagination and line breaks

Table 3.1.: Width of the different horizontal spaces.

<table>
<thead>
<tr>
<th>Space</th>
<th>Width</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td>1/3 em</td>
</tr>
<tr>
<td>Protected</td>
<td>1/3 em</td>
</tr>
<tr>
<td>Thin</td>
<td>1/6 em</td>
</tr>
<tr>
<td>Negative thin</td>
<td>-1/6 em = -3 mu</td>
</tr>
<tr>
<td>Negative medium</td>
<td>-4 mu</td>
</tr>
<tr>
<td>Negative thick</td>
<td>-5 mu</td>
</tr>
<tr>
<td>Enspace (0.5 em)</td>
<td>0.5 em</td>
</tr>
<tr>
<td>Quad (1 em)</td>
<td>1 em</td>
</tr>
<tr>
<td>QQuad (2 em)</td>
<td>2 em</td>
</tr>
</tbody>
</table>

of thin spaces in cases where normal spaces would be too wide, for instance, inside abbreviations:

D. E. Knuth has developed our beloved typesetting program.

or between values and units. Compare for example this:
10 kg (thin space)
10 kg (normal space)

You can insert thin spaces with the menu Insert ➤ Formatting ➤ Thin Space (shortcut Ctrl+Shift+Space).

3.5.2.3. More Spaces

You can also insert the following space types:

**Negative thin space** A line with a → ← negative thin space between the arrows.

**Negative medium space** A line with a → ← negative medium space between the arrows.

**Negative thick space** A line with a → ← negative thick space between the arrows.

**Enspace (0.5 em)** A line with an → ← enspace (0.5 em) space between the arrows.

**Quad (1 em)** A line with a → ← Quad (1 em) space between the arrows.

**QQuad (2 em)** A line with a → ← QQuad (2 em) space between the arrows.

**Custom space** A line with → ← 2 cm space between the arrows.

Table 3.1 lists the different space sizes.
3. **\LaTeX** Basics

### 3.5.2.4. Horizontal Fills

Horizontal fills (HFills) are a special \LaTeX feature for adding extra space in a uniform fashion. An HFill is actually a variable length space, whose length always equals the remaining space between the left and right margins. If there is more than one HFill on a line, they divide the available space equally between themselves.

Here are a few examples of what you can do with them:

<table>
<thead>
<tr>
<th>This is on the left side</th>
<th>This is on the right</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left</td>
<td>Middle</td>
</tr>
<tr>
<td>Left</td>
<td>1/3 Left</td>
</tr>
</tbody>
</table>

That was an example in the *Quote* environment. Here→← is one in a standard paragraph. It may or may not be apparent in the printed text, but it *is* sitting in-between the two arrows.

HFills can be made visible when you choose one of the *Fill Patterns* in the space dialog: The following patterns are available:

- **Dots**: .................................................................
- **Rule**: .................................................................
- **Left arrow**: ←..............................................................
- **Right arrow**: .............................................................→
- **Up brace**: ...............................................................\n- **Down brace**: .............................................................

**Note:** If an HFill is at the beginning of a line, and *not* in the first line in a paragraph, \LaTeX ignores it. This prevents HFills from accidentally being wrapped onto a new line. If you need space in this case anyway, set the *Protect* option in the space dialog.

### 3.5.2.5. Phantom Space

Sometimes you want to insert space with exactly the length of a phrase. For example, you want to create the following multiple choice question:

What is correct English?:

- Mr. Edge would have been jumps the gun.
  - has to be jumped
  - jumps

so that the choices appear exactly after the phrase “Mr. Edge”. To get this, you can use the phantom insets available via the menu *Insert* \rightarrow *Formatting* \rightarrow *Phantom*. In
3.5. Spacing, pagination and line breaks

our case insert a horizontal phantom at the beginning of the last two lines and insert “Mr. Edge” into the phantom inset (note the space after “Edge”). A phantom insets prints only the space of its content (like a placeholder). That is why it is named “phantom”. The normal phantom outputs the width and height of the content as space, while the horizontal and vertical variant only outputs the corresponding dimension.

3.5.3. Vertical Space

To add extra vertical space above or below a paragraph, use the Insert ➤ Formatting ➤ Vertical Space dialog. There you find the following sizes:

SmallSkip, MedSkip and BigSkip are \LaTeX\ sizes which depend on the font size of the document. DefSkip is the skip adjusted in the dialog Document ➤ Settings ➤ Text Layout for the paragraph separation. If you use indentation to separate paragraphs DefSkip is equal to MedSkip.

VFill is a variable space, set so that the space is maximal within one page. An example: you have only two short paragraphs on one page with a Vfill between them. Then the first paragraph is placed at the top of the page and the second one at the bottom, because the space between them is then maximal. VFills work like HFills: they fill the remaining vertical space on a page with blank space.\(^5\) If there are several VFills on a page, they divide the remaining vertical space equally between themselves. You can therefore use VFills to center text on a page, or even place text 2/3 down a page.

Custom are custom spaces in units explained in Appendix D.

Note: If the extra vertical space would be in the output at the top/bottom of a page, the space is only added if you have also checked the option Protect.

3.5.4. Paragraph Alignment

You can change the paragraph alignment with the Edit ➤ Paragraph Settings dialog (toolbar button \(\text{E}\)). There are five possibilities:

- Justified (shortcut Alt+A J)
- Left (Alt+A L)
- Right (Alt+A R)
- Center (Alt+A C)
- Default (Alt+A E)

\(^5\)HFills are described in section 3.5.2.
3. \textit{LyX Basics}

The default in most cases is justified alignment, in which the inter-word spacing is variable and each line of a paragraph fills the region between the left and right margins. The other three alignments should be self-explanatory, and look like this:

This paragraph is right aligned,

this one is centered,

this one is left aligned.

3.5.5. Forced Page Breaks

If you don’t like the way \LaTeX{} does the page breaks in your document, you can force a page break where you want one. Normally this will not be necessary, because \LaTeX{} is good at page breaking. Only if you use a lot of \textit{Floats}, \LaTeX{}’s page breaking algorithm can fail.

We recommend you not to use forced page breaks until the text is finished and you have checked in the preview to see if you \textit{really} have to change the page breaking.

There are two types of page breaks: One that ends the page without any special action. This can be inserted above or below a paragraph via the menu Insert $\Rightarrow$ Formatting $\Rightarrow$ New Page. The second type, that is inserted via the menu Insert $\Rightarrow$ Formatting $\Rightarrow$ Page Break, ends a page but stretches the content of the page, so that it fills out the complete page. This type is useful to avoid whitespace when a page break produces a page on which only the last few lines are absent.

You might try to use a page break to ensure that a figure or table appears at the top of a page. This is, of course, the wrong way to do it. \textit{LyX} gives you a way of automatically ensuring that your figures and tables appear at the top of a page (or the bottom, or on their own page) without having to worry about what precedes or follows your figure or table. See chapter 4 to learn more about \textit{Floats}.

3.5.5.1. Clear Page Breaks

Rather than forced page breaks where the content behind the break is placed directly on the next page, you can also clear pages while breaking them. That means that the current paragraph is terminated and everything, including unprocessed floats, from the earlier part of the document are placed after it, if necessary by adding pages.

You can insert a clear page break with the menu Insert $\Rightarrow$ Formatting $\Rightarrow$ Clear Page. When you have a two-sided document like a book, you can use the menu Insert $\Rightarrow$ Formatting $\Rightarrow$ Clear Double Page to insert a clear page break that assures that the next page is a right-hand page (odd-numbered), if necessary by adding a page.
3.5.6. Forced Line Breaks

Similar to page breaks there are two types of line breaks: one simply breaks the line. You can force this line break within a paragraph by selecting Insert › Formatting › Ragged Line Break or with Ctrl+Return. Another type that is inserted via the menu Insert › Formatting › Justified Line Break or with Ctrl+Shift+Return breaks the line and stretches it so that it fills out the whole space between the page margins. This is useful to avoid “fringes” in justified paragraphs due to possible whitespace introduced by line breaks.

You shouldn’t use forced line breaks to correct \LaTeX’s line breaking, as \LaTeX is very good at line breaking. There are, however, a number of situations where it is necessary to set a line break actively, for example, in a poem or for an address (see sections 3.3.5.1, 3.3.5.2 and 3.3.8.2).

3.5.7. Horizontal Lines

In the dialog Insert › Formatting › Horizontal Line you can insert horizontal lines. The line offset is the vertical distance between the line and the baseline of the current text line or the paragraph. The line settings can be changed by left-clicking on the line.

3.6. Characters and Symbols

You can directly enter all characters that are available on your keyboard. You can also use special keyboard maps to be able to enter, for example, characters needed for French with an English keyboard. See section 6.18.2 for information on how this is done.

For the case where you need a character that is not on your keyboard, you can use the Symbols dialog via the menu Insert › Special Character › Symbols.

Note: Maybe not all symbols inserted with the symbols dialog can be displayed when you are using a special screen font in \LaTeX’s preferences. But the inserted symbols will in every case be displayed in the output.

3.7. Fonts and Text Styles

3.7.1. Font Types

There are two types of fonts:
Vector fonts are built from outlines of the single glyphs (e.g. characters) in the font. This means that each glyph is defined using mathematical curves that are well suited for scaling to any requested size. This mathematical definition is interpreted by the font renderer and the curve is filled out with pixels according to the size and glyph. This means that vector fonts will look pretty good in all sizes. Only at very small sizes where each pixel has to be very carefully computed to provide a good image might it be hard to provide a good rendering. That could mean that one only needs to define one font size and scale them. But to achieve a better quality, many fonts define several font sizes. That improves the appearance because you need more details at large font sizes than at small ones.

The font types TrueType, OpenType, and Type 1 are vector fonts.

Bitmap fonts on the other hand, are defined by bitmap graphics from the start; so they will look good at all the sizes they are meant for. However, they don’t scale well, because in order to scale a glyph, each pixel is enlarged into several pixels. It is the same effect that happens if you try to enlarge a picture in an image manipulation program. In order to mitigate this effect, bitmap fonts are typically provided in several fixed sizes typically from around 8 pixels high up to 34 pixels or so high in steps according to what is believed to be useful. The advantage of bitmap fonts is that no complicated computations are necessary to display each glyph; so bitmap fonts display therefore more quickly than scalable fonts. The disadvantage is that sizes that don’t exist as fixed versions have to be scaled by doubling pixels, and thus look bad.

Bitmap fonts are named Type 3 in PostScript- and PDF-documents.

The result of all this is that bitmap fonts are best for the size they are designed for, while scalable fonts are good for nearly all sizes. So one needs fewer font size definitions for scalable fonts. That’s the reason why nearly all text rendering and typesetting programs use scalable fonts.

To see which fonts are used in a PDF-document, look at its document properties.

Many modern typesetting and markup languages have begun to move towards specifying character styles rather than specifying a particular font. For example, instead of changing to an italicized version of the current font to emphasize text, you use an “emphasized style” instead. This concept fits in perfectly with LyX. In LyX, you do things based on contexts, rather than focusing on typesetting details.

### 3.7.2. \LaTeX{} font support

Traditionally, \LaTeX{} used its own fonts. That is to say, you cannot directly access the fonts installed on your operating system, but you have to use specific fonts provided by your \LaTeX{} distribution. The reason is that \LaTeX{} needs some extra information about the fonts, which have to be provided by additional files and packages. The downside of this is that your font choice is somewhat limited compared to a word
3.7. Fonts and Text Styles

processor. On the other hand this comes with the advantage that the provided fonts are generally of very good quality, and that \LaTeX files are very portable across different machines. Also, the range of fonts supported by traditional \TeX has increased a lot in the meantime; so you can find packages for many free and commercial fonts. \lyx supports the fonts that are under a free license via the user interface (see section 3.7.3 for details). Other fonts are available if you enter the relevant \TeX code in the document preamble (please refer to the documentation of your desired font).

Recent developments brought some new \TeX engines that are also able directly to access fonts that are installed for your operating system, namely Xe\TeX and Lua\TeX. Both engines are supported by \lyx. By using them, you can theoretically use any OpenType or TrueType font that is installed on your system. The next section describes how to use these fonts.

Note: In practice, some fonts might fail due to bad metrics and other font deficiencies; so you might have to experiment.

3.7.3. Document Font and Font size

You can set the document fonts in the Document ➤ Settings dialog. In the Fonts section of the dialog, you can specify which font should be used for the three different font shapes — roman (serif), sans serif and typewriter (monospaced) — and you can specify the base font size and scaling factors for (some) sans serif and typewriter fonts if this is necessary to fit with the roman font.

If you select Use non-\TeX fonts, you will have access to the fonts installed on your operating system. This requires that you use PDF (Xe\TeX), PDF (Lua\TeX) or DVI (Lua\TeX) as the output format, i.e. you will have to have either Xe\TeX or Lua\TeX installed (see section 3.7.2). You will then not have access to \TeX’s own fonts. Note that \lyx then lists all available fonts in each of the three lists (roman, sans serif, and typewriter), since \lyx cannot determine the family. Also note that the output might fail with some of the listed fonts, due to the encoding of the fonts and/or font failures. \lyx cannot determine this in advance, so you might need to experiment.

If you use \TeX fonts (which is the default), the possible options for the font include Default and a list of fonts available with your \TeX distribution. If you select Default, the font that is preset by the current document class is used. In most cases, this will be the standard \TeX font, known as “Computer Modern” (cm) or “European Computer Modern” (ec), but some classes preset different default fonts.

As cm and ec are bitmap fonts, they often look pixelated in PDF output, especially when you read the PDF in a zoomed size. To get rid of pixelated fonts, you have to use a vector font. Depending on how your document should look, you can either:

\footnote{This problem does not appear if you read PDFs in Adobe Reader version 6 or later, because this program includes a special bitmap font renderer.}
3. LyX Basics

- select the **Latin Modern** fonts, which is the recommended choice if you want to keep the look of **cm/ec**. **Latin Modern** was developed for the **\LaTeX** community in order to replace **cm** as the default font. It covers a huge range of glyphs and several font shapes. Except for some details, where the appearance was improved, **Latin Modern** looks identical to **cm**.\(^7\)

- or select the **AE (Almost European)** fonts in (the rare) case that **Latin Modern** is not available to you or does not work, and you still want to emulate the look of **cm/ec**. AE is a virtual font. Virtual means that it “steals” outline **cm**-glyphs from other fonts. This has the disadvantage that some characters are missing, like the French guillemets (“«” and “»”)\(^8\) and that accented characters are not one glyph, but built of two characters, the accent and the letter. Therefore you cannot search for words with accented characters in documents using the **AE** fonts. If you search for example for the French word “rêve” in a PDF, you will not get any result, because the PDF-viewer searches for the glyph “ è ” and not for the glyph “ e + ‘ ”.

- If you do not like the look of **cm/ec**, you can of course select one of the other vector fonts provided, e.g. **Times Roman** or **Palatino**. Most roman vector fonts will automatically select matching sans serif and typewriter fonts,\(^9\) but you can also select your own.

The differences between roman, **sans serif** and **typewriter** fonts are explained in section 3.7.6.

The font **Times Roman** was originally designed for newspapers. Its glyphs are thus smaller than glyphs from other fonts in order to fit into the small newspaper columns. Therefore **Times Roman** is not the optimal choice for larger documents like books.

For the font size there are generally four possible values: **Default**, 10, 11 and 12. Some classes provide additional sizes. The size of **Default** depends on the class you are using. In the standard classes it is equal to the font size 10.

Note that the font size is the **base size**. That means that **LyX** scales all other possible font sizes (such as those used in footnotes, super-, and subscripts) by this value. You can fine-tune the font size of text parts via the **Text Style** dialog if needed. The possible font sizes for text parts are explained in section 3.7.6.

The **Default Family** selection lets you specify whether the base font of your document should be roman, sans serif or typewriter. The **Default** selection uses what is preset by the class, the other selections override this. In most cases, **Default** is equal to **roman**, but some classes (such as presentation classes) use other defaults.

\(^7\)One difference is improved kerning.

\(^8\)Loading the **\LaTeX**-package **aeguill** with the document preamble line

\begin{verbatim}
\usepackage[ec]{aeguill}
\end{verbatim}

will fix the guillemet problem.

\(^9\)These are sometimes just matching other fonts (e.g., **Times Roman** selects **Helvetica** for sans serif text), or different shapes of the same font, i.e. a real font **family** (e.g. in case of **Latin Modern** oder **Computer Modern**).
3.7. Fonts and Text Styles

The \LaTeX\ font encoding selection is an expert setting which lets you change the value passed to the \LaTeX\-package fontenc (see also section C.6.2). Normally, you do not need to change (or even understand) this. Unless you have specific reasons, use Default.

With some fonts, the checkboxes Use Old Style Figures and Use True Small Caps are available. These are extra features some fonts provide. If Use Old Style Figures is checked, old style figures (also known as medieval or text figures) are used. Old style figures are the numerals (0–9) with ascenders and descenders, which makes them fit nicely with lowercase letters. Use True Small Caps determines that real small caps are used instead of faked small caps made of scaled capitals. Real small caps are often part of expert font sets; they generally look better than faked small caps but might have to be purchased separately.

The field CJK allows users of the languages Chinese, Japanese, Korean (CJK) to specify a font to display the script characters.\footnote{The font will be the argument for the commands of the \LaTeX\-package CJK. So this has no effect for the document language Japanese that does not use CJK.} \textbf{Note:} When you choose a new font or font size, \LaTeX\ does \textit{not} change the screen font! You will only see a difference in the printed output; this is part of the WYSIWYM concept. \LaTeX\’s screen fonts can be adjusted in the Tools$\backslash$Preferences dialog, see section C.1.3.

3.7.4. Math Fonts

In \LaTeX\ the font used for characters in equations is different from the document font. For the case that you use \TeX\ fonts for your document, you can explicitly choose a math font in the dialog Document\$\backslash$Settings. The default setting is that \LaTeX\ automatically selects a math font. For most cases this will be \LaTeX\’s default – the math variant of \LaTeX\’s default font family “Computer Modern”. \LaTeX\ will automatically only load another math font if a math variant of the document font is available.

Note that the math font will not be used for mathematical text (which is inserted with the shortcut Alt+C Space or by the insertion of the command \text into a formula). Also note that some math fonts are sans serif. Your document might therefore look strange when the document text has serifs while the math characters do not. Sans serif math fonts make therefore in most cases only sense if you select Sans Serif for the Default family in the document font settings.

If you use non-\TeX\ fonts for the document, you can only choose for math to use either the document’s class default \TeX\ font (in most cases “Computer Modern”) or to use the non-\TeX\ variant of the document’s class default font (in most cases “Latin Modern”).
3.7.5. Using Different Character Styles

As we’ve already seen, LyX automatically changes the character style for certain paragraph environments. LyX supports two character styles, Emphasized and Noun. You can activate both of these styles via key bindings, the menus, and the toolbar.

To activate the Noun style, do one of the following:

- click on the toolbar button
- use the key binding Alt+C C

These commands are all toggles. That is, if Noun style is already active, they deactivate it.

One typically uses the Noun style for proper names. For example: “MATTHIAS ETTRICH is the original author of LyX.”

A more widely used character style is the Emphasized style. You can activate (or deactivate — it’s also a toggle) the Emphasized style by:

- clicking on the toolbar button
- using the keybindings Ctrl+E

Normally the Emphasized style is equivalent to an italic font but some document classes or \LaTeX-packages use a different font.

We’ve been using the Emphasized style all over the place in this document. Here’s one more example:

\textit{Do not overuse character styles!}

It’s also a warning in addition to an example. One’s writing should parallel ordinary conversation. Since we don’t all constantly scream at each other, we should also avoid the common tendency to overuse character styles.

You can always reset to the default font using the key binding Alt+C Space or the dialog Edit\& Text Style\& Customized (\textfn{5b}).

3.7.6. Fine-Tuning with the Text Style dialog

There are always occasions when you will need to do some fine-tuning; so LyX gives you a way to create a custom character style. For example, an academic journal or a corporation may have a style sheet requiring a sans-serif font be used in certain situations. Also, writers sometimes use a different font to offset a character’s thoughts from ordinary dialog.

Before we document how to use custom character style, we want to issue a warning yet again: Don’t overuse character styles!

Documents that overuse different fonts and sizes are not easy to read and tend to look as if someone has knocked huge holes in them.
3.7. Fonts and Text Styles

To use custom character styles, open the Edit $\rightarrow$ Text Style $\rightarrow$ Customized dialog or press the toolbar button $\mathbb{E}$. There are several boxes in this dialog, each corresponding to a different font property that you can choose. You can choose an option for one of these properties, or select No change, which keeps the current state of that property. The item Reset will reset the property to whatever is the default. You can use this to reset attributes across a bunch of different paragraph environments all at once.

The font properties, and their options (in addition to No change and Reset) are:

**Family**  The “overall look” of the font. The possible options are:

- **Roman**  This is the Roman font family. Normally a serif font. It’s also the default family. (key binding Alt+C R)

- **Sans Serif**  This is the Sans Serif font family. (key binding Alt+C S)

- **Typewriter**  This is the Typewriter font family. (key binding Ctrl+Shift+P)

**Series**  This corresponds to the print weight. Options are:

- **Medium**  This is the Medium font series. It’s also the default series.

- **Bold**  This is the Bold font series. (key binding Ctrl+Alt+B)

**Shape**  As the name implies. Options are:

- **Upright**  This is the Upright font shape. It’s also the default shape.

- **Italic**  This is the Italic font shape.

- **Slanted**  This is the Slanted font shape (although it might not be visible in LyX, this is different from italic).

- **Small Caps**  This is the Small caps font shape.

**Color**  Alters the text color. Note that not all DVI-viewers are able to display colors. Besides No color, which means that the document default color set in Document $\rightarrow$ Settings $\rightarrow$ Color for Main text is used, you can choose between Black, White, Red, Green, Blue, Cyan, Magenta, Yellow, Brown, Darkgray, Gray, Lightgray, Lime, Orange, Olive, Pink, Purple, Teal and Violet text.

**Language**  This is used to mark regions of text as having a different language from the language of the document. Text marked in this way will be underlined in blue to indicate the change (only within LyX).

If you have for example, an extract of German text in a non-German document, LyX respects the German hyphenation rules automatically. When using the spell checking (see section 6.14) the German-marked text will be checked according to the German dictionary.

**Size**  Alters the size of the font. You will find no numerical values here; all possible sizes are actually proportional to the document font size. Once again, you don’t feed LyX the details, but a general description of what you want to do. The options are:
3. \texttt{LyX} Basics

Tiny

This is the “Tiny” font size. (key bindings \texttt{Alt+S T}, \texttt{Alt+S 1})

Smallest

This is the “Smallest” font size. (key binding \texttt{Alt+S 2})

Smaller

This is the “Smaller” font size. (key bindings \texttt{Alt+S Shift+S}, \texttt{Alt+S 3})

Small

This is the “Small” font size. (key bindings \texttt{Alt+S S}, \texttt{Alt+S 4})

Normal

This is the “Normal” font size. It’s also the default size. (key bindings \texttt{Alt+S N}, \texttt{Alt+S 5})

Large

This is the “Large” font size. (key bindings \texttt{Alt+S L}, \texttt{Alt+S 6})

Larger

This is the “Larger” font size. (key bindings \texttt{Alt+S Shift+L}, \texttt{Alt+S 7})

Largest

This is the “Largest” font size. (key binding \texttt{Alt+S 8})

Huge

This is the “Huge” font size. (key bindings \texttt{Alt+S H}, \texttt{Alt+S 9})

Huger

This is the “Huger” font size. (key bindings \texttt{Alt+S Shift+H}, \texttt{Alt+S 0})

Increase

This increases the size by one step (for instance, from “Largest” to “Huge”). (key binding \texttt{Alt+S +})

Decrease

This decreases the size by one step (for instance, from “Normal” to “Small”). (key binding \texttt{Alt+S -})

We warn you \textit{yet again}: don’t go crazy with this feature. You should almost never need to change the font size. \texttt{LyX} automatically changes the font size for different paragraph environments — use those instead. This is here for fine-tuning only!

Misc

Here you can change a few other things at the character level. Options are:

\textbf{Emph}

\textit{This is text with emphasize on.} This might seem like the same as \textit{Italic}, but it is actually a bit different. Emphasized is a \textit{logical} attribute. That means every document class can define its own font used for emphasized text. Normally this font is equal to italic.

\textbf{Underbar}

\underline{This is text with Underbar on.} (key binding \texttt{Ctrl+U}, \texttt{Alt+C U})

Avoid using underbar if you can! It is a hangover from the typewriter days, when you could not change fonts. One no longer needs to emphasize text by underscoring characters. This is only possible in \texttt{LyX} because some people \textit{may} need it in order to follow style sheets for journal submissions.

\textbf{Double underbar}

\underline{This is text with Double underbar on.} (key binding \texttt{Alt+C D})
As we just warned you against using underbar, you can imagine what we think about double underbar.

**Wavy underbar** This is text with Wavy underbar on. (key binding Alt+C W)
Use this only if a journal absolutely insists on it. Keep antinausea pills handy.

**Strikeout** This is text with Strikeout on. (key binding Ctrl+Shift+O)
This is frequently used to indicate an older version of text that has been changed in the meantime.

**Noun** This is text with Noun on. Like *Emph*, this is a logical attribute. Normally it’s equivalent to *Small Caps*.

So you have a huge number of combinations to choose from. Once you have chosen a new character style via the Edit▸Text Style▸Customized dialog, the settings are saved. You can activate them by using the toolbar button . The button lets you apply your custom character style even when the dialog isn’t visible.

To completely reset the character style to the default, use Alt+C Space. If you want to toggle only those properties that you have just changed (suppose you just set the shape to “slanted” and the series to “bold”), set the Toggle all switch and press Apply.

You should also know something about the differences between the three main font types serif, sans serif, and typewriter:

- **Typewriter** is a so called “monospaced” font, which means every character has the same width; the “i” is as wide as the “m”. Here is an example
  typewriter text
  no typewriter text

- **Serif** fonts use characters with serifs. These are the small “appendices” at the ends of the strokes that form the character. The following example shows the difference:
  text with serifs
  text without serifs
  Serifs facilitate quick and easy reading. These fonts are therefore used as default (named *roman*).

- **Sans serif** is not recommended for use as a base type. This font type is therefore often only used for headings and short texts. We use it in this document to highlight menu names.

“Toggling” refers to applying or removing font properties. When a property is marked for toggling in the Text Style dialog, applying the style to text that already has the property will cause the property to be removed. If you, for example, apply a style with properties A, B and C to text that currently has font properties B, C, F and G, and if B is set to toggle and C is set not to toggle, the text ends up with properties A, C, F and G. “Never toggled” and “always toggled” mean that you do not control the toggling behavior. For the properties on the left side of the dialog (“Family” etc.),
toggling behavior is up to you. If Toggle all is checked, all of the left side properties
are toggled; by default, none of them are. Finally, “Reset” is never toggled. If you,
for example, set “Series” to “Reset” and select Toggle all, then apply the style to bold
face text, the text will revert to the default series (“Medium”), no matter how many
times you apply the style.

We conclude with the same warning once again: Do not overuse the fonts! They are,
more often than not, a kludge and a bad substitute for good writing.

3.8. Printing and Previewing

3.8.1. Overview

Now that we have covered some of the basic features of document preparation using
\LaTeX{}, you probably want to know how to print out your masterpiece. Before we tell
you that, we want to give you a quick explanation of what goes on behind-the-scenes.
We cover this information in much greater detail in the *Additional Features* manual
as well.

\LaTeX{} uses the program \TeX{} as its backend. \TeX{} is just a macro package for the
\TeX{} typesetting system, but to prevent confusion, we will only refer to \TeX{}. \LaTeX{} is
what you use to do your actual writing. Then, \LaTeX{} calls \TeX{} to turn your writing
into printable output. This happens in two stages:

1. First, \LaTeX{} converts your document to a series of text commands for \TeX{},
generating a file with the extension, “.tex”.

2. Next, \LaTeX{} calls \TeX{} to use the commands in the .tex file to produce printable
output.

3.8.2. Output file formats

3.8.2.1. Simple text (ASCII)

This file type has the extension “.txt”. It contains your document as plain text
following the rules of the “American Standard Code for Information Interchange”
(ASCII).

You can export your document to ASCII with the menu File$\Rightarrow$Export$\Rightarrow$Plain text.
However, this will not export any externally generated material such as a Bib\TeX{}
bibliography (section 6.5.2). If your document includes such material, use File$\Rightarrow$
Export$\Rightarrow$More Formats & Options and then select Plain text (ps2ascii). This will first
internally export your document to PostScript (generating thereby the external ma-
terial) and then do the conversion to ASCII.
3.8. Printing and Previewing

3.8.2.2. \texttt{\LaTeX}

This file type has the extension “.\texttt{tex}” and contains all commands that are necessary for the \texttt{\LaTeX} program to process your document. If you know \texttt{\LaTeX}, you can use it to find out \texttt{\LaTeX}-Errors or to process it manually with console commands. The \texttt{\LaTeX}-file is automatically created in LYX’s temporary directory whenever you view or export your document.

You can export your document as a \texttt{\LaTeX}-file using the menu \texttt{File} \texttt{Export} \texttt{LaTeX}. The different \texttt{\LaTeX} export variants are explained in section A.1.13.

3.8.2.3. DVI

This file type has the extension “.\texttt{dvi}”. It is called “device-independent” (DVI), because it is completely portable; you can move them from one machine to another without needing to do any sort of conversion. DVIs are used for quick previews and as a pre-stage for other output formats, like PostScript.

DVI files do not contain images, they only link to them. So don’t forget to deliver the images together with your DVIs. Because the DVI-viewer has to convert the images in the background to make them visible when you scroll the DVI, this can slow down your computer when you view the DVI. So we recommend using PDF for files with many images.

You can export your document to DVI by the menus \texttt{File} \texttt{Export} \texttt{DVI} or \texttt{File} \texttt{Export} \texttt{DVI (LuaTeX)}. The latter option uses the program \texttt{LuaTeX}. \texttt{LuaTeX} is an engine that provides direct Unicode support and support for direct font access (see section 3.7.2). \texttt{LuaTeX} is still a work in progress, but it might develop into the next standard \TeX processor.

3.8.2.4. PostScript

This file type has the extension “.\texttt{ps}”. PostScript was developed by the company \texttt{Adobe} as a printer language. The file therefore contains commands that the printer uses to print the file. PostScript can be seen as a “programming language”; you can calculate with it and draw diagrams and images.\footnote{If you are interested in learning more about this, have a look at the \texttt{\LaTeX}-package \texttt{pstricks}.} As a result of this, the files are often bigger than PDFs.

PostScript can only contain images in the format “Encapsulated PostScript” (EPS, file extension “.\texttt{eps}”). As \texttt{LYX} allows you to use any known image format in your document, it has to convert them in the background to EPS. If, for example, you have 50 images in your document, \texttt{LYX} has to do 50 conversions when you view or export your document the first time. This might slow down your workflow with \texttt{LYX}.
3. \textit{\LaTeX} Basics

So if you plan to use PostScript, you can insert your images directly as EPS to avoid this problem.

You can export to PostScript using the menu File\texttt{\boldmath{$\rightarrow$}}\texttt{Export} \texttt{PostScript}.

3.8.2.5. PDF

This file type has the extension “.pdf”. The “Portable Document Format” (PDF) developed by \textit{Adobe} was derived from PostScript. It is more compressed and it uses fewer commands than PostScript. As the name “portable” implies, it can be processed on any computer system and the printed output looks exactly the same.

PDF can contain images in its own PDF format and in the formats “Joint Photographic Experts Group” (JPG, file extension “.jpg” or “.jpeg”) and “Portable Network Graphics” (PNG, file extension “.png”). You can also use any other image format, because \textit{\LaTeX} converts them in the background to one of these formats. But as described in the section about PostScript, the image conversion will slow down your workflow. So we recommend using images in one of the three formats mentioned above.

You can export your document to PDF via the menu File\texttt{\boldmath{$\rightarrow$}}\texttt{Export} in different ways:

**PDF (pdflatex)** This uses the program \texttt{pdftex} which converts your file directly to PDF.

**PDF (LuaTeX)** This uses the program \texttt{LuaTEX} which converts your file directly to PDF. \texttt{LuaTEX} is a new engine, derived from \texttt{pdflatex}, that also provides direct Unicode support and support for direct font access (see section 3.7.2). \texttt{LuaTEX} is still a work in progress, but it might develop into the next standard \TeX processor.

**PDF (XeTeX)** This uses the program \texttt{XeTEX} that converts your file directly to PDF. \texttt{XeTEX} is a new engine that provides direct Unicode support and support for direct font access (see section 3.7.2). It is particularly good at typesetting different scripts, for example, vertically written Japanese.

**PDF (cropped)** This is the same as PDF (pdflatex) but the result is a PDF with cropped page margins. This is for example useful if you want to use \textit{\LaTeX} to generate good-looking formulas to use them in other programs like for presentations.

**PDF (dvipdfm)** This uses the program \texttt{dvipdfm} that converts your file in the background to DVI and in a second step to PDF.

**PDF (ps2pdf)** This uses the program \texttt{ps2pdf} that creates a PDF from a PostScript-version of your file. The PostScript-version is produced by the program \texttt{dvips} which uses a DVI-version as intermediate step. So this export variant consists of three conversions.
3.9. A few Words about Typography

We recommend using PDF (pdflatex) because pdftex supports all the features of actual PDF-versions, is quick, stable, and works without problems. If you rely on multiscript support and/or specific OpenType fonts, you might want to try out PDF (XeTeX) or PDF (LuaTeX) instead, bearing in mind that these two programs are not yet as mature as pdflatex.

### 3.8.2.6. XHTML

This file type has the extension “.xhtml”. It is a file suitable for viewing in web browsers. It does not itself contain images and the like but only links to them. When LyX produces XHTML, it also generates corresponding images in formats suitable for the purpose. For the math output you can choose in the menu Document ▶ Settings ▶ Output between different formats, which are described in section Math Output in XHTML of the Additional Features manual.

XHTML output remains “under development”, and not all LyX features are supported yet. See the chapter LyX and the World Wide Web, in the Additional Features manual, for more information.

You can export your document as an XHTML file using the menu item File ▶ Export ▶ LyXHTML.

### 3.8.3. Previewing

To get a look at the final version of your document, with all of the page breaks in place, the footnotes correctly numbered, and so on, use the menu Document and choose View or use the toolbar button \(\infty\). A viewing program will pop up showing the output in the defined default output format, which is globally set in the preferences (see section C.7.2) and can also be altered for single documents in the document settings (see section B.20). Further output formats can be selected via Document ▶ View (Other Formats) or the toolbar button \(\infty\).

If you have changed your document, you can refresh the output in the same viewer window using the menu Document ▶ Update or Document ▶ Update (Other Formats), respectively.

When you preview a file, the output file is only generated in LyX’s temporary directory. To have a real output, export your document.

### 3.9. A few Words about Typography

#### 3.9.1. Hyphens, Dashes and Minus Signs

In LyX, the “-” character comes in four lengths: the *hyphen*, the *en dash*, the *em dash*, and the minus sign:
3. **LyX Basics**

<table>
<thead>
<tr>
<th>name</th>
<th>output</th>
<th>inserted with</th>
</tr>
</thead>
<tbody>
<tr>
<td>hyphen</td>
<td>-</td>
<td>“-” in text</td>
</tr>
<tr>
<td>en dash</td>
<td>–</td>
<td>Insert ➤ Special Character ➤ Symbols</td>
</tr>
<tr>
<td>em dash</td>
<td>—</td>
<td>Insert ➤ Special Character ➤ Symbols</td>
</tr>
<tr>
<td>minus sign</td>
<td>—</td>
<td>“-” in math mode</td>
</tr>
</tbody>
</table>

You can alternatively generate the en and em dash by inserting the “-” character multiple times in a row. They will automatically be converted to the appropriate length dash in the final output, but not in LyX. “-” gives a en dash, “---” a em dash.

The three dash types are distinct from the minus sign, which appears in math mode and has a length of its own. Here are some examples:

1. line- and page-breaks (hyphen)
2. From A–Z (en dash)
3. Oh — there’s a dash. (em dash)
4. \( x^2 - y^2 = z^2 \) (minus sign)

### 3.9.2. Hyphenation

Words are not hyphenated within LyX but automatically in the output. Hyphenation is done by the \texttt{\LaTeX} package \texttt{babel} following the rules of the document language.

\texttt{\LaTeX} hyphenates almost perfectly; it only has problems with text in the \texttt{typewriter} font and with unusual constructs, like “h3knix/m0n0wall”. If \texttt{\LaTeX} cannot break a word correctly, you can set hyphenation points manually. This is done with the menu Insert ➤ Formatting ➤ Hyphenation Point. These extra hyphenation points are only recommendations to \texttt{\LaTeX}. If no hyphenation is necessary, \texttt{\LaTeX} will ignore them.

Sometimes you want to prevent words or constructs from being hyphenated. Imagine that you are describing keybindings/shortcuts in your document in the form “A-b c”. \texttt{\LaTeX} would then see the hyphen “-” as a hyphenation possibility. Hyphenating at this point would look ugly. To prevent the shortcut from being hyphenated, you can put it into a makebox as described in section Prevent Hyphenation of the Embedded Objects manual.
3.9.3. Punctuation Marks

3.9.3.1. Abbreviations and End of Sentence

When \LaTeX{} calls \LaTeX{} to generate the final version of your document, \LaTeX{} automatically distinguishes between words, sentences, and abbreviations. \LaTeX{} then adds the “appropriate amount of space.” That means sentences get a little bit more space between the period and the next word. Abbreviations get the same amount of space after the period that a word gets after another word.

Unfortunately, the algorithm for figuring out what’s an abbreviation does not work in all cases. If a “.” is at the end of a lowercase letter, it’s the end of a sentence; if it’s at the end of a capitalized letter, it’s an abbreviation.

Here are some examples of correct abbreviations and of the end of a sentence:

- M. Butterfly
- Don’t worry. Be happy.

And here is an example of the algorithm going wrong:

- e.g. this is too much space!
- This is I. It’s okay.

You will not see anything wrong until you view a final version of your document.

To fix this problem, use one of the following:

1. Use an Inter-word Space after lowercase abbreviations (see section 3.5.2.1).
2. Use a Thin Space between two tokens of an abbreviation (see section 3.5.2.2).
3. Use an End of sentence period found under the Insert Special Character menu to force the use of inter-sentence spacing. This function is also bound to Ctrl+. for easy access.

With the corrections, our earlier examples look like this:

- e.g. this is too much space!
- This is I. It’s okay.

Some languages don’t use extra spacing between sentences. If your language is such a language, you don’t need to worry, because \LaTeX{} will take care of this.

For those that do need to bother, there is help to catch those sneaky errors: Check out the Check \TeX{} feature described in the section Checking \TeX{} of the Additional Features manual.
3. *LyX Basics*

### 3.9.3.2. Quotes

*LyX* usually sets quotes correctly. Specifically, it will use an opening quote at the beginning of quoted text, and use a closing quote at the end. For example, “open close”. The keyboard character, `, generates this automatically.

You can specify what character the `, key produces using the submenu *Language* of the *Document > Settings* dialog in the box *Quote Style*. There are six choices:

- **“Text”** Use quotes like “this”
- **”Text”** Use quotes like ”this”
- **„Text“** Use quotes like „this“
- **„Text”** Use quotes like „this”
- **«Text»** Use quotes like «this»
- **»Text«** Use quotes like »this«

For single quotes you have to use the shortcut Alt+`.`

### 3.9.4. Ligatures

It is standard typesetting practice to group certain letters together and print them as single characters. These groups are known as *ligatures*. Since *\LaTeX* knows about ligatures, your documents will contain them too in the output. Here are the standard ligatures:

- ff
- fi
- fl
- ffi
- ffl

Some languages uses other ligatures if the document font supports them.

Sometimes, you don’t want a ligature in a word. While a ligature may be okay in the word, “graffiti,” it looks really weird in compound words, such as “cufflink” or the German “Dorffest.” To break a ligature, use *Insert > Formatting > Ligature Break*. This changes “cufflinks” to “cufflinks” and “Dorffest” to “Dorffest”.

### 3.9.5. *LyX* and *\LaTeX* logos

Via *Insert > Special Characters > Logos*, *LyX* provides the following program logos with special formatting:
3.9. A few Words about Typography

\textsc{LyX} The name of the game.
\textsc{TeX} The typesetting engine used by \textsc{LyX}.
\textsc{L}\textsc{a}\textsc{TeX} The \TeX\ macro collection used by \textsc{LyX}.
\textsc{L}\textsc{a}\textsc{TeX}\textsc{2}\epsilon The current version of \textsc{LaTeX}.

You might wonder why the \textsc{LaTeX} version is “2\epsilon”. It is an old tradition in the \TeX\ world to give programs geek version numbers. For example the version number of \TeX\ converges to the number $\pi$: The actual version is “\TeX-3.141592”, the previous one was “\TeX-3.14159”.

3.9.6. Units

Generally the space between units and the number is smaller than the normal space between two words. As you can see in the example below, it looks better when the space is smaller. To get such a “half space” for units use the menu \textbf{Insert} $\Rightarrow$ \textbf{Formatting} $\Rightarrow$ \textbf{Thin Space} (shortcut Ctrl+Shift+Space).

Here is an example to show the differences:

24 kW·h space between number and unit
24 kW·h half space between number and unit

3.9.7. Widows and Orphans

In the early days of word processors, page breaks went wherever the page happened to end. There was no regard for what was actually going on in the text. For example the heading for a new section was printed at the very bottom of the page, the first line of a new paragraph all alone at the bottom of a page, or the last line of a paragraph at the top of a new page. These bits of text became known as \textit{widows} and \textit{orphans}.

Clearly, \textsc{LyX} can avoid breaking pages after a section heading. That’s part of the advantage of paragraph environments. But what about widows and orphans, where the page breaks leave one line of a paragraph all alone at the top or bottom of a page? There are rules built into \textsc{LaTeX} governing page breaks, and some of those rules are there specifically to prevent widows and orphans. If they appear nevertheless and you don’t like them, you can add the commands

\begin{verbatim}
\widowpenalty=10000
\clubpenalty=10000
\end{verbatim}

\texttt{\textbackslash widowpenalty=10000}
\texttt{\textbackslash clubpenalty=10000}

to the \textsc{LaTeX} preamble of your document to avoid them. Some \textsc{LaTeX} books (such as [1] or [2]) have more information about the technical details of \textsc{LaTeX}’s page break mechanism.
4. Notes, Graphics, Tables and Floats

The issues of this chapter are described in detail in the *Embedded Objects* manual. There you will also find tips and tricks for special cases.

**4.1. Notes**

\LaTeX{} offers you a few types of notes to add to your document:

**\LaTeX{} Note** This note type is for internal notes that will not appear in the output.

**Comment** This note also doesn’t appear in the output but it does appear as a \LaTeX{}-comment when you export the document to \LaTeX{} via the menu File\>Export\LaTeX{} (xxx).

**Greyed Out** This note will appear in the output as text in a color which you can set in the document settings under Colors\>Greyed-out notes.

This is the text\(^1\) of a comment that appears in the output.

As you can see in the example, greyed out notes can have footnotes.

Notes are inserted with the toolbar button or the menu Insert\>Note. Right-click on the note box that appears to select the note type.

**4.2. Footnotes**

\LaTeX{} uses boxes to display footnotes: When you insert a footnote using the menu Insert\>Footnote or the toolbar button, you will see a box like this: This box is \LaTeX{}’s representation of your footnote. If you left-click on the “foot” label, the box will be opened and you can enter the footnote text into it. Clicking on the box label again will close the box. If you want to turn existing text into a footnote, simply highlight it and click on the footnote toolbar button.

\(^1\)This is an example footnote within a greyed out note. In this document the color of this note type is set to blue.
4. Notes, Graphics, Tables and Floats

Here is an example footnote:\footnote{2}{The footnote will appear in the output as a superscript number at the text position where the footnote box is placed. The footnote text is placed at the bottom of the current page. The footnote number is calculated by \LaTeX according to the document class. \LaTeX does not yet support a particular numbering scheme, but you can get other schemes using special \LaTeX-commands. They are described in the \textit{Embedded Objects} manual.}

4.3. Marginal Notes

Marginal notes look and behave just like footnotes in \LaTeX. When you insert a margin note via the menu \textit{Insert} $\rightarrow$ \textit{Marginal Note} or the toolbar button $\equiv$, you will see a box with the label “margin” appearing within your text. This box is \LaTeX’s representation of your marginal note.

At the side of this sentence is an example marginal note.

Marginal notes appear at the right side in single-sided documents. In double-sided documents they appear in the outer margin – left on even pages, right on odd pages.

For further information about marginal notes see the section \textit{Margin Notes} in the \textit{Embedded Objects} manual.

4.4. Graphics and Images

To insert an image in your document, place the cursor at the text position you want and click on the toolbar icon $\equiv$ or select \textit{Insert} $\rightarrow$ \textit{Graphics} from the menu. Then a dialog will appear to choose the file to load.

This dialog has numerous mostly self-explanatory parameters. The \textit{Graphics} tab allows you to choose your image file. The image can be transformed by setting a rotation angle and a scaling factor. The scaling units are explained in Appendix D.

In the tab \textit{Clipping} it is possible to set image coordinates to adjust the height and width of the image in the output. The coordinates can also be calculated automatically by pressing the button \textit{Get from file}. The option \textit{Clip to bounding box} will only print the image region within the given coordinates. Normally you don’t need to take care about image coordinates and can ignore the tab \textit{Clipping}.

In the \LaTeX and LyX options tab \LaTeX experts can specify additional \LaTeX options. In this tab you can also specify the appearance of the image inside \LaTeX. The option \textit{Draft mode} has the effect that the image doesn’t appear in the output, only a frame with the image size is printed.

\footnote{2}{To close a footnote, click on the footnote box label.}
The graphics dialog can be called at any time by clicking on an image. Images will appear in the output exactly at the position where they are in the text. This is an example image within a separate, horizontally centered paragraph:

![Example Image](image.png)

If you need image captions or want to reference images, you have to put the image into a float, see section 4.6.2.

### 4.4.1. Image Formats

You can insert images in any known file format. But as we explained in section 3.8.2, every output document format allows only a few image formats. \LaTeX\ therefore uses the program \texttt{ImageMagick} in the background to convert the images to the right format. To increase your workflow by avoiding these conversions in the background, use only the image formats listed in the subsections of section 3.8.2.

Similar to fonts there are two types of image formats:

- **Bitmap images** consist of pixel values, often in a compressed form. They are therefore not fully scalable and look pixelated in large zooms. Well-known bitmap image formats are “Graphics Interchange Format” (GIF, file extension “.gif”), “Portable Network Graphics” (PNG, file extension “.png”), and “Joint Photographic Experts Group” (JPG, file extension “.jpg” or “.jpeg”).

- **Scalable images** consist of vectors and can therefore be scaled to any size without data loss. The scaling ability is desired if you want to create presentations, because presentations are always scaled by the beamer. Scaling is also useful for online documents to let the user zoom into diagrams. Scalable image formats can be “Scalable Vector Graphics” (SVG, file extension “.svg”), “Encapsulated PostScript” (EPS, file extension “.eps”), and “Portable Document Format” (PDF, file extension “.pdf”). We say “can be”, because you can convert any bitmap image format to PDF or EPS and the result will not be scalable. In this case only a header with the image properties is added to the original image.\footnote{In the case of PDF, the original image is additionally compressed.}

Normally one cannot convert a bitmap image into a scalable one, only \textit{vice versa}. 

\footnote{In the case of PDF, the original image is additionally compressed.}
4.4.2. Grouping of Image Settings

Each image can define a new group of image settings or join an existing group. Images within such a group share their settings, so adjusting one image of the group automatically also adjusts all other images of the group in the same way. So you can for example change the size for a bunch of images without the need to manually change each of them.

A new group can be set by pressing the button **Open new group** in the **Graphics** dialog in the **LaTeX and LyX options** tab. Joining an existing group can be done using the context menu of the image and checking the name of the desired group.

4.5. Tables

You can insert a table using either the toolbar button ![Table Icon] or the menu **Insert > Table**. A dialog will appear, asking you for the number of rows and columns. The default table has lines around any cell and the first row appears separated from the rest of the table. This separation appears due to a double line: The cells of the first row have a line below them and the cells of the second row have a line above them. Here is an example table:

<table>
<thead>
<tr>
<th></th>
<th>1</th>
<th>2</th>
<th>3</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>B</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>C</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

4.5.1. Table Dialog

You can alter a table by clicking on it with the right mouse button and then choosing **More > Settings**. This brings up the table dialog. Here you can adjust the settings of the cell, row and/or column where the cursor is placed currently. Most of the dialog options also work on selections. This means that if you select more cells, columns or rows the action is done on all of your selection.

In addition to the table dialog, the **table toolbar** helps you in setting table properties. It appears if the cursor is inside a table.

In the tab **Table Settings** of the table dialog you can set the alignment for the current row. If you add a row or column, it will be inserted right beside or below the current cell respectively. The vertical alignment of a column can only be adjusted when a column width is given. A given width will allow the cell to have line breaks and multiple paragraphs of text, see section 4.5.3.
You can mark multiple cells of one row/column as a multicolumn/row cell using the check box Multicolumn or Multirow. This will merge the cells to one cell, spread over more than one column/row. Multicolumn cells are treated as own rows, so that the alignment, width, and border settings affect only the multicolumn cell. Here is an example table with a multicolumn cell in the first row and one in the last row without the upper border:

<table>
<thead>
<tr>
<th>abc</th>
<th>def ghi</th>
<th>jkl</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>B</td>
<td>C</td>
</tr>
<tr>
<td>1</td>
<td>2</td>
<td>3</td>
</tr>
</tbody>
</table>

Adept users can declare special \LaTeX-arguments for the table. They are necessary for special table formatting, such as the multirow cells, explained in the chapter Tables of the Embedded Objects manual. You can also rotate the current cell or the whole table. These rotations are not visible in LYX but are visible in the output.

**Note:** Most DVI-viewers are not able to display rotations.

The Borders tab allows you to add and delete border lines for the current row/column. The button Default adds lines for all cell borders.

### 4.5.2. Multi-page Tables

If the table is too long to fit on one page, you can use the option Use multi-page table in the tab Multi-page table of the table dialog to split the table automatically over more pages. Doing this enables some check boxes and you can now define:

**Header:** The current row and all rows above, that don’t have any special options defined, are defined to be the header rows of all pages of the longtable. Except for the first page, if First header is defined.

**First header:** The current row and all rows above, that don’t have any special options defined, are defined to be the header rows of the first page of the longtable.

**Footer:** The current row and all rows below, that don’t have any special options defined, are defined to be the footer rows of all pages of the longtable, except for the last page, if Last footer is defined.

**Last footer:** The current row and all rows below, that don’t have any special options defined, are defined to be the footer rows of the last page of the longtable.

**Caption:** The first row is reset as a single column. You can now insert there the table caption via the menu Insert > Caption. More about multi-page table captions can be found in the Embedded Objects manual.

You can also specify a row where the table is split. If you set more than one option in the same table row, you should be aware that then only the first option is used; the others will be defined as empty. In this context, first means first in this order: Footer, Last footer, Header, First header; see the following longtable to see how it works:
<table>
<thead>
<tr>
<th>NAME</th>
<th>TEL.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Annovi</td>
<td>Silvia</td>
</tr>
<tr>
<td>Bertoli</td>
<td>Stefano</td>
</tr>
<tr>
<td>Bozzi</td>
<td>Walter</td>
</tr>
<tr>
<td>Cachia</td>
<td>Maria</td>
</tr>
<tr>
<td>Cachia</td>
<td>Maurizio</td>
</tr>
<tr>
<td>Cinquemani</td>
<td>Giusi</td>
</tr>
<tr>
<td>Colin</td>
<td>Bernard</td>
</tr>
<tr>
<td>Concli</td>
<td>Gianfranco</td>
</tr>
<tr>
<td>Dal Bosco</td>
<td>Carolina</td>
</tr>
<tr>
<td>Dalpiaz</td>
<td>Annamaria</td>
</tr>
<tr>
<td>Feliciello</td>
<td>Domenico</td>
</tr>
<tr>
<td>Focarelli</td>
<td>Paola</td>
</tr>
<tr>
<td>Galletti</td>
<td>Oreste</td>
</tr>
<tr>
<td>Gasparini</td>
<td>Franca</td>
</tr>
<tr>
<td>Rizzardi</td>
<td>Paola</td>
</tr>
<tr>
<td>Lassini</td>
<td>Giancarlo</td>
</tr>
<tr>
<td>Malfatti</td>
<td>Luciano</td>
</tr>
<tr>
<td>Malfatti</td>
<td>Valeriano</td>
</tr>
<tr>
<td>Meneguzzo</td>
<td>Roberto</td>
</tr>
<tr>
<td>Mezzadra</td>
<td>Roberto</td>
</tr>
<tr>
<td>Pirpamer</td>
<td>Erich</td>
</tr>
<tr>
<td>Pochiesa</td>
<td>Paolo</td>
</tr>
<tr>
<td>Radina</td>
<td>Claudio</td>
</tr>
<tr>
<td>Stuffer</td>
<td>Oskar</td>
</tr>
<tr>
<td>Tacchelli</td>
<td>Ugo</td>
</tr>
<tr>
<td>Tezzele</td>
<td>Margit</td>
</tr>
<tr>
<td>Unterkalmsteiner</td>
<td>Frieda</td>
</tr>
<tr>
<td>Vieider</td>
<td>Hilde</td>
</tr>
<tr>
<td>Vigna</td>
<td>Jürgen</td>
</tr>
<tr>
<td>Weber</td>
<td>Maurizio</td>
</tr>
<tr>
<td>Winkler</td>
<td>Franz</td>
</tr>
<tr>
<td>Annovi</td>
<td>Silvia</td>
</tr>
<tr>
<td>Bertoli</td>
<td>Stefano</td>
</tr>
<tr>
<td>continue ...</td>
<td></td>
</tr>
<tr>
<td>NAME</td>
<td>TEL.</td>
</tr>
<tr>
<td>-------------</td>
<td>-------</td>
</tr>
<tr>
<td>Bozzi</td>
<td>555</td>
</tr>
<tr>
<td>Cachia</td>
<td>555</td>
</tr>
<tr>
<td>Cachia</td>
<td>555</td>
</tr>
<tr>
<td>Cinquemani</td>
<td>555</td>
</tr>
<tr>
<td>Colin</td>
<td>555</td>
</tr>
<tr>
<td>Concli</td>
<td>555</td>
</tr>
<tr>
<td>Dal Bosco</td>
<td>555</td>
</tr>
<tr>
<td>Dalpiaz</td>
<td>555</td>
</tr>
<tr>
<td>Feliciello</td>
<td>555</td>
</tr>
<tr>
<td>Focarelli</td>
<td>555</td>
</tr>
<tr>
<td>Galletti</td>
<td>555</td>
</tr>
<tr>
<td>Gasparini</td>
<td>555</td>
</tr>
<tr>
<td>Rizzardi</td>
<td>555</td>
</tr>
<tr>
<td>Lassini</td>
<td>555</td>
</tr>
<tr>
<td>Malfatti</td>
<td>555</td>
</tr>
<tr>
<td>Malfatti</td>
<td>555</td>
</tr>
<tr>
<td>Meneguzzo</td>
<td>555</td>
</tr>
<tr>
<td>Mezzadra</td>
<td>555</td>
</tr>
<tr>
<td>Pirpamer</td>
<td>555</td>
</tr>
<tr>
<td>Pochiesa</td>
<td>555, 222</td>
</tr>
<tr>
<td>Radina</td>
<td>555</td>
</tr>
<tr>
<td>Stuffer</td>
<td>555</td>
</tr>
<tr>
<td>Tacchelli</td>
<td>555</td>
</tr>
<tr>
<td>Tezzele</td>
<td>555</td>
</tr>
<tr>
<td>Unterkalmsteiner</td>
<td>555</td>
</tr>
<tr>
<td>Vieder</td>
<td>555</td>
</tr>
<tr>
<td>Vigna</td>
<td>999</td>
</tr>
<tr>
<td>Weber</td>
<td>555</td>
</tr>
<tr>
<td>Winkler</td>
<td>555</td>
</tr>
</tbody>
</table>

End
4. Notes, Graphics, Tables and Floats

4.5.3. Table Cells

A table cell can contain text, inline equations, a figure, or another table. All these kinds of objects can be placed in the same cell. Font sizes and shapes can also be altered. But you can’t put a special environment in a cell (like Section*, etc.), nor set spacing options for the cell’s paragraph.

To have multi-line entries in table cells, you have to declare a fixed width for the column in the table dialog. Your text is then automatically split into multiple lines and the cell is enlarged vertically when the length of the text exceeds the given width. An example:

<table>
<thead>
<tr>
<th></th>
<th>2</th>
<th>3</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>This is a multi-line entry in a table.</td>
<td>5</td>
</tr>
<tr>
<td>6</td>
<td>This is longer now.</td>
<td>7</td>
</tr>
<tr>
<td>8</td>
<td>This is a multi-line entry in a table. This is longer now.</td>
<td>9</td>
</tr>
</tbody>
</table>

Cutting and pasting between tables and table cells works reasonably well. You can even cut and paste more than one row.\(^4\) Selection with the mouse or with Shift plus the arrow keys works as usual. You can also copy and paste the entire table as a single unit by starting the selection from outside the table.

4.6. Floats

4.6.1. Introduction

A float is a block of text associated with some sort of label, which doesn’t have a fixed location. It can “float” forward or backward a page or two, to wherever it fits best. Footnotes and Margin Notes are also floats, because they can float to the next page when there are too many notes on the current page.

Floats make it possible to get a high quality layout. Images and tables can be distributed evenly over the pages to avoid whitespace and pages without text. As the floating often destroys the spatial context between the text and the image/table,

\(^4\)Note that you cannot paste into a multicell selection because it would not be clear what to do when pasting a single word in a selected 2×3.
4.6. Floats

Figure 4.1.: A severely distorted platypus in a float.

every float can be referenced in the text. Floats are therefore numbered. Referencing is described in section 6.1.

To insert a float, use the menu Insert→Float. A box with a caption will be inserted into your document. The label will automatically be translated to the document language in the output. After the label you can insert the caption text. The image or table is inserted above or below the caption in a separate paragraph within the float. To keep your \LaTeX-document readable, you can open and close the float box by left-clicking on the box label. A closed float box looks like this: 

You should insert floats in a separate paragraph to avoid possible \LaTeX-errors that can occur when the surrounding text is specially formatted.

4.6.2. Figure Floats

Figure 4.1 was created using the menu Insert→Float→Figure (toolbar button \textcircled{1}). The image was inserted by setting the cursor above the caption label and using the menu Insert→Graphics (toolbar button \textcircled{2}). The image in the float was horizontally centered by putting the cursor to the left or right of the image and using the menu Edit→Paragraph Settings (toolbar button \textcircled{3}).

This figure float also shows how to set a label and create a cross-reference to it: Insert a label into the caption using the menu Insert→Label (toolbar button \textcircled{4}) and refer to it using the menu Insert→Cross-Reference (toolbar button \textcircled{5}). It is important to use cross-references to figure floats rather than using vague references like “the figure above”, because, as \LaTeX will reposition the floats in the final document, it might not be “above” at all. For more about cross-references, see section 6.1.

Normally only one image is inserted in a figure float, but sometimes you might want to use two images with separate subcaptions. This can be done by inserting image
4. Notes, Graphics, Tables and Floats

(a) Undefinable

(b) Platypus

Figure 4.2.: Two distorted images.

Table 4.2.: A table float.

<table>
<thead>
<tr>
<th>1</th>
<th>2</th>
<th>3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Joe</td>
<td>Mary</td>
<td>Ted</td>
</tr>
</tbody>
</table>
| $\int x^2 dx$ | \[
\begin{bmatrix}
  a & b \\
  c & d \\
\end{bmatrix}
\] | $1 + 1 = 2$ |

floats into existing image floats. Note that only the main caption of the float is added to the List of Figures as described in section 6.2.2. Figure 4.2 is an example of a figure float with two images set side by side. You can also set the images one below the other. Figure 4.2a and 4.2b are the subfigures.

4.6.3. Table Floats

Table floats can be inserted using the menu Insert $\triangleright$ Float $\triangleright$ Table or the toolbar button $\mathbb{[}$]. They have the same properties as figure floats except that the table in the float is normally placed below the caption and not above like for figures and that the label begins with “tab:”. Table 4.2 is a table float.

4.6.4. More Information

\LaTeX{} offers you further float types as well as rotated floats. It also allows you to change the float numbering scheme, to control the float placement and to change the
4.7. Minipages

\LaTeX\ provides a mechanism essentially to produce a page within a page, called a minipage. Within a minipage, all the usual rules of indentation, line wrapping, etc. apply.

Minipages in \LaTeX\X have their own collapsible box inserted via the menu Insert>Box. Right-clicking on the box label allows you to alter the width of the minipage and its alignment within the page.

\begin{quote}
This is a minipage. The text is set in an italic style. Minipages are often used for text in another language or text that needs another formatting.
\end{quote}

If you place two minipages side-by-side, you can use Horizontal Fills as described in section 3.5.2:

\begin{itemize}
\item This is a minipage with some stupid dummy text. This dummy text is used to increase the size of the minipage.
\item This is a minipage with some stupid dummy text. This dummy text is used to increase the size of the minipage.
\end{itemize}

When you right-click on a minipage box, you can transform the box to another box type. All box types and their settings are explained in detail in chapter Boxes of the Embedded Objects manual.
5. Mathematical Formulas

The issues of this chapter are described in detail in the Math manual. There you will also find tips and tricks for special cases.

5.1. Basic Math Editing

To create a math formula, you can just click on the toolbar icon \(\Sigma\) (shortcut Ctrl+M). That will create a little blue rectangle, with purple markers around its corners. That blue rectangle is the formula itself; the purple markers indicate what level of nesting within the formula you are at. You can also choose a particular formula type to insert via the Insert\(\rightarrow\)Math menu.

Editing the parameters of a formula and adding math constructs can be done with the math toolbar, that appears if the cursor is in a formula.

There are two main types of formulas, inline formulas and display formulas. Inline formulas appear within a text line, like this one:

This is a line with an inline formula \(A = B\) in it.

Displayed formulas appear outside the text like if they were in a separate paragraph, like this one:

\[ A = B \]

You can only number and reference displayed formulas.

\LaTeX{} also supports many \LaTeX{} math commands. For example, typing “\alpha”, followed by a space, in a formula will create the Greek letter \(\alpha\). Typing commands might sometimes be faster than using the Math Panel.

5.1.1. Navigating in Formulas

The best control over the cursor position within an existing formula is achieved with the arrow keys. \LaTeX{} uses small rectangles to indicate places where something can be inserted. The arrow keys can be used to navigate between parts of a formula. Pressing Space will leave a formula construct (a square root \(\sqrt{2}\), or parentheses \((f)\), or a matrix \[
\begin{bmatrix}
1 & 2 \\
3 & 4
\end{bmatrix}
\]). Pressing Escape will leave the formula, placing the cursor after
5. Mathematical Formulas

the formula. Tab can be used to move horizontally in a formula; for example, through the cells of a matrix or the positions in a multi-line equation.

Space, printed in this document as “ " , seems to do nothing in a formula, since it does not add a space between characters, but it does exit a nested structure. For this reason, you have to be careful about using Space. For example, if you want $\sqrt{2x+1}$, type $\sqrt{2x+1}$ and not $\sqrt{2x+1}$, since in the latter case only the $2x$ will be under the square root sign: $\sqrt{2x+1}$.

You can leave many parts of a formula, like this matrix, partially filled in, such as:

$$
\begin{pmatrix}
\lambda_1 \\
\vdots \\
\lambda_n
\end{pmatrix}
$$

If you leave a fraction only partially filled in, or a subscript with nothing in it, the results will be unpredictable, but most constructs don’t mind.

5.1.2. Selecting Text

You can select text within a formula in two different ways. Place the cursor at one end of the string of text you want, and press Shift and a cursor movement key to select text. It will be highlighted as with regular text selection. Alternatively, you can select text with the mouse in the usual way. That text can then be cut or copied, and then pasted within any formula, but not in a normal text region in LYX.

5.1.3. Exponents and Subscripts

You can use the math panel to add superscripts or subscripts (buttons $^{\circ}$ and $_{\circ}$), but it is often much easier to use a command. To get $x^2$, type in a formula $x^{2\odot}$. The final Space puts the cursor back down on the base line of the expression. If you type $x^{2\odot}$, you will get $x^2y$, to get $x^2y$, type $x^{2\odot}y$. If you use characters in the superscript, that could be accented with the circumflex “^”, you have to use an extra Space to separate the circumflex and the character. For example, if you want $x^a$, type $x^{^a\odot}$. Subscripts are similar: To get $a_1$, type $a_{_1\odot}$.

5.1.4. Fractions

Create a fraction either with the command \frac or by using the icon $\frac{1}{2}$ in the Math Panel. You will be presented with an empty fraction. The cursor is above the fraction line. To move it to the bottom, simply press Down. To move back up, press
5.1. Basic Math Editing

Up. Any math structure can be placed in a fraction, as this example shows:

\[
\begin{bmatrix}
1 \\
\begin{pmatrix}
2 & 3 \\
4 & 5
\end{pmatrix}
\end{bmatrix}
\]

5.1.5. Roots

Roots can be created using the Math Panel buttons $\sqrt[n]{\text{expression}}$ or the commands \texttt{\sqrt} or \texttt{\root}. With the command \texttt{\root} you can produce roots of higher orders, like cube roots, while \texttt{\sqrt} always produces a square root.

5.1.6. Operators with Limits

Sum ($\sum$) and integral ($\int$) operators are very often decorated with limits. These limits can be entered in LYX by entering them as you would enter a super- or subscript, directly after the symbol. The sum operator will automatically place its “limits” over and under the symbol in displayed formulas, and to the side in inline formulas, as in

\[
\sum_{n=0}^{\infty} \frac{1}{n!} = e,
\]

versus

\[
\sum_{n=0}^{\infty} \frac{1}{n!} = e
\]

Integral signs, however, will place the limits to the side in both formula types.

All operators with limits will be automatically re-sized when placed in display mode. The placement of the limits can be changed by placing the cursor directly behind the operator and using the menu Edit $\rightarrow$ Math $\rightarrow$ Change Limits Type or entering Alt+M L.

Certain other mathematical expressions also have this “moving limits” feature, such as

\[
\lim_{x \to \infty} f(x),
\]

which will place the $x \to \infty$ underneath the “lim” in display mode. In inline formulas it looks like this: $\lim_{x \to \infty} f(x)$.

Note that the lim-function was entered as the function macro $\texttt{\lim}$. Have a look at section 5.1.9 for an explanation of function macros.

5.1.7. Math Symbols

Most math symbols can be found in the Math Panel under one of several categories; including Greek, Operators, Relations, Arrows. There are also the additional symbols provided by the American Mathematical Society (AMS).
5. Mathematical Formulas

If you know the LaTeX-command for a construct or symbol you wish to use, you don’t have to use the Math Panel: you can type the command directly into the formula. LYX will convert it to the corresponding symbol or construct.

5.1.8. Altering Spacing

You may want to create spaces that differ from the standard spacing that \LaTeX provides. To do this, press Ctrl+Space or use the Math Panel button \textasciitilde. This generates a small space, and shows a small marker on the screen. For example, the sequence a Ctrl+Space b: ab appears in LYX as \textasciitilde ab. You can change the space to different sizes when you set the cursor behind the space marker and enter space again several times. With every space enter the size will be changed. Some markers for the space size appear red in LYX, because they are negative spaces. Here are two examples:

a Ctrl+Space b and 3×Space: a b

a Ctrl+Space b and 5×Space: \textasciitilde ab

5.1.9. Functions

The Math Panel contains under the button \textasciitilde a number of function macros, such as \textasciitilde sin, \textasciitilde lim, etc. (you can also insert them in a formula by typing \textasciitilde sin etc.). Standard mathematical practice is that functions are printed upright to avoid confusions, because sin does normally mean s · i · n.

Using the function macros will also produce correct spacing around the function: a \textasciitilde sin x is different from asinx.

For some mathematical objects, like limits, the macro changes where subscripts are placed, as described in section 5.1.6.

5.1.10. Accents

In a formula you can insert accented characters in the same way as in text mode. This may depend on your keyboard, or the bindings file you use. You can also use \LaTeX commands, for example, to enter \textasciitilde a even if your keyboard doesn’t have the circumflex enabled. Our example is entered by typing \textasciitilde hat a in a formula. Table 5.1 shows the equivalences between the accent names and the commands.

You can choose one of the accents by selecting an item from the Frame decorations symbol set button \textasciitilde in the math panel; this will apply to any selection you have made within a formula too.
5.2. Brackets and Delimiters

There are several brackets available through \LaTeX. For some purposes, using just the keys \[ () \{ \} \| \langle \rangle \] should suffice. But if you want to surround a large structure, like a matrix or a fraction, or if you have several layers of brackets, it is better to use the math toolbar delimiter icon. For example, if you construct the brackets around a matrix in this way:

\[
\begin{pmatrix}
1 & 2 \\
3 & 4
\end{pmatrix}
\]

it makes it easier to see the layers of parentheses. Below, the expression on the left was entered using the delimiter icon and the expression on the right was entered using the () keys.

\[
\frac{1}{1 + \left( \frac{1}{1 + \left( \frac{1}{1 + x} \right)} \right)} \quad \quad \frac{1}{1 + \left( \frac{1}{1 + \left( \frac{1}{1 + x} \right)} \right)}
\]

If you use the delimiter icon, the parentheses, and other brackets from that menu will automatically re-size to accommodate the size of what is inside.

To construct brackets click on the button for the bracket you want on the left side and right side. If you use the option Keep matched, the selected bracket type will be used for the left and the right side. The selection will be shown as \TeX code. If you want one side not to have a bracket, use (none). It will appear in \LaTeX with a dotted line, but nothing will be printed.

If you want to place brackets around existing math structures, like a square root, you can do so by first highlighting (selecting) the structure that is to go inside the brackets. Then choose the appropriate brackets for left and right and click on Insert.

<table>
<thead>
<tr>
<th>Name</th>
<th>Command</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>circumflex</td>
<td>\hat</td>
<td>̀a</td>
</tr>
<tr>
<td>grave</td>
<td>\grave</td>
<td>̀a</td>
</tr>
<tr>
<td>acute</td>
<td>\acute</td>
<td>̀a</td>
</tr>
<tr>
<td>umlaut</td>
<td>\ddot</td>
<td>̀a</td>
</tr>
<tr>
<td>tilde</td>
<td>\tilde</td>
<td>̀a</td>
</tr>
<tr>
<td>dot</td>
<td>\dot</td>
<td>̀a</td>
</tr>
<tr>
<td>breve</td>
<td>\breve</td>
<td>̀a</td>
</tr>
<tr>
<td>caron</td>
<td>\check</td>
<td>̀a</td>
</tr>
<tr>
<td>macron</td>
<td>\bar</td>
<td>̀a</td>
</tr>
<tr>
<td>vector</td>
<td>\vec</td>
<td>̀a</td>
</tr>
</tbody>
</table>
5. Mathematical Formulas

The most common bracket combinations (parentheses, square brackets, and braces, on both sides) can be entered more quickly using keyboard shortcuts. For example, to insert a pair of parentheses, select the structure and enter Alt+M ().

5.3. Arrays and Multi-line Equations

Matrices are entered in LyX using the Math Panel matrix button. It will open a dialog for you to choose the number of rows/columns. Here is an example:

\[
\begin{pmatrix}
1 & 2 & 3 \\
4 & 5 & 6 \\
7 & 8 & 9
\end{pmatrix}
\]

The parentheses aren’t automatic, but you can add them as described in section 5.2. When you construct the matrix, you can decide whether the column entries will be left-, right-, or center-justified. This alignment is set in the box Horizontal with the letters “l”, “r”, and “c”. LyX proposes a “c” for every column as default. For example, the sequence “lcrc” means that the first column will be left-justified, the second will be centered, and the third column will be right-justified, because each letter corresponds to the relevant column. The result will look like this:

<table>
<thead>
<tr>
<th>this column</th>
<th>this column</th>
</tr>
</thead>
<tbody>
<tr>
<td>has left alignment</td>
<td>has right alignment</td>
</tr>
</tbody>
</table>

You can add more rows to an existing matrix by entering Ctrl+Return while the cursor is in the matrix. Adding or deleting columns can be done via the menu Edit→Math or the math toolbar.

There are other arrays used in formulas, such as distinctions of cases. It can be created with the menu Insert→Math→Cases Environment or the command \cases. Here is an example:

\[
f(x) = \begin{cases}
-1 & x < 0 \\
0 & x = 0 \\
1 & x > 0
\end{cases}
\]

Multi-line formulas are created when you press Ctrl+Return within a formula. In an empty formula you can see that three blue boxes appear, one for each column. When you press Ctrl+Return in a non-empty formula, the part before the relation sign (equal sign “=” etc.) will be inserted automatically in the first column, the relation sign is in the second column, and the rest in the third column. A new row is created by every
5.4. Formula Numbering and Referencing

Further entry of Ctrl+Return. Multi-line formulas are always displayed formulas. Here is an example:

\[ a^2 = (b^2 + c^2)(b^2 - c^2) \]
\[ a = \sqrt{b^4 - c^4} \]  

(5.1)

Note that the middle column is designed for relation signs so structures in this column will be printed in a smaller size:

\[
\begin{array}{ccc}
A & & A \\
\hline
B & A & B \\
\end{array}
\]

The multi-line formula type described here is called eqnarray. There are other multi-line types more suitable for certain situations, for example if you want a better inter-line spacing than in formula (5.1). The other types are described in section 5.7.2.

5.4. Formula Numbering and Referencing

To number a formula, set the cursor in the formula and use the menu Edit → Math → Number Whole Formula or the shortcut Alt+M N. The formula number appears in \LaTeX\ within parentheses. The number shown is temporary and may be different when the output is generated. The placement and format of the formula number in the output depends on the document class. In this document the number is printed together with the chapter number, separated by a dot:

\[ 1 + 1 = 2 \]  

(5.2)

Using Alt+M N in a numbered formula will switch off the numbering. You can only number displayed formulas.

Multi-line formulas can be numbered line by line: Using the menu Edit → Math → Number This Line or the shortcut Alt+M Shift+N will only toggle the numbering of the line where the cursor is:

\[ 1 = 3 - 2 \]  
\[ 2 = 4 - 2 \]  
\[ 4 \leq 7 \]  

(5.3)  

(5.4)

To number all lines use the shortcut Alt+M N.

Every displayed formula can be referenced by its number using a label. A label is inserted with the menu Insert → Label (toolbar button \(\ddagger\)) when the cursor is in the formula. This opens a dialog to enter the label. It is recommended that you use the suggested “eq:” as the first part of the label, because this helps later to identify the
5. Mathematical Formulas

label type when you have many labels in your document. We inserted in the following example the label “eq:tanhExp” in the second line:

\[
\tanh(x) = \frac{\sinh(x)}{\cosh(x)} = \frac{e^{2x} - 1}{e^{2x} + 1} \quad (5.5)
\]

Every labeled line is automatically numbered. Therefore the label is shown behind the formula number. You can reference a labeled formula using the menu Insert > Cross Reference (toolbar button \(\text{\textasciitilde}\)). A dialog appears to choose a label you want to refer to. The reference appears in LyX as a gray cross-reference box and in the output as the formula number:

This is a cross-reference to equation (5.5).

The properties of LyX’s cross-reference box are described in section 6.1. To delete a label, set the cursor at the end in the labeled formula and press Del.

5.5. User defined math macros

LyX allows you to define macros for formulas which is very useful when you have equations of the same form in a document several times. Math macros are explained in section Math Macros of the Math manual.

5.6. Fine-Tuning

5.6.1. Typefaces

The standard font for text is italic, for numbers the standard is roman. To set a font in a formula, use the Math Panel button \(\mathbb{A}\), or enter its command, listed in table 5.2, directly.

**Note:** You can only print capital letters in the typefaces Blackboard and Calligraphic.

When you use a typeface, a blue box is inserted in the formula. Every character in this box will be printed in this typeface. Pressing Space within the box will set the cursor outside, so that you have to use a protected space when you need a space in the box. Here is an example where “N” in Blackboard denotes the set of numbers:

\[
f(x) = \sqrt{x} ; x \in \mathbb{N}
\]

The typefaces are nestable, which can cause confusion. You can, for example, put a character in Fraktur in a box for Typewriter: \(\text{\textit{abcde}}\)

So it is better not to use this feature.
5.6. Fine-Tuning

Table 5.2.: Typefaces and the corresponding commands.

<table>
<thead>
<tr>
<th>Font</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Roman</td>
<td>\texttt{\textbackslash mathrm}</td>
</tr>
<tr>
<td>Bold</td>
<td>\texttt{\textbackslash mathbf}</td>
</tr>
<tr>
<td>Italic</td>
<td>\texttt{\textbackslash mathit}</td>
</tr>
<tr>
<td>Typewriter</td>
<td>\texttt{\textbackslash mathit}</td>
</tr>
<tr>
<td>BLACKBOARD</td>
<td>\texttt{\textbackslash mathbb}</td>
</tr>
<tr>
<td>Fraktur</td>
<td>\texttt{\textbackslash mathfrak}</td>
</tr>
<tr>
<td>CALLIGRAPHIC</td>
<td>\texttt{\textbackslash mathcal}</td>
</tr>
<tr>
<td>SansSerif</td>
<td>\texttt{\textbackslash mathsf}</td>
</tr>
</tbody>
</table>

The typefaces have no effect on Greek letters: $\alpha\beta\gamma$
You can only print them emboldened using the command \texttt{\textbackslash boldsymbol}, which works like the other typeface commands: \texttt{\textbackslash boldsymbol}$\alpha\beta\gamma$

\texttt{\textbackslash boldsymbol} works for all symbols, letters, and numbers.

A number of other font options are available as well, in the menu Edit $\rightarrow$ Math $\rightarrow$ Text Style.

5.6.2. Math Text

Typefaces are useful for entering some characters in some given font, but not for text. For typing longer pieces of text use the math text, which is obtained using the entry Normal text mode of the Math Panel button $\mathbb{E}$. Math text appears in \LaTeX{} in black instead of blue. You can use spaces and accents in math text as in normal text. Here is an example:

$$f(x) = \begin{cases} 
x & \text{if I say so} \\
-x & \text{under Umständen} 
\end{cases}$$

5.6.3. Font Sizes

There are four font styles (relative sizes) used in math-mode, which are automatically chosen in most situations. These are called textstyle, displaystyle, scriptstyle, and scriptscriptstyle. For most characters, textstyle and displaystyle are actually the same size, but fractions, superscripts and subscripts, and certain other structures, are set larger in displaystyle. Except for some operators, which resize themselves to accommodate various situations, all text will be set in the styles that \LaTeX{} thinks are appropriate. These choices can be overridden by using the math panel button $\mathbb{E}$. A box for the size will be created in which you can insert the math structure. For
example, you can set $\frac{1}{2}$, which is normally in \textstyle, larger in \displaystyle: $\frac{1}{2}$. The four styles are used in the following example:

\text{displaystyle}, \text{textstyle}, \text{scriptstyle}, \text{scriptscriptstyle}.

All these math-mode font sizes are relative so that if the whole math inset is set in a particular size with the menu \text{Edit} \rightarrow \text{Text Style}, all sizes in the formula will be adjusted relative to this size. Similarly, if the base font size of the document is changed, all fonts will be adjusted to correspond. As an example here is a formula in the font size “largest”:

$$e = \sum_{n=0}^{\infty} \frac{1}{n!}$$

5.7. \LaTeX

\LaTeX\ supports the packages provided by the American Mathematical Society (AMS) that are in common use.

5.7.1. Enabling AMS-Support

You can make the facilities of the AMS-packages explicitly available in the document by selecting the checkbox \text{Use AMS math package} in the \text{Document} \rightarrow \text{Settings} dialog under \text{Math Options}. AMS is needed for many math-constructs; so when you get \LaTeX-\text{errors} in formulas, ensure that you have enabled AMS.

5.7.2. AMS-Formula Types

AMS-\LaTeX\ provides a selection of different formula types. \LaTeX\ allows you to choose between \text{align}, \text{alignat}, \text{flalign}, \text{gather}, and \text{multiline}. We refer you to the AMS-documentation, [12], for an explanation of these formula types.
6. More Tools

6.1. Cross-References

One of \LaTeX{}’s strengths is cross-references. You can reference every section, float, footnote, formula, and list in the document. To reference a document part, you have to insert a label into it. The label is used as an anchor and a name for the reference. We want for example to refer to the second item of the following list:

1. First item
2. Second item
3. Third item

First we insert a label into the second item with the menu Insert \textup{Label} or by pressing the toolbar button \textcircled{\textup{Label}}. A gray label box like this: \textit{enu:Second-item} is inserted and the label window pops up asking for the label text. \LaTeX{} offers as text the first words of the item with a prefix, in our case the text “enu:Second-item”. The prefix “enu:” stands for “enumerate”. The prefix depends on the document part where the label is inserted; for example, if you insert a label into a section heading, the suggested prefix will be “sec:”.

To reference the item, we refer to its label using the menu Insert \textup{Cross-Reference} or the toolbar button \textcircled{\textup{Cross-Reference}}. A gray cross-reference box like this: \textit{Ref. enu:Second-item} is inserted and the cross-reference window appears showing all the labels in the document. We can now sort the labels alphabetically and then choose the entry “enu:Second-item”. At the position of the cross-reference box the item number will appear in the output.

As an alternative to Insert \textup{Cross-Reference}, you can right-click on a label and in the popup menu select \textit{Copy as Reference}. The cross-reference to this label is now in the clipboard and can be pasted to the actual cursor position via the menu Edit \textup{Paste} (shortcut Ctrl+V).

Here is our cross-reference: Item 2

It is recommended to use a protected space\footnote{described in section 3.5.1} between the cross-reference name and the cross-reference to avoid ugly line breaks between them.

There are six formats of cross-references:
6. More Tools

**<reference>:** prints the number, this is the default: 4.2

**(<reference>):** prints the number within two parentheses, this is the style normally used to reference formulas, especially when the reference name “Equation” is omitted: (5.5)

**<page>:** prints the page number: Page 74

**on page <page>:** prints the text “on page” and the page number: on page 74

If the label is on the same page, it prints “on this page”; if the label is on a facing page in a two-sided document, it prints “on the facing page”; if it is on the previous page which is not a facing page, it prints “on the previous page”; if it is on the next page which is not a facing page, it prints “on the next page”. The wording of the printed text also depends on the used document class.

**<reference> on page <page>:** prints the number, the text “on page” and the page number: 4.2 on page 74

If the label is on the same page, this format behaves like <reference>; otherwise it behaves like on page <page>.

**Formatted reference:** prints a self defined cross-reference format.

**Note:** This feature is only available when you have the \texttt{prettyref} or \texttt{refstyle} installed.

You can select which \LaTeX-package should be used for this feature by setting the option \texttt{Use refstyle (not prettyref) for cross-references} in the menu \texttt{Document	extgreater{}Settings	extgreater{}Document Class}. The package \texttt{refstyle} is the default and preferred because \texttt{prettyref} supports only English documents. The format is specified by using the command \texttt{\newrefformat} (prettyref) or \texttt{\newref} (refstyle) in the \LaTeX-preamble of the document. For example, if you are using \texttt{refstyle}, then redefining all references to figures (which have the label shortcut “fig”) can be done with this command

\begin{verbatim}
\newref{fig}{refcmd={Image on page \pageref{#1}}}
\end{verbatim}

Please note that neither \texttt{prettyref} nor \texttt{refstyle} (nor LyX itself) defines reference formats for all available types. This is especially true for the wide variety of mathematical ‘theorem’ environments. So if you want to make formatted references to, say, Propositions, then you will need to define the relevant format yourself. For \texttt{prettyref}, you might do so as follows:

\begin{verbatim}
\newrefformat{prop}{Proposition \ref{#1}}
\end{verbatim}

For more information about the defining formatted references, have a look at the package documentations, [18, 19].

**Textual reference:** prints the caption or the name of the reference: Two distorted images.

The number and current page of the referenced document part in the output is automatically calculated by \LaTeX. The varieties are adjusted in the field \texttt{Format} of the cross-reference window, that appears when you click on the cross-reference.
You can only use the style \texttt{<reference>} to reference numbered document parts, while the reference style \texttt{<page>} is always possible.

If you want to reference a section, put the label in the section heading; for floats put the label in the caption; for footnotes put the label in it. Referencing formulas is explained in section 5.4.

Right-clicking on a cross-reference opens a context menu. The entry \texttt{Go to Label} sets the cursor before the referenced label. This entry will be renamed in the context menu of the label to \texttt{Go Back} so that you can use it to set the cursor back to the cross-reference. You can also go back with the toolbar button \texttt{\rightleftharpoons}.

You can change labels at any time. References to the changed label will automatically be updated so that you do not need to think about this.

If a cross-reference refers to a non-existent label, you will see in \LaTeX\ “BROKEN” in the cross-reference label and two question marks in the output instead of the reference.

References are described in detail in the section \textit{Referencing Floats} of the \textit{Embedding Objects} manual.

### 6.2. Table of Contents and other Listings

#### 6.2.1. Table of Contents

The Table of Contents (TOC) is inserted with the menu \texttt{Insert} \texttt{List/TOC} \texttt{Table of Contents}. It is displayed in \LaTeX\ as a gray box. If you click on it, the Outline window appears, showing you the TOC entries as outline, which allows you to move and re-arrange sections in your documents. So this operation is an alternative to the menu \texttt{View} \texttt{Outline Pane} that is described in section 2.5.1.

The TOC in the document output lists every numbered section automatically. If you have declared a short title for a section heading, as described in section 3.3.4.4, it will be used in the TOC instead of the section heading. Section 3.3.4.3 describes how the level is adjusted that defines which section types are listed in the TOC. Unnumbered sections are not listed in the TOC.

#### 6.2.2. List of Figures, Tables, Listings and Algorithms

Table, figure, listings and algorithm lists are very much like the table of contents. You can insert them via the \texttt{Insert} \texttt{List/TOC} submenus. The list entries are the float captions and the float number.
6. More Tools

6.3. URLs and Hyperlinks

6.3.1. URLs

Links to web pages or email addresses can be inserted via the menu \texttt{Insert\textgreater URL}.

Here is an example URL: LyX’s homepage: \url{http://www.lyx.org}

You cannot change the style of the link text, the URL text will always be in the style \texttt{Typewriter}. To be able to format the URL text, use hyperlinks as explained in the next subsection.

\textbf{Note:} URLs must not end with a backslash, otherwise you get \LaTeX{} errors.

6.3.2. Hyperlinks

Hyperlinks can be inserted with the menu \texttt{Insert\textgreater Hyperlink} or with the toolbar button \textbullet{}. The appearing dialog has two fields: \texttt{Target} and \texttt{Name}. The name is the printed text for the hyperlink. The hyperlink type can be a weblink like this: LyX’s homepage, an Email address like this: lyx-docs mailing list, or a link to a file.

You can start applications via a hyperlink when you insert a weblink by adding the prefix \enquote{run:} to the link target.

Hyperlinks will automatically be hyphenated if necessary in the PDF output, and become clickable in the DVI and PDF-output. To set the format of the link text, highlight the hyperlink inset and use the text style dialog. This is for example a hyperlink with bold sans serif text: \texttt{LyX’s homepage}

The link text color can be changed, when the option \texttt{Color links} is set in the PDF Properties dialog (menu \texttt{Document\textgreater Settings\textgreater PDF Properties}). The link text is for example set in this document to blue by adding the option \texttt{urlcolor=blue} to the field \texttt{Additional options} in the PDF Properties dialog.

6.4. Appendices

Appendices are created with the menu \texttt{Document\textgreater Start Appendix Here}. This menu sets the document from the current cursor position to the end as the appendix part of the book. This part is marked with a red borderline.

Every chapter (or section) within the appendix part is treated as an appendix, numbered with a capital Latin letter. The appendix subsections are numbered with this letter followed by a dot and the subsection number. All appendix sections can be referenced as if they were normal sections, here two examples:

Appendix E; Appendix A.1.13
There are two ways of generating the bibliography in a LyX-document. You can include a bibliography database, which is explained in the next subsection, or you can insert the bibliography manually, using the paragraph environment **Bibliography**, which was described in section 3.3.9.2. If you want anything other than the numerical citations that are used in this document, like author-year citations, then you must use a bibliography database.

### 6.5.1. The Bibliography Environment

Within the **Bibliography** environment, every paragraph begins with a gray bibliography box labeled with a number. If you click on it, you will get a dialog in which you can set a **Key** and a **Label**. The key is the symbolic name by which you will refer to this bibliography entry. For example, our second entry in the bibliography is a book about \LaTeX\ and we used “latexcompanion”, a short form of its title, as the key.

You can cross-reference a bibliography entry using the menu **Insert > Citation** or the toolbar button 📖. A citation reference box is inserted and a citation window will appear containing the available citations. Select one or more keys from the list and **Add** them. Then press **OK**. The citation reference box will be labeled with the referenced key(s). If you click on the box, the citation window will appear and you can change the reference.

Citation references appear in the output as the number of the bibliography entry with surrounding brackets. If you set a **Label** for the entry, the label will appear instead of the number. Here are two examples; the first without a label, the second with the label “Credits”:

Have a look at the \LaTeX\ Companion Second Edition: [1]

The LyX-Team members are listed in the Credits: [Credits]

To align all entries in the bibliography environment you can set a longest label via the menu **Edit > Paragraph Settings** (toolbar button 📖). All entries are then indented in the output by the width of the given label.

### 6.5.2. Bibliography databases (\texttt{BibTeX})

Bibliography databases are useful if you use the same bibliography in different documents. It also makes it very easy to have a uniform layout for all bibliography

---

2 Known under the name “\texttt{BibTeX} database”.

3 They are also useful for keeping a database of articles and notes concerning them. Most of the database programs mentioned below allow you to store annotations and reviews along with bibliographical information.
entries. You can collect the bibliography of all relevant books and articles of your working field in a database. This database can be used for different documents, and by default only the entries cited in a particular document will appear in the bibliography list for that document. This relieves you of the need to keep track of which articles and books you have cited.

The database is a text file with the file extension "*.bib", containing the bibliography in a special format. The format is explained in [8] and in the \LaTeX\ books ([MG04, KD03, Lam94]). The file can be created using any text editor, but normally one uses a special program to create and edit the entries in the database. A list of such programs is maintained on the LyX Wiki at http://wiki.lyx.org/BibTeX/Programs.

To use a database, use the menu Insert ➤ List/TOC ➤ \LaTeX\ Bibliography. A gray box will be inserted and a window appears. In this window you can add one or more databases and select a style file. The option Add bibliography to TOC adds a table of contents entry for the bibliography. In the Content drop box you can select whether to include all the entries in the database in the document or just the cited references.

The style file is a text file with the file extension "*.bst" that controls how the bibliography entries will appear. Your \LaTeX\ distribution should provide several of these, and many publishers provide their own style files, so that you don’t have to take care of the layout. It is of course possible to write your own style file, but this is something for experts.\footnote{For information on how this is done, have a look at http://mirrors.ctan.org/biblio/bibtex/contrib/doc/btxhak.pdf.}

Inserting a citation reference works as described in the previous section.

To generate the bibliography from a database, LyX uses the program \BibTeX. You can choose which of its variants should be used by LyX as the Processor either in Document ➤ Settings ➤ Bibliography or in Tools ➤ Preferences ➤ Output ➤ \LaTeX. The following variants are possible:

- **biber** provides full Unicode support, unlimited memory, but does not work with other bibliography packages (e.g. natbib), only with the package biblatex; recommended for multilingual texts and for languages that don’t use Latin letters

- **bibtex** the standard; does not allow special characters in bibliography entries that are not possible to encode in a 7-bit encoding, limited memory, works with all bibliography packages, except biblatex

- **bibtex8** allows all characters that are possible to encode in an 8-bit encoding, larger memory than bibtex, works with all bibliography packages

\BibTeX can be controlled with options that you can add below the specification of the variants. Before adding options, it is strongly recommended that you read the manual of \BibTeX [7].
When you select the option Sectioned bibliography in the Document > Settings > Bibliography dialog, it is possible to have multiple and sectioned bibliographies. This and other options are explained in detail in section Customizing Bibliographies with Bib\TeX of the Additional Features manual.

We use two bibliographies in this document to show the difference between the two methods of creating them. As you can see, the bibliography that is created from a database lists only the database entries that are referenced in the document. We used the style file alphadin.bst to get the complicated German reference key scheme in the bibliography.

6.5.3. Citation Format

In the citation reference dialog you can set a special citation format. For this feature you need to enable the option Natbib in the Document > Settings dialog under Bibliography. Setting a citation style for a reference will overwrite the default. For the global citation format use the Bib\TeX style files as explained in the previous section.

You can also set text to appear before or after a citation reference, in the citation reference window. Here is an example where the text “Chapter 3” appears after the reference:

Have a look at [1, Chapter 3].

6.6. Index

An index entry is created if you use the menu Insert > Index Entry or the toolbar button \indexentry. A box is inserted containing the text that appears in the index. The word where the cursor is in or the currently highlighted text is proposed by \LaTeX as the index entry.

The index list is inserted in the document with the menu Insert > List/TOC > Index List. A light blue box labeled “Index” will show the place where the index is printed in the output. The index list box is not clickable like other \LaTeX-boxes.

We give a short overview of the index commands in the next subsections. For a detailed description of \LaTeX’s index mechanism, have a look at one of the \LaTeX books [1, 2, 3].

6.6.1. Grouping Index Entries

Index entries are often grouped to offer the reader a fast search in the index. We want to group for example the index entries for itemized and enumerated lists under
the entry “Lists”. First we create the entry “Lists” in section 3.3.6. In the text field for the itemized list index entry in section 3.3.6.2, we insert the command

Lists ! Itemize

and the command

Lists ! Enumerate

for the enumerated list in section 3.3.6.3.

The exclamation mark “!” marks the grouping levels. You can have three levels; every index level is indented a bit more. An index entry for the higher levels is not required. If we don’t have an index entry for “Lists”, it will be printed anyway, but without a page number.

6.6.2. Page Ranges

Normally an index entry will appear with the page number of the indexed section. But sometimes you want to index more pages under the same entry. For example, if we want to index the paragraph environments, we create an index entry in section 3.3 with the command

Paragraph environments|

and another entry at the end of section 3.3.10.1 with the command

Paragraph environments|

The commands “|” and “|” respectively start and end the index range. You can also add the same index entry at different places in the document. They appear in the output under one entry with a comma separated list of the pages of the indexed document parts. An example is the index entry “Document ! Settings”.

6.6.3. Cross referencing

It is also possible to refer to another index entry. We referred for example in the index entry “GIF” (in section 4.4.1) to the index entry “Image formats” in the same section using the entry

GIF|see{Image formats}

where the braces have to be inserted as \TeX Code. The text within the braces is the referenced entry. The reference will appear in the output without a page number.

6.6.4. Index Entry Order

If you use accented characters in the index entry the entries might not follow the rules for the index order. The index entries are sorted alphabetically but \TeX does

\footnote{The index generating is done in the background by an extra program, see section 6.6.6.}

94
not know how to sort accents in different languages. We have created as an example
the three dummy index entries “maison”, “maîs”, and “maître”. They will be sorted
in the order maïs, maître, maison but we want the order maïs, maison, maître. To
achieve this, we use the command

\texttt{previous entry@current entry}

In our case we want to have “maison” after “maîs” and write therefore for the index
entry of maison:

\texttt{maîs@maison}

The previous entry need not be a real existing entry. You can also use another word
to tell \LaTeX{} the entry order. See the next subsection for an example.

In some cases the index entry order is not correct when you are using the program
\texttt{makeindex} to generate the index (see section 6.6.6). \texttt{makeindex} would for example
print the index entry for the \LaTeX-package aeguill in section 3.7.3 after the index
entries of the other \LaTeX-packages although all these index commands start with
\texttt{\LaTeX-packages !"}. The reason is that the index entry for aeguill is in a footnote.
To fix this \texttt{makeindex} bug, add these commands to the preamble of your document:

\begin{verbatim}
\let\OrgIndex\index
\renewcommand*{\index}[1]{\OrgIndex{#1}}
\end{verbatim}

\textbf{6.6.5. Index Entry Layout}

You can change the appearance of index entries via the text style dialog. You can
also format the page number using the character “|” followed by a \LaTeX-command
without a backslash. We can write for example

\texttt{italic page number:|textit}

\texttt{to get the page number in italic. Normally all \LaTeX-commands begin with a back-
slash, but in this special case “|\texttt{command}” means \texttt{\textbackslash command\{page number\}.}
Have a look at section 6.10.2 to learn more about the \LaTeX-syntax.

\textbf{Note:} Formatting single index entries only works when you use the program \texttt{makein-
dex} to generate the index, see section 6.6.6. If you use \texttt{xindy}, this will not work for
anything other than bold or italic text. This is because \texttt{xindy} requires you to define
semantic elements before they can be used, see [1, p. 678 ff.] for details.

In general, we encourage you to not format page numbers directly as shown above.
Instead, you should define a macro in the preamble and use that. Maybe you want
all page references italic that refer to a definition of the indexed term, so that users
can easily find definitions. If so, put the following in the preamble

\begin{verbatim}
\newcommand{\IndexDef}[1]{\textit{#1}}
\end{verbatim}
and write

\texttt{\textbf{my entry|IndexDef}}

in the index entry. The advantage is that, if you change your mind later or if your publisher insists that definitions must not be italic but bold, you just need to change the macro in the preamble, not every single index entry.

You can also change the layout for the whole index. For example, we marked the index list box of this document as bold to get a bold font for all index entries. For more advanced tasks you have to set up a so-called \textit{Index Style File}, see the \texttt{makeindex} or \texttt{xindy} documentation for details, [9, 11].

### 6.6.6. Index Program

If the index generation program \texttt{xindy} is installed, \LaTeX\ uses it for index generation; otherwise the program \texttt{makeindex}, the program that is part of every \LaTeX\ distribution, is used.\footnote{\texttt{Makeindex} is very old, no longer under development and has many pitfalls, notably that it was developed with only the English language in mind. So it fails to sort anything other than a monolingual English text correctly. We have shown above how to fix this sorting. However, if you are writing in another than the English language, consider to use \texttt{xindy}.} Both programs can be controlled by options that can be set in \LaTeX\’s preferences dialog, see section C.6.2. The available options are listed and explained in [10, 11]. In this dialog, you can also specify an alternative program to generate the index.

If you need specific options or an alternative index program only for a given document, you can define the program and/or the options in Document\textellipsis\ Settings\textellipsis\ Indexes. This is especially useful if you need to pass language-specific options to the index program or if you need a specific layout style.

### 6.6.7. Multiple Indexes

In many fields it is common to have more than one index. For instance, you might need to set up a separate “Index of Names” next to the standard index. \LaTeX\ does not provide this possibility out of the box, but there are packages that add this feature. \LaTeX\ uses the \texttt{splitidx} package to generate multiple indexes. The package is included in all recent \LaTeX\ distributions.\footnote{If yours does not ship it, consult the \TeX\ catalogue, [5]. Note that the package does not only consist of a \LaTeX\ style, but it also includes specific preprocessor programs that need to be installed as well. Please consult the package’s manual for details.}

To set up \LaTeX\ for the use of multiple indexes, go to Document\textellipsis\ Settings\textellipsis\ Indexes and select the option Use multiple Indexes. Note that the list Available Indexes already contains the standard index “Index”. To add further indexes, add the name of the index (in the form that should also appear as a heading) to the New input field and...
press the Add button. The new index now also appears in the list. If you like, you can attribute an alternative \LaTeX label color to the new index.

Once the document changes have been applied, you can find the new index list in Insert\texttt{List/TOC} and the Insert menu has a separate entry for each of the defined indexes. The workflow is basically the same as for the default index, but there are additional features:

- If you want to change the attribution of a specific index entry, right-clicking on the entry’s label will open a dialog where you can do that.
- By right-clicking on an index, you can change its type. Furthermore, you can specify an index to be a “Subindex.” If you do that, the heading of that list will be decreased by one level. For example, if you use a book class, where the standard index heading is defined as a chapter, subindexes will be defined as sections and can thus be nested to the non-subindexes.

\section*{6.7. Nomenclature/Glossary}

Sometimes you need to provide a list of technical terms or symbols that are mentioned in your document with a brief explanation of them – a so called nomenclature or glossary.

To be able to create nomenclatures or glossaries, you need the \LaTeX package \texttt{nomencl} installed. You find it in the \TeX catalogue, [5] or in the package manager of your \LaTeX-system.

A nomenclature entry is created if you place the cursor after a symbol entry and then use the menu Insert\texttt{Nomenclature Entry} or the toolbar button \textbullet\textbullet. A gray box labeled “Nom” is inserted and a window pops up asking for the nomenclature entry.

A nomenclature entry consists of two main entries. The first is the term or Symbol that you wish to define. The second is the Description of the term or symbol.

\textbf{Note:} You have to enter valid \LaTeX-code for all fields of the nomenclature dialog.

\subsection*{6.7.1. Nomenclature Definition and Layout}

If you have symbols in formulas, you have to define them in the Symbol field as \LaTeX-formulas. For example to get “$\sigma$”, insert this:

\begin{verbatim}$\sigma$\end{verbatim}

The “$” character starts/ends the formula. The \LaTeX-command for the Greek letter is the name of the letter beginning with a backslash “\”. For capital Greek letters, start the command also with a capital letter, like \texttt{\Sigma}.

(A short introduction to the \LaTeX-syntax is given in section 6.10.2.)
6. More Tools

You cannot use the Text Style dialog to format the description text; you have to use \TeX\ commands. For example the description of the nomenclature entry for the “σ” in this document is:

**dummy entry for the character \textsf{sigma}**

The command \textsf sets the fonts to sans serif. To get **bold** font use the command \textbf, for typewriter use \texttt, for *emphasized* use \textit.

To customize the appearance of all symbols add e.g. the command

\begin{verbatim}
\renewcommand{\nomlabel}[1]{\textsf{\textbf{#1}}}
\end{verbatim}

...to the \LaTeX\ preamble in the document settings. This command will make the font of all symbols **bold** and sans serif.

If the characters |, !, @ and ’ should appear in nomenclature entries they need to be escaped by adding a quote character in front of them.

### 6.7.2. Sort Order of Nomenclature Entries

The nomenclature entries are sorted alphabetically by the \TeX\-code of the symbol definition. This leads to undesired results when you, for example, have symbols in formulas. Suppose you have nomenclature entries for the symbols \(a\) and \(\sigma\). They will be sorted by “a” and “$\sigma$” – the \(\sigma\) will be sorted before the \(a\) since the character “$” is considered in sorting.

To control the sort order, you can edit the Sort as field of the nomenclature dialog. Then the nomenclature entry will be sorted by this entry and not the symbol definition. For the example given, you can insert \texttt{sigma} in this field for the \(\sigma\), then \(a\) will be located before \(\sigma\).

For subgrouping and tips for using sort entries see the nomencl documentation, [17].

### 6.7.3. Nomenclature Options

The nomencl package offers some options to adjust the appearance of the nomenclature. Here are some of its options; for more have a look at its documentation:

- **refeq** Appends the phrase “\textit{, see equation (eq)}” to every nomenclature entry, where eq is the number of the last equation in front of the nomenclature entry

- **refpage** Appends the phrase “\textit{, page (page)}” to every nomenclature entry, where page is the number of the page on which the nomenclature entry appeared

- **intoc** Inserts the nomenclature in the Table of Contents

To use one or more of the options, add them to the comma-separated document class options list in the Document > Settings dialog. In this document the options refpage, intoc are used.
You can also use the first two options above only for certain nomenclature entries when you add one of the following commands as last entry to the Description field in the nomenclature dialog:

\nomrefeq Like the refeq option
\nomrefpage Like the refpage option
\nomrefeqpage Short notation of \nomrefeq\nomrefpage
\nomnorefeq, \nomnorefpage, \nomnorefeqpage Turns off the corresponding options

Words like “page” are automatically translated for some document languages. If not, add these lines to your \LaTeX{} preamble:
\renewcommand{\eqdeclaration}[1]{{, see equation
nobreakspace(#1)}}
\renewcommand{\pagedeclaration}[1]{{, page
nobreakspace{}#1}}
and replace “see equation” and “page” by their translation.

### 6.7.4. Printing the Nomenclature

To print the nomenclature, use the menu Insert $\triangleright$ Lists/TOC $\triangleright$ Nomenclature. A box labeled “Nomenclature” will show the place where the nomenclature is printed in the output. By right-clicking on it, the amount of space for symbols can be altered. You can choose between these settings:

- **Default** a space of 1 cm is used
- **Longest label width** the width of the widest symbol of all nomenclature entries is used
- **Custom** custom space

In the printed output the title of the nomenclature appears as “Nomenclature”. If you are not happy with the name, you can change it by redefining the command \nomname in the preamble. For example, in order to change the name to *List of Symbols*, add the following line to the preamble:

\renewcommand{\nomname}{List of Symbols}

### 6.7.5. Nomenclature Program

\LaTeX{} uses the program makeindex, that is part of every \LaTeX{} distribution, to generate the nomenclature. \LaTeX{}’s preferences dialog allows you to specify another program or to control makeindex by adding options, see section C.6.2. The available options are listed and explained in [17, 9].


6. More Tools

6.8. Branches

Sometimes it is useful to hide some document parts in the output. For example a teacher who is setting an exam obviously doesn’t want the pupils to see the answers, but having questions and answers in the same document will make the life of the markers of that exam much easier.

For these cases LyX allows you to put text into branches. The text will then only appear in the output when its branch is activated. To create a branch, either select the menu Insert\>|\>Branch\>|\>Insert New Branch (if you just want to specify a new branch) or go in the Document\>|\>Settings dialog to Branches, where you can specify and change the name of the branch, its activation state (whether the content of the branch is shown in the output or not), its background color inside LyX and whether the name of the branch should be appended to the document file name on export if the branch is active (see below for an example). Furthermore, the dialog lets you merge two branches (just rename one branch to the name of the other) and to add “unknown branches” (i.e. branches that were added to the document via copy and paste from other documents, without having been defined) to the document’s branch list.

Text that should be in a branch is set into branch inset boxes. These boxes are inserted via the menu Insert\>|\>Branch where you can choose a branch. You can later change the activation state of the branch by right-clicking on them.

Here is an example, where only the question text appears, the answer branch is deactivated and therefore does not appear in the output:

Question: Who was the first physics Nobel prize winner?

If you activate Filename Suffix in Document\>|\>Settings\>|\>Branches, the name of the active branches will be appended to the file name at export. Consider for example a file “Exam.lyx” which has the above branches. If “Filename Suffix” is active, the PDF export file would be called “Exam.pdf” if both the “Question” and “Answer” branch were inactive, “Exam-Question.pdf” if only the “Question” branch was active, likewise “Exam-Answer.pdf” if only the “Answer” branch was active, and “Exam-Question-Answer.pdf” if both branches were active. This helps you to export different versions of your document easily.

To use conditional output inside places where you cannot insert branch insets, like inside equations, you can code special \LaTeX definitions for each branch. For example you can define for the question branch:

\newcommand{\question}{[1]{#1}}

\newcommand{\answer}{[1]{}}

and for the answer branch

\newcommand{\answer}{[1]{}}

For an introduction to the \LaTeX-syntax, see section 6.10.2.
\newcommand{\question}{\}
\newcommand{\answer}{\{}[#1]

Now it is possible to use the \question{...} and \answer{...} commands to obtain conditional output. Here is an example formula where only the \question part appears:

\[ x^2 - 2x - 2 \Rightarrow x_1 = 1 + \sqrt{3}. \]

Inside math, the same effect can be achieved using math macros, see the Math manual.

Each type of branch is allowed to have its specific style defined in layout files (e.g. any branch inset can be automatically wrapped by your own \LaTeX commands.). For this advanced usage, see the Customization manual, section Flex insets and InsetLayout).

\section{PDF Properties}

The Document\longrightarrow Settings\longrightarrow PDF Properties dialog allows you to set up special options for the PDF output of your document. All these options are provided by the \LaTeX-package hyperref which will link all cross-references in the DVI- and PDF-output. This means that the reader of your document will be able to click on a table of contents entry or on a reference to move to the cross-referenced part of the document.

The header information in the dialog tab General is saved together with the PDF as file properties. Many programs are able to extract this information, for example, automatically to recognize who the author is and what the PDF is about. This is very useful to sort, classify or use PDFs for bibliography issues. When the option Automatically fill header is set, \LaTeX tries to extract the header information from your document title and author entries. The option Load in fullscreen mode will open the PDF in fullscreen mode, which is useful for presentations.

You can specify in the dialog tab Hyperlinks how the links will look and if links for bibliographical backreferences are created. The Break links over lines option allows long links to be split; No frames around links and Color links both turn off the default behavior of enclosing all links in frames; Color links colors the different links. The default colors are:

- magenta for hyperlinks and URLs
- red for links
- green for citations

but you can change these in the field Additional options. For example, in this document they were changed with the additional options:

linkcolor=black, citecolor=black, urlcolor=blue, filecolor=blue
6. More Tools

If the option Backreferences is set, the hyperlinks will appear in the bibliography after the different entries, showing, depending on the option selected, the number of the section, slide or page where the entry is referenced.

In the dialog tab Bookmarks you can specify if PDF-bookmarks should be created for every section of your document to make it easier for readers to navigate through the document. You can decide if the bookmarks should be numbered like your document sections or not. With the Open bookmarks Level you can specify what sectioning level should be displayed in the bookmarks when opening the PDF. For example level 2 will display all sections and subsections, while level 1 will only display the sections.

PDF properties are also used in this document. When you look in its document settings, you can see that some additional hyperref options are used. For an explanation of all them we refer you to the hyperref manual [16].

6.10. \TeX\ Code and the \LaTeX\ Syntax

6.10.1. \TeX\ Code Boxes

As LyX uses \LaTeX\ in the background, it supports many \LaTeX\ commands and constructs, but not all. \LaTeX\ contains hundreds of packages that provide different commands. All the time packages are being updated and new ones added. This has the advantage that you can typeset nearly everything as there is a \LaTeX\-package for every problem, though LyX cannot support all packages and their commands.

But don’t worry, you can use any \LaTeX\-command directly in LyX inside the \TeX\ Code box. A \TeX\ Code box is created by the menu Insert > \TeX\ Code or by the toolbar button $\TeX$ (shortcut Ctrl+L). The box can be opened by left-clicking and closed by right-clicking on it and selecting Close Inset.

You can insert complete or incomplete commands as \TeX\ Code. Incomplete means that the command argument can be Standard LyX text. For example, if you want to draw a frame around a word\textsuperscript{9} and are therefore using the \LaTeX\-command $\fbox$, you can write the command part $\fbox{$ in a \TeX\ Code box before the word and the closing brace $}$ in a second \TeX\ Code box behind the word. The word between the two \TeX\ Code boxes is then the argument as it is in the following example:

\begin{quote}
This is a line with a \fbox{framed} word.
\end{quote}

gives

This is a line with a \texttt{framed} word.

\textbf{Note:} At the end of \LaTeX\-commands without parameters, you have to insert a space to let \LaTeX\ know that the command is finished.

\textsuperscript{9}The LyX way would be to use a framed box.
6.10.2. A Short Introduction to the \LaTeX Syntax

When you write larger documents or books, you will need to know something about the \LaTeX-commands that \LaTeX{} uses in the background. Because \LaTeX{} is based on commands, you can "program" your text. This has the advantage that the layout of the document can be changed at any time if you know the right commands. For example, imagine you have to write a manual for a product and the deadline is the end of the day. Your boss has just complimented you for your good work but wants to have all caption labels bold. But you have over a hundred figure and table captions with non-bold labels in your manual. Of course it is impossible to change all caption labels manually in one day.

Now \LaTeX{} comes into play. As mentioned above, for every problem there exists a \LaTeX-package. First you have to find out which and therefore look in the \LaTeX{} package database, [FW].

As result you find that the package \texttt{caption} is what you need. To use a package, you have to load it in the document preamble (menu \texttt{Document} \texttt{Settings} \texttt{LaTeX Preamble}) with the command

\texttt{\usepackage[options]{package\ name}}

All \LaTeX{} commands begin with a backslash, the command argument is set within two braces and the options are set within two brackets. Note that not all commands have an argument and options.

In your case the package name is \texttt{caption}. After a look in the documentation of the package, you know that the option \texttt{labelfont=bf} will change the font of all caption labels to bold. So you add the command

\texttt{\usepackage[labelfont=bf]{caption}}

to the preamble and the problem is solved.\cite{labelbf}

Note that some document classes have built-in solutions for well-known problems like your case. For example if you use a \texttt{KOMA-Script} class, you don't need the package \texttt{caption}, you can instead write

\texttt{\setkomafont{captionlabel}{\bfseries}}

in the preamble and the problem is solved. So if you plan to write a large document, you should have a look at the documentation of the document class you want to use. (\texttt{\setkomafont} is an example of a command with more than one argument.)

Commands in the preamble affect the whole document, while commands in the text affect only the text after the command or only the text used as command argument. To insert a \LaTeX-command in text, use the \TeX{} Code box as described in the previous section.

If you want to learn more about \LaTeX{} and its syntax, have a look at the \LaTeX-books [1, 2].

\cite{labelbf}

\footnote{For more commands provided by the \texttt{caption} package, have a look at its documentation, [13].}
6.11. Customized Page Headers and Footers

To define a custom page header and footer line for your document, you need to set the Page style to Fancy in the Document>Settings dialog under Page Layout. As a second step add in the menu Document>Settings>Modules the module “Custom Header/Footerlines”. This module offers the following 6 environments:

Left Header, Center Header, Right Header
Left Footer, Center Footer, Right Footer

for the different positions in the header/footer. These environments can be selected in the environment pull-down box.

Normally, headers and footers are set up at the beginning of the document. But you can change them anywhere you want to. Figure 6.1 shows the page layout and where the header/footer styles will appear.

<table>
<thead>
<tr>
<th>Left Header</th>
<th>Center Header</th>
<th>Right Header</th>
</tr>
</thead>
</table>

The normal text on the page goes here. The running header is above the text, and the footer is below (including footnotes). Headers/footers typically contain things like the page number, title of the chapter, company logo but you can use almost anything, except of floats.

<table>
<thead>
<tr>
<th>Left Footer</th>
<th>Center Footer</th>
<th>Right Footer</th>
</tr>
</thead>
</table>

Figure 6.1.: Page layout with custom header and footer line.

**Note**: some document classes implement their own customized page headers and footers if Page style is set to “Default”. Check what these are before you specify your own customized page headers and footers.

6.11.1. Definition

To define your header line, add all three header environments. The things you add to each environment appear on odd numbered pages, the things in the optional arguments on even numbered pages. For single-sided documents, the optional arguments will not be used and can be omitted. If you leave a header environment or its argument empty, nothing appears in the output. Defining the footer line works similarly.

For the definition, you will need some \LaTeX-commands that are inserted as \TeX code (menu Insert>TeX Code):

\texttt{\the\page} prints the current page number

\texttt{\Roman{page}} prints the current page number with capital roman numerals

LyX’s user guide
6.11. CUSTOMIZED PAGE HEADERS AND FOOTERS

\roman{page} prints the current page number with small roman numerals

\leftmark prints the current section number and title. If the document has chapters, it prints the current chapter number and title instead. It is called “leftmark” because it usually goes in a left header.

\rightmark prints the current subsection number and title. If the document has chapters, it prints the current section number and title instead. It is normally used in the right header.

6.11.2. Default header/footer

The custom header/footer is not empty by default. The default header contains the chapter and section title and the center footer has the page number. In order to remove unwanted entries from the header/footer, include the relevant header/footer style in your document, but leave it blank. So, if you do not want a page number in the footer, include a blank Center Footer style.

6.11.3. Appearance

The header and footer will appear on normal pages. Some pages are different. The title page has a header/footer environment of its own, and so does any page that starts a new part or chapter in your book. Such pages will not have the custom headers/footers, but that is normal. There is for example no need to print a header with the chapter name on the chapter page where the chapter heading is in big bold letters anyway.

6.11.3.1. Header and footer decoration line

By default, you get a 0.4 pt thick line below the header and no footer line. This can be changed in the document preamble with the commands \texttt{\headrulewidth} and \texttt{\footrulewidth} in the following way:

\renewcommand{\headrulewidth}{thickness}

where thickness is a size in standard units like \texttt{pt} or \texttt{mm}. If you don’t want a line, set the thickness to 0 pt.

The lines can also be colored, but this requires more knowledge of \LaTeX. If you really need this, have a look at the Internet or in section 4.4 of the book [MG04].

6.11.3.2. Several header/footer lines

In case you need more than one text line as a header/footer, you can do this by adding a ragged line break in the style definition. However, the default height of the

\[
\Upsilon = \frac{3\sqrt{\aleph}\spadesuit}{CV}
\]
header/footer is only the height of one text line. To expand the height, redefine the \TeX length \texttt{\headheight} or \texttt{\foottight} with this entry in Document$\to$Settings$\to$LaTeX Preamble:
\begin{verbatim}
\setlength{\headheight}{\texttt{height}}
\end{verbatim}
where \texttt{height} is a size in standard units (e.g. 1\texttt{cm}). If you don’t know how much space is needed for the height, define your header/footer and preview your document as a PDF. Then open the \TeX logfile with the menu Document$\to$LaTeX Log and use the button Next Warning to see if you can find a warning about the package fancyhdr. If there is such a warning, it contains the space that you need at least for your header/footer.

6.11.4. This example

This example demonstrates what can be done with custom header/footers. Don’t use it for your document as it is just an example. This example consists of the following definition:

\begin{itemize}
  \item \textbf{Left Header} \texttt{\rightmark}, empty optional argument
  \item \textbf{Center Header} empty, empty optional argument
  \item \textbf{Right Header} empty, \texttt{\leftmark} in the optional argument
  \item \textbf{Left Footer} empty, \texttt{\thepage} in the optional argument
  \item \textbf{Center Footer} \texttt{\textsc{LyX’s user guide}}, “Magic code: $\Upsilon = \sqrt{\aleph \spadesuit}$” in the optional argument
  \item \textbf{Right Footer} \texttt{\textsc{\Roman{page}}}, empty optional argument
\end{itemize}

\texttt{\headrulewidth} set to 2 pt

In principle you can use almost everything in headers/footers, except floats. For more specialized features, for example, thumb-indexes, see the manual of the \texttt{fancyhdr} package, \cite{15}.
6.12. Previewing Snippets of your Document

LyX allows you to generate previews of sections of your document on the fly so you can see how they will look in the final document without having to break your train of thought with viewing the output.

6.12.1. Prerequisites

To get previews working, you need the \LaTeX{} package \texttt{preview-latex} (on some systems named simply \texttt{preview}) installed. If it is not already installed, you will find it in the \TeX{}-catalogue, \cite{5} or in the package manager of your \LaTeX{}-system. You obtain prettier results if you install the program \texttt{pnmcrop} from the \texttt{netpbm} package; for LyX on Windows this program and also the \LaTeX{}-package are automatically installed together with LyX.

6.12.2. Enabling previews

If you would for example like to see in LyX your math formulas typeset by \LaTeX{}, activate the option Display Graphics in the Tools$\rightarrow$Preferences dialog under Look and feel$\rightarrow$Display. Then set Instant Preview to On. The Preview Size is the multiplication factor for the size.

If you would like to see everything but your math formulas typeset by \LaTeX{}, set Instant Preview to No math.

Previews are generated when you load a document into LyX and when you finish editing an inset.

\textbf{Note:} Previews of an already loaded document are not in every case immediately generated by activating the option Display Graphics. Reopening the document will fix such problems.

6.12.3. Selected document parts

Besides math there are other cases where you might like to see a preview, for example things that LyX cannot render like rotated parts or things that are not yet supported by LyX. To do this, insert a preview inset via the menu Insert$\rightarrow$Preview. Insert or paste the stuff that you want to preview into this inset. The preview will be generated when the cursor is outside the preview inset. If you click on the preview, you can edit the previewed stuff.

An example: To create rotated boxes, you use the \LaTeX{} command \texttt{\rotatebox} which is not yet supported by LyX.\footnote{\texttt{\rotatebox} is explained in section Rotated and Scaled Boxes of the Embedded Objects manual.} Instead of the \TeX{} Code boxes you want to see
in \LaTeX{} the final rotated boxes, for example to adjust the rotation angle to fit with the surrounding text. Therefore you create a preview inset and copy the text with the rotated boxes into it. Here is the result:

This is a line with rotated framed text \[\text{Ad}x = B\] and a formula.

Previewing works also for colors. In this example a special framed, colored box was created using the \LaTeX{} command $\texttt{\textbackslash fcolorbox}$:\footnote{$\texttt{\textbackslash fcolorbox}$ is explained in section \textit{Colored Boxes} of the \textit{Embedded Objects} manual.}

This is text within a colored, framed box.

If \LaTeX{} does not show a preview, make sure that you enabled previews as described above and also make sure that \TeX{} Code in the preview inset is valid and that you loaded the \LaTeX{} packages in your document preamble that are required by the \TeX{} Code. If \LaTeX{} cannot create a preview, you will in most cases also not be able to view your document due to \LaTeX{} errors. So if you have to use some \TeX{} Code and don’t know if it is correct, the preview inset is a nice method to check it without the need to view the whole document.

6.12.4. \LaTeX{} source code

You can preview the \LaTeX{} source of the whole document or parts of it. Use the menu View $\Rightarrow$ Source Pane and a window will be shown where you can see the \LaTeX{}-source code. The window shows the source of the whole paragraph in which the cursor currently sits. You can also select document parts in \LaTeX{}’s main window, then only this selection (when it is more than one paragraph) is shown as source code. To view the whole document as source, enable the corresponding option in the source view window. If you check Automatic update, you can see the changes as you make them in \LaTeX{}; but note that if you have several documents open, this will slow things down as \LaTeX{} updates them all, not just the one which is open at the time.

6.13. Advanced Find and Replace

6.13.1. Introduction

The advanced find and replace feature of \LaTeX{} allows for searching of complex, format-sensitive text segments and mathematics contents within \LaTeX{} documents. It is an enhancement of the standard (quick) find and replace feature. The key-features are:
• Both searching of text and of mathematical formulas is allowed, where the latter is done by entering mathematics in the usual way; not only entire mathematical formulas are found, but also parts occurring within more complex formulas

• Search may be format-insensitive, so that the searched text is found in any context/style (standard text, section headings, notes, and even mathematics), or it may be format-sensitive, so that, for example, a word entered with a section heading will only be found within section headings

• Search may be restricted to mathematics environments only; this is useful for remangling math notation where one does not want to match any text outside of mathematics environments

• Search may be widened to a specific scope, i.e. a set of files which may be all the children of the document being edited, all the open files, or all the manuals available from the Help menu

• Replace may optionally preserve capitalization, so that the replaced text capitalization is adapted to the matching text (i.e. all lowercase, all uppercase, first letter uppercase followed by lowercase)

6.13.2. Basic usage

The advanced find and replace feature is activated through the menu Edit > Find & Replace (Advanced) (shortcut Ctrl+Shift+F) or the toolbar button . This opens the Advanced Find and Replace dialog.

6.13.2.1. Searching for text

Enter into the Find LyX mini-editor a simple word, and search for occurrences of it by clicking on the Find Next button at the bottom of the dialog (or just press the Return key). The entered word is found both in text mode and in math mode, and in emphasized, bold or normal face, and in both in section titles and in standard text. Pressing Return repeatedly keeps searching forward while pressing Shift+Return searches backwards.

The Case sensitive option allows matches to occur only with the same case as entered in the Find editor. The Whole words option allows matches to occur only at word boundaries.

6.13.2.2. Searching for mathematics

Mathematical formulas, such as $x^2$ or something more complex like $\frac{x^2}{1+x^2}$, may be searched for by typing them in the Find editor. When searching for a formula, it is found both when it is alone and when it occurs in sub-formulas and nested parts of
sub-formulas. For example the mentioned segments would be found in something like
\[
\frac{x^2}{\sqrt{1+x^2}}.
\]

6.13.2.3. Style-aware search

It is also possible to search for text with specific styles. This is done by switching to the Settings tab of the dialog and unchecking the Ignore format option. This way, entering in the Find editor

- a normal word and searching for it would not find instances of the word occurring in emphasized or boldface.

- an emphasized or boldface word and searching for it would find the respective instances with the same face only, and within the same text style only.

- a normal word in a section heading, and searching for it, would find occurrences of it only within section headings. Also, if the text to search is given an emphasized or bold face, in addition to a section style, then it is found only when occurring with the same style.

- a displayed formula will only find instances of this formula that are also displayed formulas (and not inline formulas).

6.13.2.4. Replace

The entries made in the Find editor can be replaced with entries made in the Replace with editor. In order to find the next occurrence and replace it, click on the Replace button or alternatively press Return or Shift+Return while the cursor is in the Replace with editor.

You can replace with fully-featured formatted LyX entries. Typical scenarios in which to use this capability might be (just to mention two):

- replacing occurrences of a word with a customized formatted version of the same word, for example replacing occurrences of a name like “func()” with its typewriter version “\texttt{func}()”

- performing a notation rework of mathematical symbols, for example replacing occurrences of “\(R\)” with “\(\mathbb{R}\)” (you may want to enable the Whole words and Case sensitive options and disable the Ignore format option in the Settings tab, in order to avoid replacing all “R” letters occurring in normal text), or occurrences of \(x_j^i\) with \(x_{i,j}\), or occurrences of \(x[k]\) with \(x_k\).
6.13.3. Advanced usage

There is a regular expression (regexp) based searching facility. You can search for a regular expression by inserting a regexp inset into the Find editor. This is done with the context menu Insert > Insert Regular Expression while the cursor is in the Find editor. Characters entered within regexp insets are matched according to the regular expression matching rules, while text entered outside regexp insets is matched exactly against the same text in the document. You can cut and paste regexp-mode insets. Examples of using such a feature may be:

1. Searching for all fractions with a given denominator: for example, entering in the Find editor the fraction \( \frac{x^2}{1+x^2} \) (where the \( \cdot \) on the numerator is the match-everything regular expression) finds all fractions with the given denominator.

2. Searching for all text with a given style: for example, after unchecking the Ignore format option from the Settings tab, entering a \( \cdot \) regular expression and giving it an emphasized or bold face, finds all emphasized or bold face text respectively. Also, by inserting a \( \cdot \) regular expression in a bullet or enumerated list or a section heading, you can find all bullet or enumerated lists or section headings.

Finally, references to (sub)expressions in regexp may be used as usual: Enclosing parts of the expression within round braces ( ), and referring back to them through \( \backref{1}, \backref{2}, \text{etc.} \). For example, try searching with the regexp
\[
[[[:space:]]([[:alpha:]]+)[[:space:]]]\backref{1}[[[:space:]]]
\]
in order to find word repetitions, if there are any.

The usage of back references in the replaced text is not (yet) implemented.

**Note:** Back references work both when occurring within the same regexp, and when occurring in multiple different regexps, where the numbering of back-referenced sub-expressions is absolute. That is, \( \backref{1} \) always refers to the first occurrence of ( ) in all entered regexps.


\( \LaTeX \) has a built-in spell checker. The menu **Tools > Spellchecker**, the F7 key or the toolbar button \( \mathbb{D} \) start the spell checking from either the current cursor position or the beginning of the currently selected text. A sidebar will appear showing any incorrect (or unknown) word found, allowing you to edit and replace it in a second line. Whenever an unknown word is found, the word is highlighted and the text

\[^{13}\text{A good explanation of regular expressions is given in this Wikipedia entry: http://en.wikipedia.org/wiki/Regular_expression.}\]

\[^{14}\text{Under the constraint that any (sub)expression must match a well-formed \LaTeX segment, i.e. when matching \LaTeX code, no segments with unbalanced {} braces are allowed to match expressions.}\]
scrolled so that it is visible. In the spellchecker sidebar, there is a box showing suggestions for a correction, if any could be found. Clicking on one of the corrections will copy it to the Replacement field, double-clicking directly invokes the replacement. Unknown but correctly typed words can be added to the personal dictionary.

By default, the dictionary file used is determined by the document language that is set in the Document > Settings dialog. You can specify the language of a word in the spellchecker dialog by choosing a different one at the top of the dialog. LYX can correctly spell check documents containing multiple languages. This works if you have set the language of the text parts using the Text Style dialog (\ref{sec:tools:styles}) and have the spell checker dictionaries installed. LYX automatically switches to the appropriate dictionary file.

All spell-checker dictionaries supported by LYX can be downloaded from here: http://sourceforge.net/projects/lyxwininstaller/files/hunspell/

There are 2 files for each language. To install a dictionary on Windows, copy the 2 files into LYX’s installation subfolder ~\Resources\dicts and restart LYX.

With Linux one needs to install the packages for the desired language. The number of these packages vary depending on the Linux distribution, but in most cases these are aspell-xx, hunspell-xx, myspell-xx, etc., where xx is the language code.

6.14.1. Further Settings

In the menu Tools > Preferences > Language Settings > Spellchecker you can set the following things:

Spellchecker engine Select the library LYX should use for spell checking. Depending on your platform, aspell, hunspell or enchant\textsuperscript{15} are available. On Windows only hunspell is available. LYX on Mac OS can also use Mac’s own spellchecker and will use it by default.

Alternative language If this field is not empty, LYX will always use the given language for the spell checking, no matter what the document language is.

Escape characters Allows you to add non-standard characters that the spell checker should escape, e.g. German umlauts. This should normally not be needed.

Accept compound words Prevents the spell checker from complaining about compounded words like “passthrough”.

Spellcheck continuously Checks the spelling of your document as you type it. Miss-spelled words get underlined with a dotted red line. By right-clicking on an underlined word, suggestions from the spellchecker appear in a context menu. Choosing one of them will replace the misspelled word with the suggested word.

Spellcheck notes and comments If enabled, the spelling of non-printed document content is checked as well.

\textsuperscript{15}Enchant itself is a wrapper library having different configurable back-ends. Please consult the documentation or man-page of it to learn more.
6.15. Thesaurus

LyX provides a multilingual thesaurus. It uses the same thesaurus framework as LibreOffice, OpenOffice and Firefox (namely the MyThes\textsuperscript{16} thesaurus library, which is included in LyX). Therefore, LyX is able to directly access OpenOffice thesaurus dictionaries, which are available for many languages.

This section describes how new dictionaries are installed and set up for the use with LyX.

6.15.1. Setting up the thesaurus

The MyThes/OpenOffice thesauri consist of two files per language: A file with the suffix ".dat" containing the data and an index file with the suffix ".idx". The standardized file names include the language code for the given language (e.g. en_US for US English). For instance, the US English files are named:

- th_en_EN_v2.idx
- th_en_EN_v2.dat

If you have LibreOffice or OpenOffice and its thesaurus installed, these files should be already on your system and you just need to point LyX (in Tools > Preferences > Paths > Thesaurus dictionaries) to the path where they are installed.\textsuperscript{17} On Windows, you can alternatively also select dictionaries for installation during the LyX installation process, which will then be installed in the correct place right away.

If you want to install new/further thesaurus dictionaries, you can downloaded them from here:

- http://www.lyx.org/trac/browser/lyxsvn/dictionaries/trunk/thes/

To install a new dictionary, download the two files for this dictionary into the thesaurus path (which is set in Tools > Preferences > Paths > Thesaurus dictionaries) and restart LyX. If this path is not defined yet, you can use a dictionary of your choice and point LyX there.

Alternatively, you can also install new dictionaries via LibreOffice/OpenOffice or, on Linux, via your package manager (look for mythes-* or libreoffice-thesaurus-* packages). If you do this, make sure that LyX is able to find the installed dictionaries, i.e. that Tools > Preferences > Paths > Thesaurus dictionaries points to the path where you installed these dictionaries.

\textsuperscript{16}http://lingucomponent.openoffice.org/thesaurus.html
\textsuperscript{17}On Linux, depending on your distribution and the way you installed the dictionaries, typical locations are /usr/share/mythes/, /usr/share/myspell/dicts/, /usr/share/ooo/thesaurus/, ~/.config/libreoffice/<version>/user/ or alike. On Windows, dictionaries are to be found at \%Program Files\%LibreOffice\<Version>\share\extensions or similar. On the Mac, the default location is /Users/<user name>/Library/Application Support/libreoffice/<version>/user/.
6. More Tools

6.15.2. Using the thesaurus

To start the thesaurus, use the menu Tools $\Rightarrow$ Thesaurus or the toolbar button $\text{노트}$ while the cursor is at the word you want to look up or while a word is selected. A dialog pops up showing you probably related words that you can use as a replacement. The suggestions are grouped into categories. Note that, for some languages (such as English), the thesaurus does not only show equivalent words (synonyms), but also generic terms (such as organism for plant), related terms (such as political theory for anarchistic), compounds (such as tree diagram, if you look for tree) and opposites (antonyms) (such as girl for boy). Generic terms, related terms and antonyms are marked as such.

The language is automatically chosen from the language at the cursor, but you can also switch it in the dialog, as you can enter new words to look up directly there.

Note that the thesaurus cannot handle phrases (only compounds that are in the dictionary, such as the above tree diagram), and you have to use the so called lemma form, i.e. the form that is used in the dictionaries (for many languages: first person singular indicative active for nouns, infinitive for verbs). For example, looking up the word form reporting yields no results, while results are shown for the word form report. Your best bet is to highlight only the relevant part of such a word (e.g. report in reports); then you will get suggestions without needing to adjust the query in the dialog, and also the replacement will probably be correct (as only the highlighted part will be replaced; thus the ending remains).

6.16. Change Tracking

When you work on a document collaboratively it is extremely useful to be able to see changes that others have made highlighted in the document. You can then decide if you want to accept a change or not. This can be achieved by turning on change tracking in the menu Document $\Rightarrow$ Change Tracking $\Rightarrow$ Track Changes.

Changes made in the document will then be highlighted by strokes and colors: underlined text is an addition, canceled text is a deletion. The color depends on the author that made the change. You can change the color in Tools $\Rightarrow$ Preferences $\Rightarrow$ Look & feel $\Rightarrow$ Colors. The author and the date of the change are shown in LyX’s status bar when the cursor is in changed text. The same information is shown when you use the toolbar button $\text{변호}$.

When change tracking is activated, you will see the review toolbar in LyX:

![Review Toolbar]

The review toolbar as shown above contains the following buttons:
Not all changes are (yet) visualized, especially no format changes like from *normal* to *bold* font or *Standard* to *Description* paragraph.

The review toolbar helps you to accept, reject, or merge changes – highlight the change and press one of the desired toolbar buttons. When you merge changes, a window pops up showing you information about the next change after the current cursor position. So you don’t need to highlight a certain change. Within the merge window you can decide to accept or reject changes and step to the next change. This way you can jump through all the changes in the document.

The toolbar has two buttons to handle notes because notes are often important to describe a change.

To show the changes made in the output you need the \LaTeX\ package \texttt{dvipost} installed. You will find it in the \TeX\ Catalogue, [5] or in the package manager of your \LaTeX\-system.

### 6.17. Comparison of Documents

You can compare two different LyX files via the menu Tools \textgt; Compare. The comparison result is a LyX file with change tracking enabled showing the differences. In the comparison dialog you can select from which document LyX should take the document settings for the resulting difference file with the option Copy Document Settings from. The option Enable change tracking features in the output enables the change tracking option Show Changes in Output to visualize the differences also in the PDF output of the difference file.
6. More Tools

6.18. International Support

This section describes how to use LyX with any language you want. For some languages there are special Wiki-pages that explain how to set up LyX to use them: [20, 21, 23, 24, 26, 27, 28, 29]

Besides languages, LyX also supports phonetic symbols, see section A.4.2.

6.18.1. Language Options

The Document > Settings > Language dialog lets you set the language, the quote style and character encoding.

Under Encoding you can choose the character encoding map you want to use for \LaTeX export. The option Language Default is the preferred choice and works well in most cases. For details about the different encoding options see section B.9.

6.18.2. Keyboard mapping configuration

If you have for example a U.S.-style keyboard and want to write in a language other than English, you can use an alternate keymap. For example, if you want to write in Italian, you can configure LyX to use an Italian keymap. The Tools > Preferences > Editing > Keyboard/Mouse dialog allows you to choose up to two keyboard mappings, see section C.2.3. You can choose primary and secondary keyboard languages and then select which one you want to use.

Finally, you may just want to change a few key mappings or create an entirely different keymap (for Vulcan, for instance). You may, for example, normally write in Italian on a U.S.-style keyboard but want to include an occasional quotation in German. In such a case, you can write your own keyboard mapping or modify an existing one to support the characters you want. This and many other customizations are explained in the Customization manual.
A. The User Interface

This appendix lists all the available menus and describes their functionality. It is designed as a quick reference if you are searching for a special topic inside the user’s guide.

A.1. The File Menu

Under the File menu are the basic operations in addition to some more advanced operations.

A.1.1. New

Creates a new document.

A.1.2. New from Template

This menu entry prompts you for a template to use. Selecting a template will automatically set certain layout features for the document, features you would otherwise need to change manually.

A.1.3. Open

Opens a document.

A.1.4. Open Recent

The submenu shows a list of the recently opened files. Click there on a file to open it.

A.1.5. Close

Closes the current document.
A. The User Interface

A.1.6. Close All
Closes all opened documents.

A.1.7. Save
Saves the actual document.

A.1.8. Save As
Saves the actual document under a new name to create a copy.

A.1.9. Save All
Saves all opened documents.

A.1.10. Revert to saved
Reloads the actual document from disk.

A.1.11. Version Control
This is used when multiple people are working on the same document or when one person wants to keep a careful archive of changes. It is described in the section Version Control in LyX of the Additional Features manual.

A.1.12. Import
Here you can import files from older LyX versions, HTML files, \LaTeX files, NoWeb files, plain text files and comma separated, table-like text files (CSV). The files will be imported as a new LyX document.

When using the menu entry Plain text, line breaks in the text will start a new paragraph; when using the menu entry Plain Text, Join Lines, consecutive lines of text will be imported to one big paragraph. A new paragraph will begin when there is a blank line in the file.
A.1.13. Export

You can export your document to various file formats. The resulting files are placed in the directory of your LYX file. The menu entries are not the same on all installations. They depend on the programs found by LYX during its configuration.

Here is a list of all available entries; some of them are explained in detail in section 3.8.2:

**CJK LyX** format of the special LYX 1.4.x versions for Chinese, Japanese and Korean (CJK)
Since LYX 1.5.0 CJK support has been fully integrated into LYX.

**DocBook** text file with code in the language SGML that is used for the markup language DocBook

**DocBook (XML)** text file with code in the language XML that is used for the markup language DocBook

**DraftDVI** LyX’s native DVI-format. This format is not suitable if you have special characters or spaces in files paths or file names in your document. LYX use this format internally as a pre-stage to export to DVI.

**DVI** DVI-format that also allows the usage of special characters or spaces in files paths or file names

**DVI (LuaTeX)** DVI-format using the program LuaTeX; supports Unicode and the usage of non-TEX fonts; **Note:** not all DVI-viewers are currently able to display this output format properly.

**EPS (cropped)** the same as PostScript but with cropped page margins.

**Graphviz Dot** text file with code in the programming language Dot which is used to draw visualizations of graphs via the program Graphviz

**HTML** HTML-format; **Note:** the exported file will be stored in a subdirectory.

**HTML (MS Word)** HTML-format specialized so that the result can be imported to MS Word; as a consequence of this formulas will be embedded as bitmap fonts and not in the format MathML.

**LaTeX (LuaTeX)** text file with the LATEX source that is compilable with the program LuaTEX

**LaTeX (pdflatex)** text file with the LATEX source, additionally all images used in the document will be converted to a format that is readable by the pdflatex program (GIF, JPG, PDF, PNG)

**LaTeX (plain)** text file with the LATEX source code, additionally all images used in the document will be converted to the EPS-format, only this format is readable by the latex program

**LaTeX (XeTeX)** text file with the LATEX source that is compilable with the program XeTEX

119
A. The User Interface

**LilyPond book (LaTeX)** text file with the \LaTeX source and also code in the syntax of the music notation software LilyPond

**LyX z.y.x** LyX-Document in a format readable by the LyX versions z.y.x (e.g. "LyX 2.1.x"; “z” and “y” represent the version number)

**LyX Archive (zip|tar.gz)** creates a zip-archive or a tar.gz-archive file (depending upon your system) that contains your document and all files that are necessary to compile it (images, child documents, BibTeX files, etc.)

**LyXHTML** HTML-format using LyX’s internal XHTML engine

**MS Word Office Open XML** Office Open XML file, to be opened with Microsoft Word. For the conversion the program **Pandoc** is used. Pandoc is a third-party product and may not work in all cases.

**NoWeb** text file with code in the format of the literate programming language NoWeb

**OpenDocument (Pandoc)** OpenDocument file, to be opened with LibreOffice, OpenOffice, KOffice, Abiword, etc. For the conversion the program Pandoc is used. Pandoc is a third-party product and may not work in all cases.

**OpenDocument (tex4ht)** OpenDocument file. For the conversion the program tex4ht is used. tex4ht is a third-party product and may not work in all cases.

**PDF (cropped)** the same as PDF (pdflatex) but with cropped page margins

**PDF (dvipdfm)** PDF-format using the program dvipdfm, produces internally a DVI-file which is then converted to a PDF-file

**PDF (lower resolution)** the same as PDF (pdflatex) but with a reduced pixel resolution of 150 dpi (e.g. useful for e-books to be read on tablet PCs or for large documents as intermediate preview)

**PDF (LuaTeX)** PDF-format using the program LuaTeX, produces PDF-files directly

**PDF (pdflatex)** PDF-format using the program pdflatex, produces PDF-files directly

**PDF (ps2pdf)** PDF-format using the program ps2pdf, produces internally a PostScript-file which is then converted to a PDF-file

**PDF (XeTeX)** PDF-format using the program XeTeX, produces PDF-files directly

**Plain text** text format

**Plain text (ps2ascii)** text format, the document will first be converted to Postscript format and then exported as text using the program ps2ascii

**Postscript** PostScript format using the program dvips; for possible dvips options see section C.6.1

**Sweave** text file with the \LaTeX source and also code in the statistical programming language R. Using the R-function Sweave it is possible to use R-commands in \LaTeX
If one of the menu entries DVI, PDF (pdflatex) or Postscript is missing, you need to update your \TeX installation. After updating you have to reconfigure \LaTeX, see section 1.4.

**A.1.14. Fax**

This menu entry will only appear if you have a fax program installed (on Windows you additionally need to register its program path to \LaTeX’s PATH prefix, see section C.3). With this menu entry you can send your document to a fax program like hylapex or kdeprintfax. The default format of the sent file is PostScript. The format can be changed in \LaTeX’s preferences as described in section C.7.1.

**A.1.15. New and Close Window**

Opens or closes a new instance of \LaTeX.

**A.1.16. Exit**

Prompts you to save all unsaved documents and then exits.

**A.2. The Edit Menu**

**A.2.1. Undo and Redo**

Described in section 2.3.

**A.2.2. Cut, Copy, Paste, Paste Recent, Paste Special**

Described in section 2.2.

**A.2.3. Select Whole Inset**

Selects the content of the inset in which the cursor currently is. If the cursor is outside an inset, the whole document will be selected.

**A.2.4. Select All**

Selects the whole document.
A. The User Interface

A.2.5. Find & Replace (Quick)

Described in section 2.2.

A.2.6. Find & Replace (Advanced)

Described in section 6.13.

A.2.7. Move Paragraph Up/Down

This shifts the paragraph in which the cursor currently is one paragraph up or down.

A.2.8. Text Style

Described in section 3.7.6.

A.2.9. Paragraph Settings

Enables you to set the paragraph alignment, line spacing and label width. These settings only affect the paragraph in which the cursor is currently in.

You can also prevent the first line of the paragraph being indented if you have chosen to separate paragraphs with Indentation in the Document \rightarrow Settings \rightarrow Text Layout dialog.

A.2.10. Table and Rows & Columns

These menus only appear if the cursor is inside a table. It allows you to create multicolumn and multirow cells, add or remove borders of a cell and to set the alignment of the cell.

A.2.11. Dissolve Inset

This menu only appears if the cursor is inside an inset. It will dissolve this inset. This means that the inset is deleted and its content is left as normal text.

A.2.12. Settings or Math

This menu is only active if the cursor is inside an inset or a formula. Here you can change the properties of the inset or the formula.
A.2.13. Increase/Decrease List Depth

These menus are only active if the cursor is in an environment that can be nested. They increase/decrease the environment nesting level as explained in section 3.4 and 3.3.4.3.


These menus are only visible if it is possible to have two consecutive environments of the same type. See section 3.4.6 for an explanation.

A.3. The View Menu

At the bottom of the View menu the opened documents are listed.

A.3.1. Open/Close all Insets

Opens/closes all insets in your document.

A.3.2. Unfold/Fold Math Macros

Unfolds/folds the current math macro.

Math macros are described in the Math manual.

A.3.3. Outline Pane

Shows the outline window as described in sections 2.5 and 6.2.1.

A.3.4. Source Pane

Opens a window showing the source code of the actual document, as described in section 6.12.

A.3.5. Messages Pane

Opens a window showing console messages. This is useful for debugging LyX (i.e., hunt for errors in the program) or to see what is going on in the background while \LaTeX is processing the document.
A. The User Interface

A.3.6. Toolbars

In this menu entry you can set the appearance of the different toolbars. All toolbars and the Command Buffer can be turned on and off. The on state is denoted in the menu with a checkmark. The Table, Math, Math Macros, Review and Math Panels toolbars can additionally be set to the state automatic, denoted in the menu with the suffix (auto).

In the on state the toolbar is permanently shown; in the automatic state the toolbar is only shown when the cursor is in a certain environment or when a certain feature is enabled. That means that the review toolbar will only be shown if change tracking is activated, the math and table toolbars are only shown if the cursor is inside a formula or table respectively.

\LaTeX{}’s toolbars and their buttons are explained in section A.9.

A.3.7. Split View

Split View into Left and Right Half will split \LaTeX{}’s main window vertically while Split View into Upper and Lower Half will split it horizontally. This allows you to view documents at the same time to compare them, or to view the same document, but at different positions. You can even split the main window several times to view, for example, three or more documents at the same time. To close a split view, use the menu Close Current View.

A.3.8. Close Current View

Closes a split view.

A.3.9. Fullscreen

Using this menu entry or pressing F11 removes the menu bar and all toolbars so that you will see nothing but your text. It furthermore displays \LaTeX{}’s main window fullscreen. To return from fullscreen to the normal view, press F11, or right-click and turn off the fullscreen mode in the context menu.

A.4. The Insert Menu

A.4.1. Math

Inserts math constructs that are explained in chapter 5 and the Math manual.
A.4.2. Special Character

Here you can insert the following characters:

**Symbols** Opens the Symbols dialog which allows you to insert any character that can be output by your \LaTeX\ system. By default groups of characters are displayed in character categories; the available characters depend on the \LaTeX-packages you have installed. You can get a complete display by checking Display all.

**Note:** Not all characters will be visible in the Symbols dialog because none of the screen fonts that you can set in the preferences dialog (see section C.1.3) can display every character.

**Ellipsis** Inserts an ellipsis: \ldots

**End of Sentence** Inserts an end of sentence period as described in section 3.9.3.1.

**Ordinary Quote** Inserts this quote: ", no matter what quote style you selected in the Document > Settings > Language dialog.

**Single Quote** Inserts a single quote in the quotation marks style selected in the Document > Settings > Language dialog.

**Protected Hyphen** Inserts a hyphen that is protected from line breaks: -

**Breakable Slash** Inserts a slash where a line break can also occur: /

**Visible Space** Inserts a character representing a single space (the one you get when pressing the Space key): ☐

**Menu Separator** Inserts the menu separator sign: \rightarrow

**Phonetic Symbols** Inserts a box where you can insert symbols from the International Phonetic Alphabet (IPA) and opens a toolbar which provides a large set of these symbols. To use this feature you must have the \LaTeX-package tipa installed. More information about this feature can be found in the Linguistics manual (Help > Specific Manuals).

**Logos** Inserts the logos of the programs LyX, \TeX, \LaTeX\ and \LaTeX{}\textsuperscript{2ε}.

A.4.3. Formatting

Opens a submenu with the following options:

**Superscript** Inserts a superscript: test\textsuperscript{a, b}

**Subscript** Inserts a subscript: test\textsubscript{3x}

**Protected Space** Inserts a protected space as described in section 3.5.1.

**Interword Space** Inserts an inter-word space as described in section 3.5.2.1.

**Thin Space** Inserts a thin space as described in section 3.5.2.2.
A. The User Interface

Visible Space Inserts a character to visualize that there is or should be a space. This is e.g. useful if you need to indicate a space in a command sequence. An example from the LyX Math manual: “To insert a fraction use the command \frac{A}{B}.” The visible space is hereby the character before the A.

Horizontal Space Inserts horizontal space as described in section 3.5.2.

Horizontal Line Inserts a horizontal line as described in section 3.5.7.

Vertical Space Inserts vertical space as described in section 3.5.3.

Phantom Inserts a Phantom space as described in section 3.5.2.5.

Hyphenation Point Inserts a hyphenation point as described in section 3.9.2.

Ligature Break Inserts a ligature break as described in section 3.9.4.

Ragged Line Break Inserts a forced line break as described in section 3.5.6.

Justified Break Inserts a forced line break that right justifies the remaining text as described in section 3.5.6.

New Page Inserts a forced page break as described in section 3.5.5.

Page Break Inserts a forced page break that shares the extra space among paragraph breaks instead of leaving it at the bottom of the page, as described in section 3.5.5.

Clear Page Inserts a clear page break as described in section 3.5.5.1.

Clear Double Page Inserts a clear doublepage break as described in section 3.5.5.1.

A.4.4. List/TOC

Various lists can be inserted with this menu entry. The Table of Contents, the List of Algorithms, List of Figures, List of Tables and List of Listings are described in section 6.2. The Index List is described in section 6.6, the Nomenclature is described in section 6.7 and the BibTeX Bibliography is described in section 6.5.2.

A.4.5. Float

To insert floats, as described in section 4.6 and in detail the chapter Floats of the Embedded Objects manual.

A.4.6. Note

To insert notes, described in section 4.1.
A.4.7. Branch

Inserts a branch inset, if any, and allowing you to create and insert a new branch. Branches are described in section 6.8.

A.4.8. Custom Insets

Inserts document class-specific insets. Such insets only exist if they are defined in the layout file for a certain document class. An example is the document class “article (Elsevier)” with three custom insets. The section Flex insets and InsetLayout in Installing New Document Classes, The Layout file format of the Customization manual explains how custom insets are defined.

A.4.9. File

This menu entry allows you to insert or include the contents of other files in your document. For more information see chapter External Document Parts of the Embedded Objects manual.

A.4.10. Box

Inserts a box in a certain style. Boxes are described in detail in the chapter Boxes of the Embedded Objects manual.

A.4.11. Citation

Opens the Citation dialog as described in section 6.5.

A.4.12. Cross-Reference

Inserts a cross-reference as described in section 6.1.

A.4.13. Label

Inserts a label as described in section 6.1.


Inserts a caption in a float or multi-page table. Floats are described in section 4.6; captions in multi-page tables are described in the section Multi-page Captions of the Embedded Objects manual.
A. The User Interface

A.4.15. Index Entry

Inserts an index entry as described in section 6.6.

A.4.16. Nomenclature Entry

Inserts a nomenclature entry as described in section 6.7.

A.4.17. Table

Opens a dialog allowing you to specify the rows and columns of the table. Tables are described in section 4.5 and in detail in the chapter Tables of the Embedded Objects manual.

A.4.18. Graphics

Opens the Graphics dialog. Graphics are described in section 4.4.

A.4.19. URL

Inserts a URL as described in section 6.3.1.

A.4.20. Hyperlink

Inserts a hyperlink as described in section 6.3.2.

A.4.21. Footnote

Inserts a footnote as described in section 4.2.

A.4.22. Marginal Note

Inserts a marginal note as described in section 4.3.

A.4.23. Short Title

Is only visible if the cursor is in front, in or behind a section heading, title or caption of a float. Inserts a short title as described in section 3.3.4.4.
A.4.24. \TeX Code

Inserts a \TeX Code box as described in section 6.10.1.

A.4.25. Program Listing

Inserts a program listings box. Program listings are explained in the chapter Program Code Listings of the Embedded Objects manual.

A.4.26. Date

Inserts the actual date. The format depends on the date format of the language that is used for LyX’s menus. LyX offers various ways to insert a date which are explained and also compared in the section External Material of the Embedded Objects manual.

A.4.27. Preview

Inserts a preview inset as described in section 6.12.

A.5. The Navigate Menu

This menu lists the existing chapters, sections, figures, tables, etc. of the current document. This allows you to navigate easily through your document.

A.5.1. Bookmarks

With this menu entry you are able to define your own bookmarks. This is useful when you are working on a large document and often have to jump, for example, between section 2.5 and 6.3. To create bookmarks for this example, go to section 2.5 and use the submenu Save Bookmark 1. Then go to section 6.3 and use Save Bookmark 2. Now you can jump easily between these sections by using the menu or by the key bindings Ctrl+1 and Ctrl+2. You can also use bookmarks to jump between several opened documents.

The saved bookmarks are valid till the document is closed. The submenu Clear Bookmarks allows you to clear bookmarks while the submenu Navigate Back jumps to the position in the document where you recently changed something.

A.5.2. Next Note, Change, Cross-reference

Jump to the next note, change, or cross-reference after the current cursor position.
A. The User Interface

A.5.3. Go to Label

Only active if the cursor is in front of a cross-reference. Sets the cursor before the referenced label. (It is the same as if you right-click on a cross-reference box and use Go to Label).

A.5.4. Forward Search

Allows you to jump directly to the corresponding text part in the output, see section *The LyX Server* ➤ *Forward search* in the *Additional Features* manual for a detailed description.

A.6. The Document Menu

A.6.1. Change Tracking

Change Tracking is described in section 6.16.

A.6.2. LaTeX Log

After running \LaTeX by viewing or exporting a document, this menu will be enabled. It shows the logfile of the \LaTeX-program used. You can go to the next error or the next warning, search, copy something to the clipboard or update the view. With the help of the logfile, experts can find reasons for \LaTeX-errors.

With the button Open Containing Directory one can open LyX’s temporary folder for the output. This folder contains all converted and created files to generate the output. Some of these files might be of interest for experts to solve problems or for writers who need to supply intermediate files. For example some journals require to send the *.bbl file (a text file with the used BibTeX references).

A.6.3. Start Appendix Here

Sets the start of the appendices of the document at the current cursor position as described in section 6.4.

A.6.4. View [⟨output format⟩]

This menu entry generates the output in the format you have specified as default output format for the document (menu Document ➤ Settings ➤ Output ➤ Default Output Format; see section B.20) or in the LyX preferences (menu Tools ➤ Preferences ➤ Output ➤ Default Output Format).
A.6. The Document Menu

File Handling ➤ File Formats ➤ Default Output Format; see section C.7.2) and opens it in an appropriate viewer. The viewer can be set or changed in the preferences (menu Tools ➤ Preferences ➤ File Handling ➤ File Formats ➤ Viewer; see section C.7.2). The default viewers are set by \LaTeX{} when it is first configured. The default output format is PDF (pdflatex).

A.6.5. View (Other Formats)

With this menu you can view your document in alternative output formats. The menu contains a list of available formats in which you can view the actual document with an external program. The menu entries are not the same on all installations — it depends on the \TeX{} programs that are found when \LaTeX{} was configured. All possible formats are listed in section A.1.13. You should at least see the menu entry DVI. If it is missing, you need to update or repair your \TeX{} installation. After updating you have to reconfigure \LaTeX{} (see section 1.4.)

Invoking a view menu will start a viewer program. The viewer can be set or changed in the preferences (menu Tools ➤ Preferences ➤ File Handling ➤ File Formats ➤ Viewer; see section C.7.2). The default viewers are set by \LaTeX{} when it is first configured.

A.6.6. Update [〈output format〉]

This menu entry allows you to update the view with your latest changes (in the default output format) without opening a new viewer window.

A.6.7. Update (Other Formats)

With this menu you can update the view of alternative output formats of your document without opening a new viewer window.

A.6.8. View Master Document

This menu item is only visible if your document is included to another document, which is then its “master” (see section Child Documents in the Embedded Objects manual for more information on this topic). This item allows you to view the master document from within its child. That is, if you are working on a child document which is a chapter of a book, View Master Document generates the output of the whole book, while View will just output the chapter alone.

The format used by this function is the default output format as specified in the document settings (menu Document ➤ Settings ➤ Output ➤ Default Output Format; see section B.20) or in the preferences (menu Tools ➤ Preferences ➤ File Handling ➤ File Formats ➤ Default Output Format; see section C.7.2).
A. The User Interface

A.6.9. Update Master Document

This menu item is only visible if your document is included to another document, which is then its “master” (see section Child Documents in the Embedded Objects manual for more information on this topic). This item allows you to update the view of a master document from within its child without the need to switch to the master document itself.

The format used by this function is the default output format as specified in the document settings (menu Document ➤ Settings ➤ Output ➤ Default Output Format; see section B.20) or in the preferences (menu Tools ➤ Preferences ➤ File Handling ➤ File Formats ➤ Default Output Format; see section C.7.2).

A.6.10. Compressed

Un/compresses the current document. For documents under version control it is strongly recommended to disable compression (see the Additional Features manual for details).

A.6.11. Disable Editing

Toggles the read-only state for the document.

A.6.12. Settings

The document settings are described in appendix B.

A.7. The Tools Menu

A.7.1. Spellchecker

Spell checking is explained in section 6.14.

A.7.2. Thesaurus

The thesaurus is described in section 6.15.

A.7.3. Statistics

Returns the number of the words and characters in the actual document or the highlighted document part.
A.7.4. Check TeX

Generates with the help of the program ChkTeX a log of possible \TeX\-errors and displays it in a dialog. This feature is not available on Windows.

A.7.5. TeX Information

Shows you a list of the document classes and styles installed in your \TeX-\system. Use the option Show path to see the full filename paths.

A.7.6. Compare

Opens a dialog to compare LyX files as described in section 6.17.

A.7.7. Reconfigure

Reconfigures LyX; that is, LyX looks for \TeX\-packages and programs it needs; see also section 1.4.

A.7.8. Preferences

Opens the Preferences dialog as described in detail in appendix C.

A.8. The Help Menu

This menu lists the documentation files of LyX in the language of LyX’s menus. If a file is not available in this language, the English version will be listed.

The menu LaTeX Configuration shows a LyX document with information about the \TeX\ packages and classes found by LyX (see also section 1.5).

The menu About LyX gives information about the copyright, the credits and the LyX version you are using.

A.9. Toolbars

How to show or hide toolbars is explained in section A.3.6.

It is also possible to define custom toolbars. This is described in the Additional Features manual.
A. The User Interface

A.9.1. Standard Toolbar

The standard toolbar as shown above contains from left to right the following buttons:

- Pull-down box for the environments
- File ▶ New
- File ▶ Open
- File ▶ Save
- Tools ▶ Spellchecker
- Spellcheck continuously
- Edit ▶ Undo
- Edit ▶ Redo
- Edit ▶ Cut
- Edit ▶ Copy
- Edit ▶ Paste
- Edit ▶ Find & Replace (Quick)
- Edit ▶ Find & Replace (Advanced)
- Navigate ▶ Bookmarks ▶ Navigate Back
- Emphasize text, function of the Edit ▶ Text Style ▶ Customized dialog
- Set text to noun style, function of the Edit ▶ Text Style ▶ Customized dialog
- Format text using the current settings in the Edit ▶ Text Style ▶ Customized dialog
- Insert ▶ Math ▶ Inline Formula
- Insert ▶ Graphics
- Insert ▶ Table
- Toggle outline window on/off, View ▶ Outline
- Toggle math toolbar on/off
- Toggle table toolbar on/off
A.9.2. Extra Toolbar

The extra toolbar as shown above contains from left to right the following buttons:

- Default
- Numbered list
- Itemized list
- List
- Description list
- Edit ▶ Increase List Depth
- Edit ▶ Decrease List Depth
- Insert ▶ Float ▶ Figure
- Insert ▶ Float ▶ Table
- Insert ▶ Label
- Insert ▶ Cross-Reference
- Insert ▶ Citation
- Insert ▶ Index Entry
- Insert ▶ Nomenclature Entry
- Insert ▶ Footnote
- Insert ▶ Marginal Note
- Insert ▶ Note ▶ LyX Note
- Insert ▶ Box
- Insert ▶ Hyperlink
- Insert ▶ TeX Code
- Insert ▶ Math ▶ Macro
- Insert ▶ File ▶ Child Document
A. The User Interface

- Edit > Text Style > Customized
- Edit > Paragraph Settings
- Tools > Thesaurus

A.9.3. View/Update Toolbar

The view/update toolbar as shown above contains from left to right the following buttons:

- Document > View
- Document > Update
- Document > Master Document
- Document > Update Master Document
- Document > Settings > Output > Synchronize with Output
- Document > View (Other Formats)
- Document > Update (Other Formats)

* These icons might look different for you if you do not use the default icon set.

A.9.4. Other Toolbars

The change tracking toolbar is explained in section 6.16, the table toolbar in the *Embedded Objects* manual and the math macro toolbar in the *Math* manual.
B. The Document Settings

The Document Settings dialog contains submenus to set properties for the whole document and is called with the menu Document > Settings. You can save your document settings as default with the Save as Document Defaults button in any dialog. This will create a template named defaults.lyx which is automatically loaded by LyX when you create a new document without using a template.

The button Use Class Defaults resets the document settings to the default of the document class. This affects mostly class options, the page layout and Numbering & TOC.

The different submenus of the dialog are explained in the following sections. There are so many document settings available that it might take a while to find the one you are looking for. To find a setting quicker, you can use the search field which is above the submenus of the dialog. If you search e.g. for “page”, you will see that some submenus will be grayed-out and disabled. Only the submenus with page settings stay enabled. The found page settings are labeled red in these submenus.

B.1. Document Class

Here you set the document class, class options, a graphics driver, and a master document. Document classes are described in section 3.1.2.

With the button Local Layout you can load your own layout-file, that is not in LyX’s layouts folder and thus not recognized by LyX as a layout for a document class. For more about layout-files, see the chapter Installing New Document Classes, Types of Layout Files of the Customization Handbook.

Some classes use special class options by default. If this is the case, they are listed in the field Predefined and you can decide to use them or not. If you do not know exactly what the default class options are for, it is recommended you leave them untouched. The Graphics driver is used for \LaTeX’s graphics, color and page layout packages. If using Default, the default driver for the \LaTeX-packages is used. It is recommended that you use the default unless you know what you are doing.1

1When you want to use one of the following drivers dvi2ps, dvilw, dvlaser, dvitops, psprint, pubps, ln you first have to activate them in your \LaTeX distribution, see section Driver support in http://mirrors.ctan.org/macros/latex/required/graphics/grfguide.pdf.
B. The Document Settings

Specifying a Master document is necessary if the current document is a child or subdocument. The master document will be used by LyX in the background if the child document is opened without its master. This way child documents are always compilable. More about master and child documents is explained in the section Child Documents of the Embedded Objects manual.

There is also an option to suppress the date and one to use the \texttt{refstyle} instead of \texttt{prettyref} for cross-references, see section 6.1.

B.2. Child Documents

This submenu is only visible when your document includes child documents. Please refer to the section Child Documents of the Embedded Objects manual for details.

B.3. Modules

Modules are explained in section 3.1.2.3.

B.4. Local Layout

See section 3.1.2.4 for a description.

B.5. Fonts

The document font settings are described in section 3.7.

B.6. Text Layout

You can specify if paragraphs should be separated by \texttt{Indentation} or by \texttt{Vertical space}. The \texttt{Line spacing} and whether it should be a Two-column document can also be specified here.

Note that LyX will not show two columns or the specified line spacing on screen. That would be impractical, often unreadable, and is not part of the WYSIWYM concept. However, it will be as you specified in the output.

With the option \texttt{Use justification in LyX work area} you can decide if LyX justifies the text on screen. This only affects the text inside LyX not in the output.
B.7. Page Layout

This dialog is described in sections 3.1.4 and 3.1.3.

B.8. Page Margins

Here you can adjust the page margins as described in section 3.1.5.

B.9. Language

The document language and quote styles are set here. The encoding specifies how the document content is exported to \( \LaTeX \) (the \LYX{} file is always encoded in utf8). All characters that cannot be encoded using the specified encoding will be exported as \( \LaTeX \)-commands (this can fail if a \( \LaTeX \)-command is not known for a particular character).

If you use the option Language Default, \LYX{} determines the encoding of a text part from the language of this text. If the document contains text in more than one language you may get more than one encoding in the \( \LaTeX \) file. If you do not use this option then the complete document will always use exactly one encoding. Checking this option is the preferred setting.

\LYX{} also supports Unicode output, which is particularly useful if you need lots of special symbols or non-alphabetic scripts, respectively. If you want to use this (and your \( \LaTeX \) installation supports Unicode), choose one of the four utf8 variants from the list below. Unfortunately the Unicode support of standard \( \LaTeX \) is quite incomplete, so it is not uncommon that a file with lots of Unicode symbols works fine with Language Default (when \LYX{} uses its list of known \( \LaTeX \)-commands), but does not work with a fixed utf8 encoding (when the list of known \( \LaTeX \)-commands is not used, because all Unicode symbols can be encoded in utf8). The situation is much better with \XeTex{} and \LuaTeX{}, two new alternative engines to standard \( \LaTeX \). Both engines support Unicode natively. \LYX{} now also supports these two engines (via the output formats PDF (\( \text{XeTeX} \)), PDF (\( \text{LuaTeX} \)) and DVI (\( \text{LuaTeX} \)), see section 3.8.2). So if you are using many special or accented characters and Language Default fails, you might try out one of these new engines.

The Language package determines the \( \LaTeX \)-package that is used for hyphenation and the translation of strings like “Part”. The possible settings are:

Default uses the language package that is selected in Tools Preferences Language Settings (see section C.5.1).
B. The Document Settings

**Automatic** selects the most suitable language package for the view/export format you will use. In many cases this will be **babel**. If the newer package **polyglossia** is more appropriate (is the case when using Xe\TeX or Lua\TeX and non-\TeX fonts), this package will be used instead of **babel**.

**Always Babel** uses **babel** even if **polyglossia** would be more appropriate.

**Custom** allows you to specify a language package command of your choice. For example if you want to use a language-specific package like **ngerman** (for German texts), type in \usepackage{ngerman}

**None** will not use a language package. This is necessary for some document classes for scientific articles.

Here is a list with the important encodings:

**Language Default (no inputenc)** Same as Language Default, but the \LaTeX-package **inputenc** is not used. When using this, you probably need to load some additional packages manually in the preamble and specify the used encoding for text parts in foreign languages in \LaTeX code.

**ASCII** the ASCII encoding, covers only plain English (7-bit ASCII). \LaTeX converts all other characters into \LaTeX commands, which may result in a big file when lots of \LaTeX-commands are needed.

**Arabic (CP 1256)** MS Windows code page for Arabic and Farsi

**Arabic (ISO 8859-6)** for Arabic and Farsi

**Armenian (ArmSCII8)** for Armenian

**Baltic (CP 1257)** MS Windows code page for Estonian, Latvian and Lithuanian, the same as the ISO-8859-13 encoding

**Baltic (ISO 8859-13)** for Estonian, Latvian and Lithuanian, a superset of the ISO-8859-4 encoding

**Baltic (ISO 8859-4)** (latin 4) for Estonian, Latvian and Lithuanian, a subset of the ISO-8859-13 encoding

**Central European (CP 1250)** MS Windows code page for ISO 8859-2 (latin2)

**Central European (ISO 8859-2)** (latin 2) covers Albanian, Croatian, Czech, German, Hungarian, Polish, Romanian, Slovak and Slovenian

**Chinese (simplified) (EUC-CN)** for simplified Chinese, used especially on UNIX OSes, since 2001 this encoding is officially replaced by the encoding GB18030, as GB18030 is not available for \LaTeX you should try to use the encoding Unicode (CJK) (utf8)

**Chinese (simplified) (GBK)** for simplified Chinese, is the same as the Windows code page CP 936 except for the Euro currency sign, since 2001 this encoding is officially replaced by the encoding GB18030, as GB18030 is not available for \LaTeX you should try to use the encoding Unicode (CJK) (utf8)
B.9. Language

Chinese (traditional) (EUC-TW) for traditional Chinese

Cyrillic (CP 1251) MS Windows code page for Cyrillic

Cyrillic (ISO 8859-5) covers Belorussian, Bulgarian, Macedonian, Serbian and Ukrainian

Cyrillic (KOI8-R) standard Cyrillic especially for Russian

Cyrillic (KOI8-U) Cyrillic for Ukrainian

Cyrillic (pt 154) Cyrillic for Kazakh

Greek (ISO 8859-7) for Greek

Hebrew (CP 1255) MS Windows code page for Hebrew, a superset of the ISO-8859-8 encoding

Hebrew (ISO 8859-8) for Hebrew

Japanese (CJK) (EUC-JP) EUC-JP encoding for Japanese, uses the \LaTeX-package CJK, when using this, set the document language to Japanese (CJK)

Japanese (CJK) (JIS) JIS encoding for Japanese, uses the \LaTeX-package CJK, when using this, set the document language to Japanese (CJK)

Japanese (non-CJK) (EUC-JP) EUC-JP encoding for Japanese, uses the \LaTeX-package japanese, when using this, set the document language to Japanese

Japanese (non-CJK) (JIS) JIS encoding for Japanese, uses the \LaTeX-package japanese, when using this, set the document language to Japanese

Japanese (non-CJK) (SJIS) SJIS encoding for Japanese, uses the \LaTeX-package japanese, when using this, set the document language to Japanese

Korean (EUC-KR) for Korean

Southern European (ISO 8859-3) (latin 3) covers Esperanto, Galician, Maltese and Turkish

South-Eastern European (ISO 8859-16) (latin 10) covers Albanian, Croatian, Finnish, French, German, Hungarian, Irish Gaelic, Italian, Polish, Romanian and Slovenian, is designed to cover many languages and characters with diacritics

Thai (TIS 620-0) for Thai

Turkish (ISO 8859-9) (latin 5) for Turkish, is like the ISO-859-1 encoding where the Icelandic letters are replaced by Turkish ones

Unicode (CJK) (utf8) Unicode utf8 with the \LaTeX-package CJK (for the languages Chinese, Japanese and Korean)

Unicode (XeTeX) (utf8) Unicode utf8 to be used with Xe\TeX{} and Lua\TeX{}, which use Unicode directly, without the help of the \LaTeX-package inputenc. \LaTeX{} automatically selects this encoding if you export or preview Xe\TeX{} or Lua\TeX{}. Normally you do not need to set this encoding manually.
B. The Document Settings

**Unicode (ucs-extended) (utf8x)**  Unicode utf8 based on the B\TeX-package `ucs` (comprehensive, including Latin, Greek, Cyrillic and CJK scripts).

**Unicode (utf8)**  Unicode utf8 based on the B\TeX-package `inputenc`. Currently only a limited range of characters (mainly for Latin scripts) is supported.

**Western European (CP 1252)**  MS Windows code page for ISO 8859-1 (latin1)

**Western European (ISO 8859-1)**  (latin 1) covers the languages Albanian, Catalan, Danish, Dutch, English, Faroese, Finnish, French, Galician, German, Icelandic, Irish, Italian, Norwegian, Portuguese, Spanish and Swedish; better use the ISO-8859-15 encoding instead

**Western European (ISO 8859-15)**  (latin 9) like the ISO-8859-1 encoding, but with the Euro currency sign, the œ-ligature and some characters used for French and Finnish

### B.10. Colors

Here you can alter the font color for the **Main text** (default: black), for **Greyed out notes** (default: light grey) for the background color for the **Page** (default: white) and for **Shaded boxes** (default: red). The button **Reset** sets the color back to the default.

Clicking any button showing **Default** or **Change** opens a dialog enabling you to choose from a selection of colors or from a color-picker or to specify a color using HSL or RGB values. In the dialog you can add any color to the custom colors to select them later more quickly.

Note, if you change the **Main text** font color and use the option **Color links** in the document settings under **PDF properties**, you probably also need to change the link font color as described in section 6.9.

You can adapt the **Main text** font color and the **Page** background for every page in your document if you use these commands as \TeX Code after a forced page break:

- For the page color:
  \begin{verbatim}
  \pagecolor{color name}
  \end{verbatim}

- For the text color:
  \begin{verbatim}
  \color{color name}
  \end{verbatim}

You are restricted to one of **black**, **blue**, **cyan**, **green**, **magenta**, **red**, **white** or **yellow** for the **color name** unless you have defined your own color (see the section **Colored Tables** of the **Embedded Objects** Manual).

If you have changed a text or background color, you can use the following names to refer to them:

- For the **Page** background color:
  \begin{verbatim}
  page_backgroundcolor
  \end{verbatim}
B.11. Numbering & TOC

Here you can adjust the Numbering depth of section headings and the section depth in the Table of Contents as described in section 3.3.4.3.

B.12. Bibliography

Here you can specify if a citation style using the \LaTeX\ packages \texttt{natbib} or \texttt{jurabib} should be used. You can enable a Sectioned bibliography using the \LaTeX\ package \texttt{bibtopic} and you can select a Processor for the generation of the bibliography. For a further description see section 6.5.

B.13. Indexes

Here you can define the Processor that will generate your index and you can define additional indexes (see section 6.6 for details).

B.14. PDF Properties

The PDF properties are explained in section 6.9.

B.15. Math Options

These options will force \LaTeX{} to use the \LaTeX{} packages \texttt{amsmath}, \texttt{amssymb}, \texttt{cancel}, \texttt{esint}, \texttt{mathdots}, \texttt{mathtools}, \texttt{mhchem}, \texttt{stackrel}, \texttt{stmaryrd} and \texttt{undertilde}, or to use them automatically when they are needed.
B. The Document Settings

\texttt{amsmath} is needed for many constructs, so when you get \LaTeX errors in formulas, ensure that you have this enabled.

\texttt{amssymb} is needed for some special math symbols like bold or upright Greek letters, so when you get \LaTeX errors in formulas, ensure that you have this enabled.

\texttt{cancel} is used for canceled formulas, see section \textit{Canceled Formulas} of the \textit{Math} manual.

\texttt{esint} is used for special integral characters, see section \textit{Big Operators} of the \textit{Math} manual.

\texttt{mathdots} is used for special ellipses, see section \textit{Ellipses} of the \textit{Math} manual.

\texttt{mathtools} is used for the math commands \texttt{\overbracket, \underbracket, \smashoperator, \adjustlimits, \splitfrac, \shortintertext} and labeled arrows, see the corresponding sections in the \textit{Math} manual.

\texttt{mhchem} is used for chemical equations, see section \textit{Chemical Symbols and Equations} of the \textit{Math} manual.

\texttt{stackrel} is used for the math command \texttt{\stackrel}, see section \textit{Relations} of the \textit{Math} manual.

\texttt{stmaryrd} is used for a few special math symbols.

\texttt{undertilde} is used for the math command \texttt{\utilde}, see section \textit{Accents for one Character} of the \textit{Math} manual.

B.16. Float Placement

The float placement options are described in the section \textit{Float Placement} of the \textit{Embedded Objects} manual.

B.17. Listings

The listings settings are explained in the chapter \textit{Program Code Listings} of the \textit{Embedded Objects} manual.

B.18. Bullets

Here you can adjust the characters used for the itemize \texttt{Levels}, specify the \texttt{Font} set to be used and set the \texttt{Size} of the bullets. The itemize environment is described in section 3.3.6.2.
You can furthermore specify a Custom Bullet by inserting in this field the \texttt{\LaTeX} command of the desired character. For example to use the € sign, you have to insert the command \texttt{\texteuro}. For math symbols you additionally need to enclose the command with $ signs. To use e.g. the symbol $\bigcirc$ you need to enter $\circlearrowright$. To find the command for a math symbol, create a formula and hover the mouse over the desired symbol in the math toolbar.

**Note:** Some characters require to load special \LaTeX-packages in the preamble (menu Document$\Rightarrow$Settings$\Rightarrow$\LaTeX Preamble). For example for the € sign one needs to add the line \texttt{\usepackage{textcomp}} to the preamble. For most math symbols it is sufficient to add the line \texttt{\usepackage{amssymb}}.


Branches are described in section 6.8.

## B.20. Formats

Here you can define some output specifics for the current document:

**Default Output Format:** The format that is used when you enter “View”, “Update”, “View Master Document” and “Update Master Document” in the Document menu or the toolbar. The default is set in Tools$\Rightarrow$Preferences$\Rightarrow$File Handling$\Rightarrow$File Formats, see section C.7.2.

**Synchronize with Output** settings for the menu Navigate$\Rightarrow$Forward search. For a detailed description see section Reverse DVI/PDF search of the Additional Features manual.

**XHTML Output Options** offers settings for the export format LyXHTML. Strict XHTML 1.1 will assure that the output follows exactly version 1.1 of the XHTML standard. The different Math output settings are described in detail in section Math Output in XHTML of the Additional Features manual. Math image scaling is used for the size of equations in the output.

**LyX Format** The option Save transient properties controls whether document settings that are frequently switched or that are specific to the user are saved with the document. The properties that are affected by option are currently:

- the activation of change tracking
- the output of tracked changes
- the recording of the document directory path.

Disabling the option can prevent issues in collaborative work and/or when using a version control system (for instance unnecessary merge conflicts).
B. The Document Settings

B.21. LaTeX Preamble

In this text field you can enter commands to load special \TeX-packages or to define \TeX-commands. The preamble is a thing for \TeX-experts. You should not enter commands here until you know exactly what you are doing.

An introduction to the \TeX-syntax is given in section 6.10.2.
C. The Preferences Dialog

The preferences dialog is called with the menu Tools ▶ Preferences. It has the following submenus.

C.1. Look and Feel

C.1.1. User Interface

C.1.1.1. User Interface File

The appearance of the menus and toolbars can be changed by choosing a user interface (ui) file. A ui-file is a text file where the toolbars and menus are listed. The file default.ui loads three files:

stdmenus.inc specifies the menu entries for the standard menus
stdcontext.inc specifies the menu entries in popup context menus
stdtoolbars.inc specifies the toolbar buttons

To create your own menu and toolbar layout, start with a copy of these files and edit the entries.

The syntax of the .inc-files is straightforward: the Menubar, Menu and Toolbar entries must be finished with an explicit End. They may contain Submenu, Item, OptItem, Separator, Icon, and in the case of the “file_lastfiles” menu a Lastfiles entry. The syntax for the entries is:

Item “menu or button name” “LYX function”

All the LYX-functions are listed in the menu Help ▶ LyX Functions.

For example, assuming you use the menu Navigate ▶ Bookmarks quite often and therefore want six available bookmarks, you can add the line

Item “Save Bookmark 6” “bookmark-save 6”

to the “navigate_bookmarks” menu in stdmenus.inc to have the sixth bookmark.

Icon Set allows you to change the appearance of LYX’s toolbar buttons. The currently available icon sets are compared in this image.
C. The Preferences Dialog

C.1.1.2. Context help

The option Enable tool tips in main work area enables tool tips showing the content of closed insets like index entries or footnotes.

C.1.1.3. Menus

Maximum last files is the number of last opened files that \LaTeX{} should display in the menu File ➤ Open Recent.

C.1.2. Document Handling

C.1.2.1. Session handling

With the option Restore window layouts and geometries \LaTeX{}’s main window will be opened with the size and layout that was used in the last \LaTeX{} session.

The option Restore cursor positions sets the cursor to the position in the file where it was at the end of the last session.

The option Load opened files from last session opens all files that were opened in the last \LaTeX{} session.

The button Clear all session information deletes all information from previous \LaTeX{} sessions (cursor positions, names of last opened documents, etc.).

C.1.2.2. Backup & saving

Backup original documents when saving creates a backup copy of the file in the state when it was opened or when it was saved the last time. It is stored in the Backup directory (see section C.3) or in the same folder as your document if no Backup directory is specified. The backup file has the file extension “.lyx~”.

With the option Backup documents, every, you can specify the time between backup saves.

Save documents compressed by default always saves files in a compressed format (see also section A.6.10). This applies to newly created documents only. The compression status of existing documents is not changed when saving.

C.1.2.3. Windows & work area

If the option Open documents in tabs is not checked, every file will be opened in its own new instance of \LaTeX{}.
C.1. Look and Feel

The option **Single instance** is only active if a \texttt{LYXServer} pipe\(^1\) is specified. If it is checked, LYX documents will be opened in the same running instance of LYX. Otherwise a new LYX instance is created for each file.

If the option **Single close-tab button** is checked, there will only be one close button \(\mathbb{X}\) at the right side of the tab bar to close tabs. Otherwise every document tab has its own close button.

**Note:** For this option you have to restart \texttt{LYX} before the change takes effect.

With the setting **Closing last view** you can decide if a document is closed or hidden when its tab or view is closed. Hidden documents are accessible via the menu \texttt{View} $\rightarrow$ Hidden. Not to close documents can be useful if you open files parallel in several instances of LYX and only want to close the view in once instance.

C.1.3. Screen Fonts

These fonts are used to display your documents within \texttt{LYX}.

**Note:** This section only deals with the fonts inside the \texttt{LYX} window. The fonts that appear in the output are independent of these fonts, and set in the menu \texttt{Document} $\rightarrow$ \texttt{Settings} $\rightarrow$ \texttt{Fonts}.

By default, LYX uses \texttt{Times} as its Roman (serif) font, \texttt{Arial} or \texttt{Helvetica} (depends on the system) as its Sans Serif font and \texttt{Courier} as its Typewriter font.

You can change the font size with the \texttt{Zoom} setting.

The Font Sizes are calculated as letter height in units of points. 72.27 points have the size of 1 inch, see Appendix D. The default font sizes are the same as if a document font size of 10 pt were used. The sizes are explained in detail in section 3.7.3.

With the option **Use pixmap cache to speed up font rendering** enabled, \texttt{LYX} needs to redraw the screen less often. This results in better performance, especially on slow systems. On the other hand, the characters might look more fuzzy on screen. So whether you enable this or not depends on whether you prefer speed over aesthetics. Note that the Pixmap Cache is only available and useful under Mac OS and Windows.

C.1.4. Colors

Here you can change the screen colors used by \texttt{LYX} by choosing an item in the list and selecting the \texttt{Alter} button.

By checking the option **Use system colors** the color scheme of your OS or window manager is used. The colors cursor, selection, table line, text, URL label and URL text are then not customizable and thus not listed.

\(^1\)See section C.3 for information about \texttt{LYXServer} pipes.
C. The Preferences Dialog

C.1.5. Display

Here you can specify if graphics are displayed inside LyX.

Instant Preview enables previewing snippets of your document. This feature is described in section 6.12.

Checking the option Mark end of paragraphs displays a pilcrow (¶) at the end of every paragraph.

C.2. Editing

C.2.1. Control

C.2.1.1. Editing

The option Cursor follows scrollbar sets the cursor to the top of the currently displayed document part when scrolling.

You can adjust the width of the cursor. If you set the value to zero, the thickness of the cursor scales relative to the zoom value you choose for the screen fonts.

Scroll below end of document is self-explanatory.

In LyX one can jump from word to word by pressing Ctrl+arrow key. With the option Use Mac-style for cursor moving between words the cursor jumps from the end of a word to the end of the next word. Normally it jumps from the beginning to the beginning.

The option Sort environments alphabetically sorts the entries in the pull-down box for the paragraph environments.

The option Group environments by their category groups the entries in the pull-down box for the paragraph environments.

The Edit math macros options determine the editing style for math macros, see the section Math Macros of the Math manual.

C.2.1.2. Fullscreen

Here you can specify what is hidden in the fullscreen mode. With the option Limit text width you can specify the width of the text in fullscreen mode. This way you can display the text smaller than the screen; the text then appears centered.

C.2.2. Shortcuts

Bind File specifies the file to be used to bind a LyX function to a key. Several binding files are available, among them:
C.2. Editing

cua.bind  a typical set of PC keyboard shortcuts

(x)emacs.bind  a set of bindings similar to those used in the editor programs Emacs (XEmacs)

mac.bind  a set of bindings for MacOS systems.

There are also binding files designed for special document classes, like broadway.bind, and binding files for special languages. The names of language binding files begin with a language code, e.g. “pt” for Portuguese. If you use LYX in a certain language, LYX will try to use the appropriate binding file.

Some binding files, like math.bind, only have a limited scope. When looking at the end of the file cua.bind, you can see that they are included to keep the overview in the bind-file.

The field Show key-bindings containing allows you to search for the shortcut provided for a particular function in the selected key binding file.

C.2.2.1. Editing Shortcuts

To add new or modify existing keybindings to your own taste you can use the table in the dialog that lists all LYX functions and the bound shortcuts. To find functions easily, they are grouped by categories and the dialog provides the field Show key-bindings containing. In this field you can insert a keyword for a function you want to edit. Insert there for example as keyword “paste” and you get the four different existing shortcuts for the three different functions that contain “paste” in their name.

As you can see, one function can have more than one shortcut. All LYX functions are also listed in the file LYX Functions that you will find in the Help menu.

For example, to add the shortcut Alt+Q for the function textstyle-apply, select the function and press the Modify button. A dialog pops up where you can add the shortcut by using it. So press Alt+Q to define the shortcut.

Modifying an existing shortcut is done the same way. You can also bind multiple functions to one shortcut by starting the LYX Function definition with “command alternatives” and following it with the different function names as a semicolon separated list. LYX will then use the first function that is enabled in the current document part.

If you don’t like a particular shortcut, you can remove it.

Alternatively you can also edit shortcuts by modifying binding files with a text editor. The syntax of the entries is:

\bind “key combination” “LYX function”
C. The Preferences Dialog

C.2.3. Keyboard/Mouse

Normally keyboard settings are made in a menu of your operating system. For the case that this is not possible, \LaTeX provides keyboard maps. If, for example, you have a Czech keyboard but want to use it as if it is a Romanian one, you can enable Use keyboard map and select the keyboard map file named `romanian.kmap`.

You can specify a First and a Second keyboard map and, if you use the cua bindings, you can select the first and second with `Alt+K 1` and `Alt+K 2` respectively or toggle between them with `Alt+K T`.

**Note:** Keyboard maps can only provide a makeshift solution and don’t work on all systems.

You can also specify the mouse Wheel scrolling speed. The standard value is 1.0; higher values speed up the scrolling, lower ones slow it down. With the option Middle mouse button pasting you can determine if pressing the middle mouse button (or the mouse wheel) inserts the content of the clipboard.

If you Enable Scroll wheel zoom, you can select a key for zooming. When this key is pressed and the mouse wheel is rotated, the text is zoomed.

C.2.4. Input Completion

Input completion is described in section 2.6.

C.3. Paths

The paths to the various resources used by \LaTeX are normally determined during the installation. But there may be reasons why you might want to modify them.

**Working directory** This is \LaTeX’s working directory. It is the default when you Open, Save or Save As files.

**Document templates** This directory will be opened when you use the menu File $\rightarrow$ New from Template.

**Example files** This directory will be opened when you use the button Examples in the File $\rightarrow$ Open dialog.

**Note:** The Examples button does not exist when using \LaTeX on Mac OS and Windows systems.

**Backup directory** Backup copies will be saved to this directory. If no directory is given but backups are enabled as described in section C.1.2.2, the Working directory will be used to save the backups.

Backup files have the ending “.lyx~”.

152
C.3. Paths

LyXServer pipe  Here you can enter the name of a so-called UNIX-pipe. This pipe is used to send data from external programs to LyX.

Example: You add a BibTeX database `test.bib` to your document. You can edit this file with the program JabRef. In JabRef you have to use the same Unix-Pipe for LyX in its preferences under External programs. If you want to get one entry of the database as citation, select it in JabRef and click on the LyX symbol. The entry will now be inserted as a citation at the current cursor position in your LyX file. Of course, JabRef and LyX need to be running the same time.

The pipe is also used for the Single instance feature, see section C.1.2.2.

To use the LyXServer-Pipe on Windows, you must use this pipe name:\\\pipe\lyxpipe

Temporary directory  Temporary files will be saved in this directory.

Thesaurus dictionary  Directory where the thesaurus dictionaries are located. You only need to specify it if the thesaurus does not work or if you want to use custom/alternative dictionaries.

Hunspell dictionary  Directory where the dictionaries of the spell checker program Hunspell are located. You only need to specify it if you are using Hunspell and spell checking does not work or if you want to use custom/alternative dictionaries. For LyX on Windows Hunspell is the only available spell checker and should work without specifying a directory.

PATH prefix  This field contains a list of paths to external programs. When LyX needs to use an external program, it looks in this list to see where to find it on the system. The path list is automatically set up on Windows and Mac systems when LyX is configured; so you normally don’t have to modify it. On Unix/Linux systems, the path list will need to be set only if there are external programs you wish to use that are not in your normal system path ($PATH).

TEXINPUTS prefix  The TEXINPUTS environment variable allows you to use external files which are included in a LyX document via commands in TeX code or in the document preamble. This prefix includes by default the document directory (represented by a single dot ‘.’). The prefix can contain any list of paths separated by the default separator of the OS (‘:’ on UNIX like systems and ‘;’ on Windows). If files are included, the paths listed in the TEXINPUTS prefix will be scanned for the input files. Note that any non-absolute path listed in the TEXINPUTS prefix is considered to be relative to the directory of your LyX file. It is recommended that you always include ’.’ as one of the paths; otherwise compilation may fail for some documents.
C. The Preferences Dialog

C.4. Identity

Here you can insert your Name and E-mail address. These will be used when you have enabled change tracking, as described in section 6.16, to mark changes you make as yours.

C.5. Language Settings

C.5.1. Language

User interface language Here you can select the language for LYX’s menus. You can find its actual translation status here: http://www.lyx.org/I18n

Language package determines which \LaTeX package should be loaded to handle language issues. Language issues that are handled by this package include proper hyphenation as well as localization of dates and text strings such as “Chapter” and “Table”. The most widespread language package is babel; it is the default language package in classic \LaTeX. More recent typesetting engines such as Xe\LaTeX and Lua\LaTeX come with the alternative language package polyglossia that is more suited to the multi-script support of these engines. Furthermore, there are also specific language packages for languages not covered by babel. The available selections are described in section B.9.

Command start If a special \LaTeX-package is needed to write in a certain document language, you can here specify the command to start the package. An example is the start command \begin{arabtext} that is needed to write Arabic using the package Arab\TeX, see [20]. The default is the babel command \selectlanguage{$$lang}.

Command end Counterpart to Command start. Some packages, like the default, don’t have an end command since the start command toggles the package on and off.

Default decimal separator Defines the default decimal point for use in tables (decimal point alignment).

Default length unit Defines the unit that is used as default for lengths in LYX’s dialogs.

Set languages globally When this option is set, the languages used in the document will be added as options to the document class options, so that they can be used by all \LaTeX-packages. Otherwise they will only be used as options for the babel package.

Auto begin When this option is set, documents start with the chosen document language. When this option is not set, the Command start is explicitly set to
the beginning of the document in the \LaTeX-output. This assures that the correct language is used when you use another Command start than the default.

**Auto end** Counterpart to Auto begin. When it is not set, the Command end is set to the end of the document.

**Mark foreign languages** Text marked formatted in a language different from the document language will be underlined in blue.

**Enable RTL support** Enables the use of languages, written from right to left (RTL), like Arabic, Hebrew or Farsi.

**Cursor movement** When writing RTL, you can define if the left and right arrow keys move the cursor visually to the left or right, respectively, or logically. Logical means that the cursor is moved to the left when pressing the right arrow key and the cursor is inside text in an RTL language.

### C.5.2. Spellchecker

The spellchecker settings are explained in section 6.14.

### C.6. Outputs

#### C.6.1. General

**Forward search** Commands that will be used for the menu Navigate$\rightarrow$Forward search. For a detailed description see section Reverse DVI/PDF search of the Additional Features manual.

**Dvips Options** Options for the program dvips that is used for the export format Postscript, see section A.1.13. Possible options are listed in the dvips manual: https://www.tug.org/texinfohtml/dvips.html#Option-details

**Output line length** sets the maximum number of characters printed in one line when using the menu File$\rightarrow$Export$\rightarrow$Plain text. Setting the line length to 0 means all text is printed in one endless line.

**Date format** The date format can be one or a mixture of the formats listed here: http://man7.org/linux/man-pages/man1/date.1.html For example the format %d/%m/%y prints the date as day/month/year.

**Overwrite on export** Setting what LyX is allowed to overwrite on export.
C.6.2. LaTeX

**Use LaTeX font encoding** This is the default encoding of the document font. **T1** is the default and covers western languages and symbols. **T2A, T2B, T2C, LCY** and **X2** are used for Cyrillic. Combinations of the encodings are possible, like “T1, T2B”. The font encoding is normally automatically loaded by the language packages LyX sets up in the background. So there is no need to change the default encoding.

**DVI viewer paper size options** They only have an effect when the program xdvi is used as DVI-viewer, read its manual to find out more.

Here you can also specify options and commands with parameters for processors. But before you change something, it is strongly recommended to read the manuals of the applications.

**Bibliography generation** Settings for the generation of the bibliography, see section 6.5.2.

**Index generation** Settings for the generation of the index, see section 6.6.6.

**Nomenclature command** Command for the program that generates the nomenclature, see section 6.7.5.

**CheckTeX command** Command for the program CheckTeX that is described in the section *Checking TeX* of the *Additional Features* manual.

There are additionally the following options:

**Use Windows-style paths in LaTeX files** Uses paths in the notation of Windows, that means that “\” is used instead of “/” to separate folders. This option is enabled by default when you use LyX on Windows.

**Reset class options when document class changes** Removes all manually set Class options in the Document>Settings>Document Class dialog when changing the document class.

C.7. File Handling

C.7.1. Converters

Here you find the list of defined converter commands to convert material from one format to another. You can modify converters or create new ones. To modify a converter, select it, change the entry of the **Converter** and/or **Extra flag** field and press the **Modify** button. To create a new converter, select an existing one, select a different format in the **To format** drop-down list, modify the **Converter** field and press the **Add** button.
If the Converter File Cache is Enabled, conversions will be cached as long as specified in the field Maximum Age (in days). This means that images don’t need to be converted again when you reopen a document; the converted images from the cache will be used instead.

More about converters, like the flags that can be used in the converter definition, is described in the section Converters of the Customization manual.

C.7.2. File Formats

Here you find the list of defined file formats that LYX can handle. You can modify the Editor and Viewer programs that should be used for certain formats.

You can also define the Default output format that is used when you use View, Update, View Master Document or Update Master Document in the Document menu or the toolbar.

More about formats and their options is described in the section Formats of the Customization manual.

Since all conversions from one format to another take place in LYX’s temporary directory, it is sometimes necessary to modify a file before copying it to the temporary directory so that the conversion may be performed. This is done by specifying a Copier. More about this is described in the section Copiers of the Customization manual.
## D. Units available in LyX

Table D.1 explains all the units available in LyX and used in this documentation.

<table>
<thead>
<tr>
<th>unit</th>
<th>name/description</th>
<th>\LaTeX{} command</th>
</tr>
</thead>
<tbody>
<tr>
<td>mm</td>
<td>millimeter</td>
<td>-</td>
</tr>
<tr>
<td>cm</td>
<td>centimeter</td>
<td>-</td>
</tr>
<tr>
<td>in</td>
<td>inch</td>
<td>-</td>
</tr>
<tr>
<td>pt</td>
<td>point (72.27 pt = 1 in)</td>
<td>-</td>
</tr>
<tr>
<td>pc</td>
<td>pica (1 pc = 12 pt)</td>
<td>-</td>
</tr>
<tr>
<td>sp</td>
<td>scaled point (65536 sp = 1 pt)</td>
<td>-</td>
</tr>
<tr>
<td>bp</td>
<td>big point (72 bp = 1 in)</td>
<td>-</td>
</tr>
<tr>
<td>dd</td>
<td>didot (1 dd ≈ 0.376 mm)</td>
<td>-</td>
</tr>
<tr>
<td>cc</td>
<td>cicero (1 cc = 12 dd)</td>
<td>-</td>
</tr>
<tr>
<td>Scale Graphics %</td>
<td>% of original image width</td>
<td></td>
</tr>
<tr>
<td>Text Width %</td>
<td>% of text width</td>
<td>\textwidth</td>
</tr>
<tr>
<td>Column Width %</td>
<td>% of column width</td>
<td>\columnwidth</td>
</tr>
<tr>
<td>Page Width %</td>
<td>% of paper width</td>
<td>\paperwidth</td>
</tr>
<tr>
<td>Line Width %</td>
<td>% of line width</td>
<td>\linewidth</td>
</tr>
<tr>
<td>Text Height %</td>
<td>% of text height</td>
<td>\textheight</td>
</tr>
<tr>
<td>Page Height %</td>
<td>% of paper height</td>
<td>\paperheight</td>
</tr>
<tr>
<td>ex</td>
<td>height of letter $x$ in current font</td>
<td>-</td>
</tr>
<tr>
<td>em</td>
<td>width of letter $M$ in current font</td>
<td>-</td>
</tr>
<tr>
<td>mu</td>
<td>math unit (1 mu = 1/18 em)</td>
<td>-</td>
</tr>
</tbody>
</table>
E. Credits

The documentation is a collaborative effort between many different people (and we would encourage people to contribute!).

- Alejandro Aguilar Sierra
- Amir Karger
- David Johnson
- Hartmut Haase
- Ignacio García
- Ivan Schreter
- John Raithel
- John Weiss
- Lars Gullik Bjønnes
- Matthias Ettrich
- Matthias Zenker
- Rich Fields
- Pascal André
- Paul Evans
- Paul Russel
- Robin Socha
- Uwe Stöhr
- The \LaTeX{} Team: [Credits]
E. Credits

The bibliography on the following page was created with the Bibliography environment.
Bibliography

[Credits] The L\LaTeX{} Team: Credits:
\url{http://www.lyx.org/Credits}


[5] The \TeX{} Catalogue:
\url{http://mirrors.ctan.org/help/Catalogue/bytopic.html}

[6] The \LaTeX{} FAQ:
\url{http://www.tex.ac.uk/faq/}

[7] Documentation of the program \BibTeX{}:
\url{http://mirrors.ctan.org/biblio/bibtex/contrib/doc/btxdoc.pdf}

[8] Documentation how to use the program \BibTeX{}:
\url{http://www.ctan.org/tex-archive/info/bibtex/tamethebeast/ttb_en.pdf}

[9] Documentation of the program \makeindex{}:
\url{http://mirrors.ctan.org/indexing/makeindex/doc/makeindex.pdf}

[10] Options for the program \makeindex{}:
\url{http://mirrors.ctan.org/indexing/makeindex/doc/manpages.dvi}

[11] Documentation of the program \xindy{}:
\url{http://www.xindy.org/documentation.html}

[12] Documentation of the AMS \LaTeX{}-packages:
\url{http://www.ams.org/publications/authors/latex/amslatex}

[13] Documentation of the \LaTeX{}-package \texttt{caption}:
\url{http://mirrors.ctan.org/macros/latex/contrib/caption/caption-eng.pdf}

[14] Documentation of the \LaTeX{}-package \texttt{enumitem}:
\url{http://mirrors.ctan.org/macros/latex/contrib/enumitem/enumitem.pdf}
Bibliography

[15] Documentation of the \LaTeX-package **fancyhdr**:
http://mirrors.ctan.org/macros/latex/contrib/fancyhdr/fancyhdr.pdf

[16] Documentation of the \LaTeX-package **hyperref**:
http://www.ctan.org/pkg/hyperref

[17] Documentation of the \LaTeX-package **nomencl**:

[18] Documentation of the \LaTeX-package **prettyref**:

[19] Documentation of the \LaTeX-package **refstyle**:

[20] Wiki-page how to set up LyX for Arabic:
http://wiki.lyx.org/Windows/Arabic

[21] Wiki-page how to set up LyX for Armenian:
http://wiki.lyx.org/Windows/Armenian

[22] Wiki-page how to set up LyX for Cyrillic languages:
http://wiki.lyx.org/Windows/Cyrillic

[23] Wiki-page how to set up LyX for Farsi:
http://wiki.lyx.org/Windows/Farsi

[24] Wiki-page how to set up LyX for Hebrew:
http://wiki.lyx.org/Windows/Hebrew

[25] Wiki-page how to set up LyX for Japanese:
http://wiki.lyx.org/Windows/Japanese

[26] Wiki-page how to set up LyX for Latvian:
http://wiki.lyx.org/Windows/Latvian

[27] Wiki-page how to set up LyX for Lithuanian:
http://wiki.lyx.org/Windows/Lithuanian

[28] Wiki-page how to set up LyX for Mongolian:
http://wiki.lyx.org/Windows/Mongolian

[29] Wiki-page how to set up LyX for Vietnamese:
http://wiki.lyx.org/Windows/Vietnamese

[30] Wiki-page about new features in LyX 2.0:
http://wiki.lyx.org/LyX/NewInLyX20
Bibliography 2

[FW] FENN, Jürgen ; WILLIAMS, Graham. The TeX Catalogue.

Addison-Wesley, 2003


Addison-Wesley, 2004

The above bibliography is created from a BibTEX database.
Nomenclature

@, |, !, "  The quote sign is output by writing ‘"’, page 98
a  dummy entry for the character a, page 98
Alt  Alt or Meta key, page 9
Ctrl  Control key, page 9
Esc  Escape key, page 9
Shift  Shift key, page 9
Tab  Tabulator key, page 9
σ  dummy entry for the character sigma, page 98
Index

A
Abstracts, 30
AMS math, 86
Appendix, 90

B
Backup
   Directory, 152
   Documents, 148
Bibliography, 31, 91
   BibTeX, 91
   Citation format, 93
   Databases, 91
Boxes, 127
Branches, 100

C
Captions, 127
Change Tracking, 114
Character count, 132
Character Styles, 52
ChkTEX, 133
Color
   background, 142
   Change tracking, 114
   Greyed-out notes, 142
   LATEX screen, 149
   main text, 142
   Shaded boxes, 142
   Text, 53
Compare, 133
Comparison of documents, 115
Converters, 156
Copiers, 157
Copy, 4

Cross references, 87
Customization
   of menus, 147
   of toolbars, 147
Cut, 4

D
Dashes, 59
Date Format, 155
Document
   Branches, 100
   Change Tracking, 114
   Classes, 11
   Font, 49
   Header/Footer line, 104
   Language, 116
   Layout, 15
   Local Layout, 14
   Margins, 16
   Modules, 13
   Paper size, 15
   Preview, 59, 107
   Settings, 11, 13, 15–17, 20, 24, 45,
      49, 51, 62, 86, 93, 116, 137
   Title, 18
   Types, 11
Dummy entries
   maison, 95
   maître, 95
   This is an italic dummy entry, 95

E
Editing, 4
External Material, 127
Index

F
File formats, 56, 157
  ASCII, 56
  DVI, 57
  \LaTeX, 57
  PDF, 58
  PostScript, 57
File handling, 156
File Operations, 3
FileFormats
  XHTML, 59
Find, 4, 108
Floats, 72
  Captions, 73
  Details, 74
  Figure floats, 73
  Table floats, 74
Font
  Screen, 149
  Size, 49
  Types, 47
Fonts
  Bitmap-, 48
  Vector-, 48
Footnotes, 65
G
Graphics, 66
H
Header/Footer line, 104
Horizontal lines, 47
HTML, 59
Hyperlinks, 90
Hyphenation, 60
Hyphens, 59
I
Images, 66
  Formats, 67
  Settings grouping, 68
Index
  Cross referencing, 94
  Entry layout, 95
  Entry order, 94
  Grouping, 93
  Page ranges, 94
  Program, 96
  Index generation, 93
  Input completion, 8
  Instant preview, 107
  International support, 116
K
Key Bindings, 8, 150
  Editing, 151
  Keyboard Map, 152
L
Language
  Encoding, 139
  Options, 116
  Phonetic symbols, 125
  Settings, 154
\LaTeX Syntax, 103
\LaTeX-packages
  aeguill, 50
  amsmath, 143
  amssymb, 143
  babel, 60, 140, 154
  bibtopic, 143
  cancel, 143
  caption, 103, 163
  CJK, 51, 141
  dvipost, 115
  enumitem, 26, 28, 29, 163
  esint, 143
  fancyhdr, 15, 106, 164
  fontenc, 51
  hyperref, 101, 164
  inputenc, 140, 142
  japanese, 141
  jurabib, 143
  mathtools, 143
  mhchem, 143
  natbib, 143
  nomencl, 97, 164
  polyglossia, 140, 154
prettyref, 88, 138, 164
preview-latex, 107
pstricks, 57
refstyle, 88, 138, 164
setspace, 17
splitidx, 96
stackrel, 143
stmaryrd, 143
tipa, 125
ucs, 142
undertilde, 143
Letters, 29
Line breaks, 47
Lists, 22
  Customization, 28
  Customized, 26
  Description, 25
  Enumerate, 24
    Custom, 26
    Resumed, 27
  Itemize, 23
  Labeling, 25
  Spacing, 28
LyX
  Basics, 11
    Proper names, 62
LyX-Code, 31
M
Marginal notes, 66
Margins, 16
Math, 77
  Accents, 80
  AMS, 86
  Arrays, 82
  Basics, 77
  Brackets, 81
  Delimiters, 81
  Exponents, 78
  Font sizes, 85
  Formula numbering, 83
  Fractions, 78
  Functions, 80
  Integrals, 79
  Limits, 79
  Macros, 84
  Matrices, 82
  Multi-line Equations, 82, 86
  Navigating, 77
  Referencing formulas, 83
  Roots, 79
  Spaces, 80
  Subscripts, 78
  Sums, 79
  Symbols, 79
  Text, 85
  Typefaces, 84
Menu
  Document, 130
  Edit, 121
  File, 117
  Help, 133
  Insert, 124
  Navigate, 129
  Tools, 132
  View, 123
Minipages, 75
Mouse Operations, 5
Multi-page tables, 69
N
Navigating, 6
  Horizontal Scrolling, 7
  Outline, 6, 89
Nesting
  Environments, 33
  Examples, 37
  Separation, 41
  Tables etc., 35
Nomenclature, 97
  Layout, 97
  Options, 98
  Printing, 99
  Program, 99
  Sort order, 98
Notes, 65
O
Outline, 6, 89
Index

P
Page breaks
  Clear, 46
  Forced, 46
Paragraph
  Alignment, 45
  Environments, 17
  Indentation, 16
  Line spacing, 17
  Separation, 17
  Settings, 122
  Verse, 22
Paragraph environments, 17–32
Paste, 4
Paths, 152, 156
PDF, 58, 67
PDF properties, 101
Phonetic symbols, 125
Poetry, 22
Preferences, 2, 147
Program listings, 129
Punctuation marks, 61

Q
Quotation, 21

R
Reconfiguration of \LaTeX, 2, 14, 121, 131, 133
Redo, 5
Replace, 4, 108

S
Section headings, 19
  Numbered, 19
  Short titles, 20
  Unnumbered, 20
Settings
  Color, 149
  Date format, 155
  Display, 150
  Editing, 150
  Keyboard Map, 152
  Language, 154
  \LaTeX, 156
  Paths, 152, 156
  Shortcuts, 150
Spaces
  Inter-word, 42
  inter-word, 61
  Protected, 42
  Thin, 42
  thin, 61
Spacing, 42
  Fills, 44, 45
  Horizontal, 42
  Phantom, 44
  Vertical, 45
Spell checking, 111

T
Table of contents, 89
Tables, 68
  Cells, 72
  Multi-page, 69
  Caption, 127
\TeX Code, 102
\TeX Information, 133
Text Style, 52
Thesaurus, 113
Toolbar, 124
  Extra, 135
  Macro, 136
  Review, 114
  Standard, 134
  Table, 136
  View / Update, 136
Typography, 59
  Ligatures, 62
  Quotes, 62
  Units, 63
  Widows and orphans, 63

U
Undo, 5
Units, 159
URLs, 90

V
Verbatim, 32

172
W
Word count, 132